dev-python/rarfile: Bump to EAPI=7
authorSam James (sam_c) <sam@cmpct.info>
Thu, 14 May 2020 12:52:33 +0000 (12:52 +0000)
committerIan Whyman <thev00d00@gentoo.org>
Sat, 23 May 2020 09:56:19 +0000 (10:56 +0100)
* EAPI 7
* Adds Python 3.7, 3.8, PyPy 3
* Enables tests

Package-Manager: Portage-2.3.99, Repoman-2.3.22
Signed-off-by: Sam James (sam_c) <sam@cmpct.info>
Closes: https://github.com/gentoo/gentoo/pull/15794
Closes: https://bugs.gentoo.org/719520
Signed-off-by: Ian Whyman <thev00d00@gentoo.org>
dev-python/rarfile/rarfile-3.0-r1.ebuild [new file with mode: 0644]

diff --git a/dev-python/rarfile/rarfile-3.0-r1.ebuild b/dev-python/rarfile/rarfile-3.0-r1.ebuild
new file mode 100644 (file)
index 0000000..3b2be61
--- /dev/null
@@ -0,0 +1,20 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} pypy3 )
+inherit distutils-r1
+
+DESCRIPTION="Module for RAR archive reading"
+HOMEPAGE="https://github.com/markokr/rarfile"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+compressed"
+
+RDEPEND="compressed? ( || ( app-arch/unrar app-arch/rar ) )"
+
+distutils_enable_tests nose