xfce-extra/xfce4-notifyd: Bump to 0.6.0
authorMichał Górny <mgorny@gentoo.org>
Wed, 8 Apr 2020 17:51:31 +0000 (19:51 +0200)
committerMichał Górny <mgorny@gentoo.org>
Wed, 8 Apr 2020 17:57:51 +0000 (19:57 +0200)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
xfce-extra/xfce4-notifyd/Manifest
xfce-extra/xfce4-notifyd/xfce4-notifyd-0.6.0.ebuild [new file with mode: 0644]

index e269d81dd1f202841d3da074d18e0e717d86be21..6764c2d89e8dc53a6e6eb3c0177708b6578aaeca 100644 (file)
@@ -1 +1,2 @@
 DIST xfce4-notifyd-0.4.4-r1.tar.bz2 536304 BLAKE2B bde62a773f7a702338e07fad8483d57576edb4c046b709c8644c17697ea73b72e46b8b4e2737d02bf23a554cbcac7c9725d7f19ee9f1ea511efb0943280f1b60 SHA512 546a5063673e36ef26bcdac624bfcef41a14918dbb496fb3d282613334f173b51669184b6bcfbee0f07a17863620898be2f464e487ca9755abe7285d6a43d8d5
+DIST xfce4-notifyd-0.6.0-r1.tar.bz2 539371 BLAKE2B aed910e3a547b29b2efb96ec5b5ab03bc3b73269dc7928018be194025d46abaa18bc2d0a879cd797b18167717b2a1f354f1a49f64e9bfc77dd2be51e06090978 SHA512 31f7977cb4639c90d806e8eaa94c00c19bacf1c9d5df2bc1d66ed791e446ed0ecf6bc59ec402994b1eeab5432dc20cffe67fbb267e86b1848fc2206aa4eaf10c
diff --git a/xfce-extra/xfce4-notifyd/xfce4-notifyd-0.6.0.ebuild b/xfce-extra/xfce4-notifyd/xfce4-notifyd-0.6.0.ebuild
new file mode 100644 (file)
index 0000000..6d76841
--- /dev/null
@@ -0,0 +1,41 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit xdg-utils
+
+DESCRIPTION="Notification daemon for the Xfce desktop environment"
+HOMEPAGE="https://goodies.xfce.org/projects/applications/xfce4-notifyd"
+SRC_URI="https://archive.xfce.org/src/apps/${PN}/${PV%.*}/${P}.tar.bz2 -> ${P}-r1.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-libs/glib-2.42:2=
+       >=x11-libs/gtk+-3.14:3=
+       >=x11-libs/libnotify-0.7:=
+       >=xfce-base/libxfce4ui-4.12:=[gtk3(+)]
+       >=xfce-base/libxfce4util-4.12:=
+       >=xfce-base/xfce4-panel-4.12:=
+       >=xfce-base/xfconf-4.10:="
+DEPEND="${RDEPEND}
+       dev-util/gdbus-codegen
+       dev-util/intltool
+       sys-devel/gettext
+       virtual/pkgconfig"
+
+src_install() {
+       default
+       find "${D}" -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+       xdg_icon_cache_update
+}
+
+pkg_postrm() {
+       xdg_icon_cache_update
+}