dev-python/setuptools_scm: splitting out test deps into use flags
authorMatthew Thode <prometheanfire@gentoo.org>
Tue, 13 Feb 2018 21:25:18 +0000 (15:25 -0600)
committerMatthew Thode <prometheanfire@gentoo.org>
Tue, 13 Feb 2018 22:03:38 +0000 (16:03 -0600)
Package-Manager: Portage-2.3.19, Repoman-2.3.6

dev-python/setuptools_scm/metadata.xml
dev-python/setuptools_scm/setuptools_scm-1.15.6-r1.ebuild [new file with mode: 0644]

index 3aabcf57991867fb2c6926766fad8879046ecf70..36c2a8fbd06edf3365d4cc9693157f666c33ac45 100644 (file)
@@ -10,4 +10,7 @@
                <remote-id type="bitbucket">pypa/setuptools_scm</remote-id>
                <remote-id type="github">pypa/setuptools_scm</remote-id>
        </upstream>
+       <use>
+               <flag name="mercurial">Enables mercurial backend</flag>
+       </use>
 </pkgmetadata>
diff --git a/dev-python/setuptools_scm/setuptools_scm-1.15.6-r1.ebuild b/dev-python/setuptools_scm/setuptools_scm-1.15.6-r1.ebuild
new file mode 100644 (file)
index 0000000..006c5a9
--- /dev/null
@@ -0,0 +1,39 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="package to manage versions by scm tags via setuptools"
+HOMEPAGE="https://github.com/pypa/setuptools_scm https://pypi.python.org/pypi/setuptools_scm"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos ~x86-macos"
+IUSE="git mercurial test"
+
+DEPEND="
+       dev-python/setuptools[${PYTHON_USEDEP}]
+       git? ( dev-vcs/git )
+       mercurial? ( dev-vcs/mercurial )
+       test? (
+               dev-python/pytest[${PYTHON_USEDEP}]
+       )"
+
+python_test() {
+       distutils_install_for_testing
+       py.test -v -v -x -k testing/test_basic_api.py || die "tests failed under ${EPYTHON}"
+       py.test -v -v -x -k testing/test_functions.py || die "tests failed under ${EPYTHON}"
+       py.test -v -v -x -k testing/test_main.py || die "tests failed under ${EPYTHON}"
+       py.test -v -v -x -k testing/test_regressions.py || die "tests failed under ${EPYTHON}"
+       if use git; then
+               py.test -v -v -x -k testing/test_git.py || die "tests failed under ${EPYTHON}"
+       fi
+       if use mercurial; then
+               py.test -v -v -x -k testing/test_mercurial.py || die "tests failed under ${EPYTHON}"
+       fi
+}