dev-python/mox3: cleanup
authorMatthew Thode <prometheanfire@gentoo.org>
Sun, 27 Jan 2019 23:51:28 +0000 (17:51 -0600)
committerMatthew Thode <prometheanfire@gentoo.org>
Mon, 28 Jan 2019 00:25:33 +0000 (18:25 -0600)
Package-Manager: Portage-2.3.51, Repoman-2.3.12
Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
dev-python/mox3/Manifest
dev-python/mox3/mox3-0.10.0.ebuild [deleted file]
dev-python/mox3/mox3-0.12.0.ebuild [deleted file]

index dbd6b0459d7f8c467bdfca021a1dab6e214f1d38..54506f3d103c310418a5bf3986c5de50ab11b272 100644 (file)
@@ -1,3 +1 @@
-DIST mox3-0.10.0.tar.gz 42424 BLAKE2B 124bb4525ed6d24ebf75037c1f049fc851d64bdf8eed29c26fcdabcfe5f6211aec7f16f5038b397978383bd11a81588b44aa790608bfdf5b8596daccf3230542 SHA512 1f56e17ae150339cb2f33dca065c246cf0ff2f633f182336a576e9ab0bd4512ec8f42a4cb128f38ede33fe7e796552768465cfc626abe4f734b7a06b4625710a
-DIST mox3-0.12.0.tar.gz 42377 BLAKE2B d6a841c8b28d47f21ae8e6f65abb7e2079762d45ccf670decf5815c5a2638af615804e711534ddb0ebbafdae6609f30e50ea20f224a7ccc5a02148f1ab0d23b6 SHA512 73e0215bf127589f791721a0cb9b8e3dcc379a23199339e370d641850a0a14c264eb9db94fbb37c99f9925ee3ebd302de14ec12fe1c8809dd3ca9c10cfd75468
 DIST mox3-0.24.0.tar.gz 44846 BLAKE2B dd1a27b20fc821de79f1e1f209872c3fb66f39b2330d1dda04c5b17045e337c84920e4538d7971f025d1377f9e91abd2fca8167508c5614fee06d9fca92aaa75 SHA512 6c081cf2b1e529f3213f7f48d22ed5d2980420b2de8f49607b624d5861f8b784f2f36d8a32fae3e81fe8186c1a9c36e6c4ec7d9de172c41c0530523590ef97b6
diff --git a/dev-python/mox3/mox3-0.10.0.ebuild b/dev-python/mox3/mox3-0.10.0.ebuild
deleted file mode 100644 (file)
index 0d53ced..0000000
+++ /dev/null
@@ -1,73 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
-DISTUTILS_IN_SOURCE_BUILD=TRUE
-
-inherit distutils-r1
-
-DESCRIPTION="Mock object framework for Python"
-HOMEPAGE="http://www.openstack.org/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE="test"
-
-CDEPEND="
-       >=dev-python/pbr-1.8[${PYTHON_USEDEP}]
-       <dev-python/pbr-2.0[${PYTHON_USEDEP}]
-"
-CRDEPEND=">=dev-python/fixtures-1.3.1[${PYTHON_USEDEP}]"
-
-# NOTE dev-python/hacking isn't actually required for tests
-# >=dev-python/hacking-0.5.6[${PYTHON_USEDEP}]
-# <dev-python/hacking-0.7[${PYTHON_USEDEP}]
-
-# NOTE dev-python/pyflakes isn't actually required for tests
-# ~dev-python/pyflakes-0.7.2[${PYTHON_USEDEP}]
-
-DEPEND="
-       dev-python/setuptools[${PYTHON_USEDEP}]
-       ${CDEPEND}
-       test? (
-               ${CRDEPEND}
-               ~dev-python/pep8-1.5.7[${PYTHON_USEDEP}]
-               ~dev-python/pyflakes-0.8.1[${PYTHON_USEDEP}]
-               >=dev-python/flake8-2.2.4[${PYTHON_USEDEP}]
-               <=dev-python/flake8-2.4.1-r9999[${PYTHON_USEDEP}]
-               >=dev-python/coverage-3.6[${PYTHON_USEDEP}]
-               >=dev-python/subunit-0.0.18[${PYTHON_USEDEP}]
-               >=dev-python/testrepository-0.0.18[${PYTHON_USEDEP}]
-               >=dev-python/testtools-1.4.0[${PYTHON_USEDEP}]
-               >=dev-python/six-1.9.0[${PYTHON_USEDEP}]
-               >=dev-python/sphinx-1.1.2[${PYTHON_USEDEP}]
-               !~dev-python/sphinx-1.2.0[${PYTHON_USEDEP}]
-               <dev-python/sphinx-1.3[${PYTHON_USEDEP}]
-               >=dev-python/oslo-sphinx-2.5.0[${PYTHON_USEDEP}]
-       )
-"
-RDEPEND="
-       ${CDEPEND}
-       ${CRDEPEND}
-"
-
-python_test() {
-       # This single test fails on python3.4.
-       # I speculate this is due to the old style classes going away but have not
-       # verified this in any way.
-       if [[ "${EPYTHON}" = "python3.4" ]]; then
-               ebegin "patching mox3/tests/test_mox.py for ${EPYTHON}"
-               sed \
-                       -e '/def testStubOutClass_OldStyle(self):/,/def/ d' \
-                       -i mox3/tests/test_mox.py
-               STATUS=$?
-               eend $?
-               [[ ${STATUS} -gt 0 ]] && die
-       fi
-
-       testr init || die "testr init failed under ${EPYTHON}"
-       testr run || die "testr run failed under ${EPYTHON}"
-}
diff --git a/dev-python/mox3/mox3-0.12.0.ebuild b/dev-python/mox3/mox3-0.12.0.ebuild
deleted file mode 100644 (file)
index d34633d..0000000
+++ /dev/null
@@ -1,59 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
-
-inherit distutils-r1
-
-DESCRIPTION="Mock object framework for Python"
-HOMEPAGE="http://www.openstack.org/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64 ~arm64 ~x86"
-IUSE="doc test"
-
-CDEPEND=">=dev-python/pbr-1.8[${PYTHON_USEDEP}]"
-CRDEPEND=">=dev-python/fixtures-1.3.1[${PYTHON_USEDEP}]"
-DEPEND="
-       dev-python/setuptools[${PYTHON_USEDEP}]
-       ${CDEPEND}
-       test? (
-               ${CRDEPEND}
-               >=dev-python/six-1.9.0[${PYTHON_USEDEP}]
-               >=dev-python/subunit-0.0.18[${PYTHON_USEDEP}]
-               >=dev-python/testrepository-0.0.18[${PYTHON_USEDEP}]
-               >=dev-python/testtools-1.4.0[${PYTHON_USEDEP}]
-       )
-       doc? (
-               >=dev-python/oslo-sphinx-2.5.0[${PYTHON_USEDEP}]
-               >=dev-python/sphinx-1.1.2[${PYTHON_USEDEP}]
-               !~dev-python/sphinx-1.2.0[${PYTHON_USEDEP}]
-               <dev-python/sphinx-1.3[${PYTHON_USEDEP}]
-       )
-"
-RDEPEND="
-       ${CDEPEND}
-       ${CRDEPEND}
-"
-
-PATCHES=( "${FILESDIR}"/${P}-RegexTest-python3.6.patch )
-
-python_compile_all() {
-       use doc && esetup.py build_sphinx
-}
-
-python_test() {
-       rm -rf .testrepository || die "could not remove '.testrepository' under ${EPYTHON}"
-
-       testr init || die "testr init failed under ${EPYTHON}"
-       testr run || die "testr run failed under ${EPYTHON}"
-}
-
-python_install_all() {
-       use doc && local HTML_DOCS=( doc/build/html/. )
-
-       distutils-r1_python_install_all
-}