dev-util/omake: Replace STRIP_MASK with RESTRICT=strip
authorMichał Górny <mgorny@gentoo.org>
Sun, 14 Apr 2019 08:08:48 +0000 (10:08 +0200)
committerMichał Górny <mgorny@gentoo.org>
Fri, 5 Jul 2019 20:17:00 +0000 (22:17 +0200)
Closes: https://bugs.gentoo.org/651452
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-util/omake/omake-0.10.2.ebuild
dev-util/omake/omake-0.10.3.ebuild
dev-util/omake/omake-0.9.8.6.0_rc1.ebuild

index 46e34cdb6a517b11d99c4bd523c52e16b5eb7136..d8f2abbc56cca26d89293e7de1e5eef267e64ad8 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=5
@@ -20,6 +20,8 @@ DEPEND=">=dev-lang/ocaml-3.10.2:=[ocamlopt?]
        readline? ( >=sys-libs/readline-4.3:0= )"
 RDEPEND="${DEPEND}"
 
+RESTRICT="!ocamlopt? ( strip )"
+
 src_prepare() {
        epatch \
                "${FILESDIR}/${P}-cflags.patch"
@@ -45,5 +47,4 @@ src_install() {
                dodoc doc/ps/omake-doc.{pdf,ps} doc/txt/omake-doc.txt
                dohtml -r doc/html/*
        fi
-       use ocamlopt || export STRIP_MASK="*/bin/*"
 }
index 019e3e3775e7f96e883213854d8feaf7747b100e..430979c1cfbd8e7dde7dda36836e39ea398272d6 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=5
@@ -20,6 +20,8 @@ DEPEND=">=dev-lang/ocaml-3.10.2:=[ocamlopt?]
        readline? ( >=sys-libs/readline-4.3:0= )"
 RDEPEND="${DEPEND}"
 
+RESTRICT="!ocamlopt? ( strip )"
+
 src_prepare() {
        epatch \
                "${FILESDIR}/${PN}-0.10.2-cflags.patch"
@@ -45,5 +47,4 @@ src_install() {
                dodoc doc/ps/omake-doc.{pdf,ps} doc/txt/omake-doc.txt
                dohtml -r doc/html/*
        fi
-       use ocamlopt || export STRIP_MASK="*/bin/*"
 }
index daa7fd04918a6e3d9901d8b530ec89b29a01a6ee..2ca918e00a10e181a838bb1b00a3eefaecf4e6bd 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=5
@@ -21,6 +21,8 @@ DEPEND=">=dev-lang/ocaml-3.10.2:=[ocamlopt?]
        readline? ( >=sys-libs/readline-4.3:0= )"
 RDEPEND="${DEPEND}"
 
+RESTRICT="!ocamlopt? ( strip )"
+
 S=${WORKDIR}/${PN}-${MY_PV%-*}
 
 use_boolean() {
@@ -77,5 +79,4 @@ src_install() {
                dodoc doc/ps/omake-doc.{pdf,ps} doc/txt/omake-doc.txt
                dohtml -r doc/html/*
        fi
-       use ocamlopt || export STRIP_MASK="*/bin/*"
 }