games-emulation/dosbox: eutils->desktop
authorMarty E. Plummer <hanetzer@startmail.com>
Fri, 3 Aug 2018 01:43:32 +0000 (20:43 -0500)
committerJames Le Cuirot <chewi@gentoo.org>
Mon, 27 Aug 2018 21:16:15 +0000 (22:16 +0100)
Only has eutils for the implicit desktop inheritance for doicon and
make_desktop_entry.

Package-Manager: Portage-2.3.44, Repoman-2.3.10
Closes: https://github.com/gentoo/gentoo/pull/9429

games-emulation/dosbox/dosbox-0.74_p20160629-r1.ebuild
games-emulation/dosbox/dosbox-0.74_p20160629.ebuild
games-emulation/dosbox/dosbox-9999.ebuild

index f622d980d347d3221b5d2a7c9b69510bfc7df386..d7fd016f2ca32a84160ce129565a9eb2ffa1861c 100644 (file)
@@ -1,8 +1,9 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=6
-inherit autotools eutils flag-o-matic
+
+inherit autotools desktop flag-o-matic
 
 PATCH=3989
 GLIDE_PATCH=3722fc563b737d2d7933df6a771651c2154e6f7b
@@ -31,7 +32,7 @@ DEPEND="${RDEPEND}
 S=${WORKDIR}/${PN}-code-0-${PATCH}-dosbox-trunk
 
 PATCHES=(
-"${FILESDIR}"/dosbox-0.74-gcc46.patch
+       "${FILESDIR}"/${PN}-0.74-gcc46.patch
 )
 
 src_prepare() {
index 45b0b0fdb711953d352aee9f823574c67c2f557b..a7b41d8d34eab36f9f9b003fd026075a34810c80 100644 (file)
@@ -1,8 +1,9 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=6
-inherit autotools eutils
+
+inherit autotools desktop
 
 PATCH=3989
 DESCRIPTION="DOS emulator"
@@ -27,7 +28,7 @@ DEPEND="${RDEPEND}
 S=${WORKDIR}/${PN}-code-0-${PATCH}-dosbox-trunk
 
 PATCHES=(
-"${FILESDIR}"/dosbox-0.74-gcc46.patch
+       "${FILESDIR}"/${PN}-0.74-gcc46.patch
 )
 
 src_prepare() {
index bceaab9e8150b699ffcac0df69e52500d073f2ab..786b1f7868879d2ae591844c83d87f7763b5784e 100644 (file)
@@ -3,6 +3,8 @@
 
 EAPI=6
 
+inherit autotools desktop flag-o-matic
+
 GLIDE_PATCH=841e1071597b64ead14dd08c25a03206b2d1d1b6
 SRC_URI="glide? ( https://raw.githubusercontent.com/voyageur/openglide/${GLIDE_PATCH}/platform/dosbox/dosbox_glide.diff -> dosbox_glide-${GLIDE_PATCH}.diff )"
 
@@ -14,8 +16,6 @@ else
        KEYWORDS="~amd64 ~arm ~ppc64 ~x86"
 fi
 
-inherit autotools eutils flag-o-matic
-
 DESCRIPTION="DOS emulator"
 HOMEPAGE="http://dosbox.sourceforge.net/"
 
@@ -37,7 +37,9 @@ if [[ ${PV} = 9999 ]]; then
        S=${WORKDIR}/${PN}
 fi
 
-PATCHES=( "${FILESDIR}/${PN}-0.74-gcc46.patch" )
+PATCHES=(
+       "${FILESDIR}"/${PN}-0.74-gcc46.patch
+)
 
 src_prepare() {
        use glide && eapply "${DISTDIR}"/dosbox_glide-${GLIDE_PATCH}.diff