net-irc/atheme-services: Rev bump
authorWade Cline <wadecline@hotmail.com>
Wed, 15 Apr 2020 05:26:59 +0000 (22:26 -0700)
committerJoonas Niilola <juippis@gentoo.org>
Fri, 17 Apr 2020 07:35:53 +0000 (10:35 +0300)
Backport part of '0f62f37d6683df42004bda2aa27e31e656f1c0b5' from
atheme contrib modules in order to fix compilation error on musl.
Update the ebuild to be compliant with GLEP 81.
Use EAPI-7.

Bug: https://bugs.gentoo.org/717288
Signed-off-by: Wade Cline <wadecline@hotmail.com>
Closes: https://github.com/gentoo/gentoo/pull/15349
Signed-off-by: Joonas Niilola <juippis@gentoo.org>
net-irc/atheme-services/atheme-services-7.2.10_p2-r1.ebuild [moved from net-irc/atheme-services/atheme-services-7.2.10_p2.ebuild with 81% similarity]
net-irc/atheme-services/files/atheme-services-7.2.10_p2-fix-backtrace-compat-detection.patch [new file with mode: 0644]

similarity index 81%
rename from net-irc/atheme-services/atheme-services-7.2.10_p2.ebuild
rename to net-irc/atheme-services/atheme-services-7.2.10_p2-r1.ebuild
index 370851d3ea4177a4cbf51cb52b51067df9e86662..6e5d339fa09de7139c93785bb2e5a18857b11744 100644 (file)
@@ -1,16 +1,16 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI=6
+EAPI=7
 
-inherit flag-o-matic perl-functions user
+inherit flag-o-matic perl-functions
 
 MY_PN="atheme"
 MY_PV="7.2.10-r2"
 
 DESCRIPTION="A portable and secure set of open-source and modular IRC services"
 HOMEPAGE="https://github.com/atheme/atheme"
-SRC_URI="https://github.com/atheme/atheme/releases/download/v${MY_PV}/${MY_PN}-v${MY_PV}.tar.xz -> ${PN}-${PV}.tar.xz"
+SRC_URI="https://github.com/atheme/atheme/releases/download/v${MY_PV}/${MY_PN}-v${MY_PV}.tar.xz -> ${P}.tar.xz"
 
 LICENSE="BSD"
 SLOT="0"
@@ -18,7 +18,10 @@ KEYWORDS="~amd64"
 IUSE="cracklib largenet ldap nls +pcre perl profile ssl"
 S="${WORKDIR}/${MY_PN}-v${MY_PV}"
 
-RDEPEND=">=dev-libs/libmowgli-2.1.0:2
+RDEPEND="
+       acct-group/atheme-services
+       acct-user/atheme-services
+       >=dev-libs/libmowgli-2.1.0:2
        cracklib? ( sys-libs/cracklib )
        ldap? ( net-nds/openldap )
        perl? ( dev-lang/perl )
@@ -28,12 +31,9 @@ DEPEND="${RDEPEND}
        dev-vcs/git
        virtual/pkgconfig"
 
-PATCHES=("${FILESDIR}"/${P}-configure-logdir.patch)
-
-pkg_setup() {
-       enewgroup ${PN}
-       enewuser ${PN} -1 -1 /var/lib/atheme ${PN}
-}
+PATCHES=(
+       "${FILESDIR}"/${P}-configure-logdir.patch
+       "${FILESDIR}"/${P}-fix-backtrace-compat-detection.patch)
 
 src_configure() {
        # perl scriping module support is also broken in 7.0.0. Yay for QA failures.
@@ -85,8 +85,8 @@ src_install() {
 
        use perl && perl_domodule -r contrib/Atheme{,.pm}
 
-       rm "${ED%/}/usr/share/doc/${PF}/WINDOWS" || die
+       rm "${ED}/usr/share/doc/${PF}/WINDOWS" || die
 
        # Bug #454840 #520490
-       rm -rf "${ED%/}/var/run" || die
+       rm -rf "${ED}/var/run" || die
 }
diff --git a/net-irc/atheme-services/files/atheme-services-7.2.10_p2-fix-backtrace-compat-detection.patch b/net-irc/atheme-services/files/atheme-services-7.2.10_p2-fix-backtrace-compat-detection.patch
new file mode 100644 (file)
index 0000000..b6f4481
--- /dev/null
@@ -0,0 +1,12 @@
+diff --git a/modules/contrib/backtrace.c b/modules/contrib/backtrace.c
+index 8c4eeb2..064e88e 100644
+--- a/modules/contrib/backtrace.c
++++ b/modules/contrib/backtrace.c
+@@ -1,6 +1,6 @@
+ #include "atheme-compat.h"
+-#if defined( __linux__) || defined(__Linux__)
++#if (defined( __linux__) || defined(__Linux__)) && defined(__GLIBC__)
+ #include <execinfo.h>
+ DECLARE_MODULE_V1