net-im/telegram-desktop: bump to 1.9.16
authorGeorgy Yakovlev <gyakovlev@gentoo.org>
Mon, 24 Feb 2020 06:51:55 +0000 (22:51 -0800)
committerGeorgy Yakovlev <gyakovlev@gentoo.org>
Mon, 24 Feb 2020 07:28:29 +0000 (23:28 -0800)
Package-Manager: Portage-2.3.89, Repoman-2.3.20
Signed-off-by: Georgy Yakovlev <gyakovlev@gentoo.org>
net-im/telegram-desktop/Manifest
net-im/telegram-desktop/telegram-desktop-1.9.16.ebuild [new file with mode: 0644]

index b9fb4629268307b0ec8bbf03d77ba7f6fcef5311..7bca09434b47c9892246cf1ae961580a4dccdff0 100644 (file)
@@ -1,3 +1,4 @@
 DIST tdesktop-1.9.13-full.tar.gz 25324119 BLAKE2B 70029ea0dd68fd4be3ba540831111b79d223e059f70551a970847190b00f2aaebc13319236b2c681b2a55ee99408d20e6feea3fc3ab2fb9c97d4740fd4c6a644 SHA512 995face8a2ffb54f9f31aaa8d5a26421f4915e73360945553b6fa4e4b02431ca83ec1e72d6d2ce77f5b9daa39892859c88f7ea53c3ddbeec2cb37f27451878d2
 DIST tdesktop-1.9.14-full.tar.gz 25324084 BLAKE2B 45c071aa573541b6e483d2ae712b7f3b672c1294e8e7e624d9292f7176482f4d68069c35541019dc27fdb1c66134c29fb4d3667f1197e7085e4f8a80c8ca603c SHA512 56efa64048d23b280782b51319c0071c6cef833cb7e2584e52c6e45488577755beb85185ec9187029c425cc8d4c9c1887142687c744697e7731a15abe2846056
 DIST tdesktop-1.9.15-full.tar.gz 25327647 BLAKE2B 5d689f656a66d55b3e62d52d48106270fc16675a01ff8a2b865c122191c7ee4781c2e698d0652c765a10985148ade0ce5dd47f4938538f24348cd5b42fe0160c SHA512 457b568226e34cc23e379d34a9ad21d0d6c26fb69647cd17bf74aef48ad9ce35eae6697795af8c349f43e376b44bcab49e1939733b1cc20ec16ddf1c29a32c4e
+DIST tdesktop-1.9.16-full.tar.gz 25328085 BLAKE2B 1d429964e67641a1cfa0f826820ed54eb7e37d9946fdd3292d5d67276609d736dcfb2b4c422f6b64364705eb68e78f6ac6bfa52096ca39d948a9e01bc152404b SHA512 89cdf12456d9bcaa4e332286d2d5c4da6cf715bd0e798e51e458adb7bf5c89044899beb9ac7b11a808b81e37958473a473e3774519420baf7a6bc34eb7938733
diff --git a/net-im/telegram-desktop/telegram-desktop-1.9.16.ebuild b/net-im/telegram-desktop/telegram-desktop-1.9.16.ebuild
new file mode 100644 (file)
index 0000000..3ca08c2
--- /dev/null
@@ -0,0 +1,134 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7} )
+
+inherit cmake desktop flag-o-matic python-any-r1 xdg-utils
+
+MY_P="tdesktop-${PV}-full"
+
+DESCRIPTION="Official desktop client for Telegram"
+HOMEPAGE="https://desktop.telegram.org"
+SRC_URI="https://github.com/telegramdesktop/tdesktop/releases/download/v${PV}/${MY_P}.tar.gz"
+
+LICENSE="GPL-3-with-openssl-exception"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64"
+IUSE="+alsa +dbus libressl pulseaudio +spell"
+
+RDEPEND="
+       !net-im/telegram-desktop-bin
+       app-arch/lz4:=
+       app-arch/xz-utils
+       !libressl? ( dev-libs/openssl:0= )
+       libressl? ( dev-libs/libressl:0= )
+       >=dev-cpp/ms-gsl-2.1.0
+       dev-cpp/range-v3
+       dev-libs/xxhash
+       dev-qt/qtcore:5
+       dev-qt/qtimageformats:5
+       dev-qt/qtnetwork:5
+       dev-qt/qtsvg:5
+       media-libs/fontconfig:=
+       >=media-libs/libtgvoip-2.4.4_p20200212[alsa?,pulseaudio?]
+       media-libs/openal[alsa?,pulseaudio?]
+       media-libs/opus:=
+       media-video/ffmpeg:=[opus]
+       sys-libs/zlib[minizip]
+       virtual/libiconv
+       x11-libs/libva:=[X,drm]
+       x11-libs/libX11
+       || (
+               dev-qt/qtgui:5[jpeg,png,X(-)]
+               dev-qt/qtgui:5[jpeg,png,xcb(-)]
+       )
+       || (
+               dev-qt/qtwidgets:5[png,X(-)]
+               dev-qt/qtwidgets:5[png,xcb(-)]
+       )
+       dbus? (
+               dev-qt/qtdbus:5
+               dev-libs/libdbusmenu-qt[qt5(+)]
+       )
+       pulseaudio? ( media-sound/pulseaudio )
+       spell? ( app-text/enchant:= )
+"
+
+DEPEND="
+       ${PYTHON_DEPS}
+       ${RDEPEND}
+"
+
+BDEPEND="
+       >=dev-util/cmake-3.16
+       virtual/pkgconfig
+"
+
+REQUIRED_USE="|| ( alsa pulseaudio )"
+
+S="${WORKDIR}/${MY_P}"
+
+src_configure() {
+       local mycxxflags=(
+               -Wno-deprecated-declarations
+               -Wno-error=deprecated-declarations
+               -Wno-switch
+       )
+
+       append-cxxflags "${mycxxflags[@]}"
+
+       # TODO: unbundle header-only libs, ofc telegram uses git versions...
+       # it fals with tl-expected-1.0.0, so we use bundled for now to avoid git rev snapshots
+       # EXPECTED VARIANT
+       local mycmakeargs=(
+               -DDESKTOP_APP_DISABLE_CRASH_REPORTS=ON
+               -DDESKTOP_APP_USE_GLIBC_WRAPS=OFF
+               -DDESKTOP_APP_USE_PACKAGED=ON
+               -DDESKTOP_APP_USE_PACKAGED_EXPECTED=OFF
+               -DDESKTOP_APP_USE_PACKAGED_RLOTTIE=OFF
+               -DDESKTOP_APP_USE_PACKAGED_VARIANT=OFF
+               -DTDESKTOP_DISABLE_DESKTOP_FILE_GENERATION=ON
+               -DTDESKTOP_LAUNCHER_BASENAME="${PN}"
+               -DDESKTOP_APP_DISABLE_DBUS_INTEGRATION="$(usex dbus OFF ON)"
+               -DDESKTOP_APP_DISABLE_SPELLCHECK="$(usex spell OFF ON)"
+       )
+
+       if [[ -n ${MY_TDESKTOP_API_ID} && -n ${MY_TDESKTOP_API_HASH} ]]; then
+               einfo "Found custom API credentials"
+               mycmakeargs+=(
+                       -DTDESKTOP_API_ID="${MY_TDESKTOP_API_ID}"
+                       -DTDESKTOP_API_HASH="${MY_TDESKTOP_API_HASH}"
+               )
+       else
+               # https://github.com/telegramdesktop/tdesktop/blob/dev/snap/snapcraft.yaml
+               # Building with snapcraft API credentials by default
+               # Custom API credentials can be obtained here:
+               # https://github.com/telegramdesktop/tdesktop/blob/dev/docs/api_credentials.md
+               # After getting credentials you can export variables:
+               #  export MY_TDESKTOP_API_ID="17349""
+               #  export MY_TDESKTOP_API_HASH="344583e45741c457fe1862106095a5eb"
+               # and restart the build"
+               # you can set above variables (without export) in /etc/portage/env/net-im/telegram-desktop
+               # portage will use custom variable every build automatically
+               mycmakeargs+=(
+                       -DTDESKTOP_API_ID="611335"
+                       -DTDESKTOP_API_HASH="d524b414d21f4d37f08684c1df41ac9c"
+               )
+       fi
+
+       cmake_src_configure
+}
+
+pkg_postinst() {
+       xdg_desktop_database_update
+       xdg_icon_cache_update
+       xdg_mimeinfo_database_update
+}
+
+pkg_postrm() {
+       xdg_desktop_database_update
+       xdg_icon_cache_update
+       xdg_mimeinfo_database_update
+}