app-misc/bb: update to EAPI=7
authorSergei Trofimovich <slyfox@gentoo.org>
Sun, 10 Nov 2019 11:53:06 +0000 (11:53 +0000)
committerSergei Trofimovich <slyfox@gentoo.org>
Sun, 10 Nov 2019 11:59:42 +0000 (11:59 +0000)
Package-Manager: Portage-2.3.79, Repoman-2.3.18
Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
app-misc/bb/bb-1.3.0_rc1-r5.ebuild [new file with mode: 0644]
app-misc/bb/files/bb-1.3.0_rc1-disable-pulse.patch
app-misc/bb/files/bb-1.3.0_rc1-fix-protos.patch
app-misc/bb/files/bb-1.3.0_rc1-m4-stuff.patch
app-misc/bb/files/bb-1.3.0_rc1-messager-overlap.patch
app-misc/bb/files/bb-1.3.0_rc1-noattr.patch
app-misc/bb/files/bb-1.3.0_rc1-printf-cleanup.patch
app-misc/bb/files/bb-1.3.0_rc1-protos.patch
app-misc/bb/files/bb-1.3.0_rc1-zbuff-fault.patch

diff --git a/app-misc/bb/bb-1.3.0_rc1-r5.ebuild b/app-misc/bb/bb-1.3.0_rc1-r5.ebuild
new file mode 100644 (file)
index 0000000..793a64d
--- /dev/null
@@ -0,0 +1,71 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools
+
+MY_P="${PN}-$(ver_cut 1-2)$(ver_cut 4-5)"
+
+DESCRIPTION="Demonstration program for visual effects of aalib"
+HOMEPAGE="http://aa-project.sourceforge.net/"
+SRC_URI="mirror://sourceforge/aa-project/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE="mikmod"
+
+DEPEND="media-libs/aalib:=
+       dev-libs/lzo:=
+       mikmod? ( media-libs/libmikmod:=[openal] )
+"
+# media-libs/libmikmod[openal] is due to bug #516964
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${PN}-$(ver_cut 1-3)"
+
+PATCHES=(
+       "${FILESDIR}"/${P}-noattr.patch
+       "${FILESDIR}"/${P}-fix-protos.patch
+       "${FILESDIR}"/${P}-messager-overlap.patch
+       "${FILESDIR}"/${P}-zbuff-fault.patch
+       "${FILESDIR}"/${P}-printf-cleanup.patch
+       "${FILESDIR}"/${P}-m4-stuff.patch
+       "${FILESDIR}"/${P}-protos.patch
+       "${FILESDIR}"/${P}-disable-pulse.patch
+)
+
+src_prepare() {
+       default
+
+       # unbundle lzo, #515286
+       rm -v README.LZO minilzo.{c,h} mylzo.h || die
+       sed -e 's/minilzo.c//' \
+           -e 's/minilzo.h//' \
+           -e 's/README.LZO//' \
+               -i Makefile.am || die
+       echo 'bb_LDADD = -llzo2' >> Makefile.am || die
+       # update code
+       sed -e 's,#include "minilzo.h",#include <lzo/lzo1x.h>,' \
+           -e 's,int size = image,lzo_uint size = image,' \
+               -i image.c || die
+
+       # rename binary and manpage bb -> bb-aalib
+
+       mv bb.1 bb-aalib.1 || die
+       sed -e 's/bb/bb-aalib/' \
+               -i bb-aalib.1
+       sed -e 's/bin_PROGRAMS = bb/bin_PROGRAMS = bb-aalib/' \
+           -e 's/man_MANS = bb.1/man_MANS = bb-aalib.1/'     \
+           -e 's/bb_SOURCES/bb_aalib_SOURCES/'               \
+           -e 's/bb_LDADD/bb_aalib_LDADD/'                   \
+               -i Makefile.am || die
+
+       mv -v configure.{in,ac} || die
+       eautoreconf
+}
+
+pkg_postinst() {
+       elog "bb binary has been renamed to bb-aalib to avoid a naming conflict with sys-apps/busybox."
+}
index dcc00c642335e79f8c2ecebf75b75e75410d9012..3d7889101b93e9c8539cf6d99edf5885069bd36c 100644 (file)
@@ -1,6 +1,4 @@
 https://bugs.gentoo.org/516964
-diff --git a/main.c b/main.c
-index c0648b4..a9fac57 100644
 --- a/main.c
 +++ b/main.c
 @@ -160,6 +160,17 @@ main (int argc, char *argv[])
index 577f306c8169fc79730538abb52245345f849d1e..a85166b0130960ba135bac727e38d7bd39494e2d 100644 (file)
@@ -1,8 +1,6 @@
 Fixes warning:
 main.c: In function 'load_song':
 main.c:56:23: warning: incompatible implicit declaration of built-in function 'strlen'
-diff --git a/main.c b/main.c
-index ae852a7..417ff62 100644
 --- a/main.c
 +++ b/main.c
 @@ -21,6 +21,7 @@
index 0fa98f8162f536970afd5fe8646dd41cdbbb1938..843d839908f7e98ca4911f6f0155480f78afe574 100644 (file)
@@ -6,9 +6,6 @@ Date:   Tue Feb 7 10:59:09 2012 +0300
 
     bb-1.3.0_rc1: bundle m4 source
 
-diff --git m4/aalib.m4 m4/aalib.m4
-new file mode 100644
-index 0000000..991fbda
 --- /dev/null
 +++ m4/aalib.m4
 @@ -0,0 +1,169 @@
@@ -181,9 +178,6 @@ index 0000000..991fbda
 +  AC_SUBST(AALIB_LIBS)
 +  rm -f conf.aalibtest
 +])
-diff --git m4/libmikmod.m4 m4/libmikmod.m4
-new file mode 100644
-index 0000000..18feebe
 --- /dev/null
 +++ m4/libmikmod.m4
 @@ -0,0 +1,207 @@
index e46b75fd581518fd82f78869f09eb7f4c096599a..378e6b7798b62ba38fc1e22825c059f7ed1e0b31 100644 (file)
@@ -8,8 +8,6 @@ messager.c: fix memory overlap (fixes artefacts in scrolling text)
 ==363==    by 0x403009: bb (bb.c:258)
 ==363==    by 0x407C06: main (main.c:202)
 
-diff --git a/messager.c b/messager.c
-index 95cc410..964080b 100644
 --- a/messager.c
 +++ b/messager.c
 @@ -40,8 +40,8 @@ static void newline()
index 7a6f9474a71e236c16c5ae17d3b2344223bb906a..a4768ab75e289c177d870c9d4922905fdd7f5e6d 100644 (file)
@@ -1,7 +1,7 @@
 # remove __attribute__
 
---- timers.h   Thu Apr 26 18:04:22 2001
-+++ timers.h   Sun Dec  9 18:44:31 2007
+--- a/timers.h Thu Apr 26 18:04:22 2001
++++ b/timers.h Sun Dec  9 18:44:31 2007
 @@ -49,8 +49,8 @@
  extern tl_group *syncgroup, *asyncgroup;
  void tl_sleep (int);
index da113795124b30e44bdddc90aabe84ee25ddb8b3..b11b2333d1d6bce79c2f4241ad86b7902b24c35a 100644 (file)
@@ -8,8 +8,6 @@ zoom.c:260:113: warning: format '%i' expects type 'int', but argument 3 has type
 zoom.c: In function 'moveoldpoints':
 zoom.c:590:3: warning: format '%i' expects type 'int', but argument 3 has type 'long unsigned int'
 zoom.c:596:3: warning: format '%i' expects type 'int', but argument 3 has type 'long unsigned int'
-diff --git a/zoom.c b/zoom.c
-index 7450095..b86cc8b 100644
 --- a/zoom.c
 +++ b/zoom.c
 @@ -241,13 +241,13 @@ static /*INLINE */ void mkrealloc_table(register number_t * pos, realloc_t * rea
index aa3fc021e5c187ab75fb345ddd0b838b5f01cbf5..40f77a0f20cde70e754802d60d22ba3bf88630f4 100644 (file)
@@ -1,13 +1,9 @@
-diff --git a/bb.c b/bb.c
-index 95850ef..a394d00 100644
 --- a/bb.c
 +++ b/bb.c
 @@ -27,2 +27,3 @@
  #include <aalib.h>
 +#include <time.h>
  #include "bb.h"
-diff --git a/main.c b/main.c
-index 417ff62..c0648b4 100644
 --- a/main.c
 +++ b/main.c
 @@ -23,2 +23,3 @@
index b3e882ed55e9aeeadcd3fc081f25ac79d4fee170..7b6eda327d185bad60c7d6707012a10d3cfb87ca 100644 (file)
@@ -20,8 +20,6 @@ Valgrind says:
 ==4525==    by 0x4031BC: bb (bb.c:325)
 ==4525==    by 0x407C56: main (main.c:202)
 
-diff --git a/tex.c b/tex.c
-index 9f2f99d..b390510 100644
 --- a/tex.c
 +++ b/tex.c
 @@ -92,7 +92,7 @@ void unset_zbuff()