dev-python/python-zipstream: Enable Python 3.7
authorMichał Górny <mgorny@gentoo.org>
Tue, 18 Jun 2019 07:36:22 +0000 (09:36 +0200)
committerMichał Górny <mgorny@gentoo.org>
Tue, 18 Jun 2019 07:40:07 +0000 (09:40 +0200)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/python-zipstream/python-zipstream-1.1.4.ebuild

index 6185735434edb41e0332593ca8a5f09af961c6f1..df1327996cbaff175e6342b85e6dbcbc4c83d3f8 100644 (file)
@@ -3,7 +3,7 @@
 
 EAPI=6
 
-PYTHON_COMPAT=( python{2_7,3_5,3_6} )
+PYTHON_COMPAT=( python{2_7,3_{5,6,7}} )
 
 inherit distutils-r1
 
@@ -15,10 +15,11 @@ LICENSE="GPL-3+"
 SLOT="0"
 KEYWORDS="~amd64 ~x86"
 IUSE="test"
+RESTRICT="!test? ( test )"
 
 DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
                test? ( dev-python/nose[${PYTHON_USEDEP}] )"
 
 python_test() {
-       nosetests || die "tests failed under ${EPYTHON}"
+       nosetests -v || die "tests failed under ${EPYTHON}"
 }