sys-libs/compiler-rt: Require Python only with USE=test
authorMichał Górny <mgorny@gentoo.org>
Mon, 6 Jan 2020 13:27:36 +0000 (14:27 +0100)
committerMichał Górny <mgorny@gentoo.org>
Mon, 6 Jan 2020 13:30:46 +0000 (14:30 +0100)
Closes: https://bugs.gentoo.org/704852
Signed-off-by: Michał Górny <mgorny@gentoo.org>
sys-libs/compiler-rt/compiler-rt-10.0.0.9999.ebuild
sys-libs/compiler-rt/compiler-rt-7.1.0.ebuild
sys-libs/compiler-rt/compiler-rt-8.0.1.ebuild
sys-libs/compiler-rt/compiler-rt-9.0.0-r1.ebuild
sys-libs/compiler-rt/compiler-rt-9.0.1.ebuild

index c709777f6bbd2fd544e1a55619d57b74b3fcf6ff..abb81deafce94e33af624cede44d031748c3f9ce 100644 (file)
@@ -45,7 +45,7 @@ pkg_pretend() {
 
 pkg_setup() {
        llvm_pkg_setup
-       python-any-r1_pkg_setup
+       use test && python-any-r1_pkg_setup
 }
 
 test_compiler() {
index dc6beaa1fa9514a2ec996abd8ec0ee1250e2ac6f..dc06a171993f01eb3757d56b57ced813640fd490 100644 (file)
@@ -49,7 +49,7 @@ pkg_pretend() {
 
 pkg_setup() {
        llvm_pkg_setup
-       python-any-r1_pkg_setup
+       use test && python-any-r1_pkg_setup
 }
 
 test_compiler() {
index aa5a64dc369d9a2ad72efde28cf978e53d6f39cc..bad82273c1294489d14e1a31cd6d6b077911d739 100644 (file)
@@ -50,7 +50,7 @@ pkg_pretend() {
 
 pkg_setup() {
        llvm_pkg_setup
-       python-any-r1_pkg_setup
+       use test && python-any-r1_pkg_setup
 }
 
 test_compiler() {
index 5625439d2c6a00ab586bf543676fc2f44c69509a..2310973c4047a808a5d323f4e91c63fe56515568 100644 (file)
@@ -51,7 +51,7 @@ pkg_pretend() {
 
 pkg_setup() {
        llvm_pkg_setup
-       python-any-r1_pkg_setup
+       use test && python-any-r1_pkg_setup
 }
 
 test_compiler() {
index d6d21f789d1b35d051bb39535d9bf1c767e409b4..fb6ce9998fa72c88169c58055e3c23577803a996 100644 (file)
@@ -45,7 +45,7 @@ pkg_pretend() {
 
 pkg_setup() {
        llvm_pkg_setup
-       python-any-r1_pkg_setup
+       use test && python-any-r1_pkg_setup
 }
 
 test_compiler() {