net-analyzer/graphite-web-1.1.5-r1: add support for Python-3.7
authorFabian Groffen <grobian@gentoo.org>
Sat, 9 May 2020 10:27:19 +0000 (12:27 +0200)
committerFabian Groffen <grobian@gentoo.org>
Sat, 9 May 2020 10:27:26 +0000 (12:27 +0200)
Drop dep on scandir, as the built-in version from Python-3.5+ is tried
first, so we don't need the dep (which additionally doesn't support
Python-3.8 yet).

Can't add support for Python-3.8 due to python-memcached.

Bug: https://bugs.gentoo.org/718418
Package-Manager: Portage-2.3.89, Repoman-2.3.20
Signed-off-by: Fabian Groffen <grobian@gentoo.org>
net-analyzer/graphite-web/graphite-web-1.1.5-r1.ebuild

index 3d688856dc87c197372025e85c706065a013c71a..35eb0f1c76f7e4e2afec2e04e81a9c5f261107eb 100644 (file)
@@ -2,7 +2,7 @@
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=7
-PYTHON_COMPAT=( python3_6 )  # 3.{7,8} dropped due to dep-hell
+PYTHON_COMPAT=( python3_{6,7} )  # 3.8 dropped due to dep on python-memcached
 
 inherit distutils-r1 prefix
 
@@ -27,7 +27,6 @@ RDEPEND="
        dev-python/cairocffi[${PYTHON_USEDEP}]
        dev-python/pyparsing[${PYTHON_USEDEP}]
        dev-python/pytz[${PYTHON_USEDEP}]
-       dev-python/scandir[${PYTHON_USEDEP}]
        dev-python/six[${PYTHON_USEDEP}]
        dev-python/urllib3[${PYTHON_USEDEP}]
        media-libs/fontconfig