dev-tex/latexmk: Version bump (v469)
authorMikle Kolyada <zlogene@gentoo.org>
Sat, 25 Apr 2020 09:48:59 +0000 (12:48 +0300)
committerMikle Kolyada <zlogene@gentoo.org>
Sat, 25 Apr 2020 09:48:59 +0000 (12:48 +0300)
Closes: https://bugs.gentoo.org/719242
Package-Manager: Portage-2.3.89, Repoman-2.3.20
Signed-off-by: Mikle Kolyada <zlogene@gentoo.org>
dev-tex/latexmk/Manifest
dev-tex/latexmk/latexmk-469.ebuild [new file with mode: 0644]

index d45e120f1aaa1edc56d0991577d575c4bac3fac1..f9e0cd2d4103f3cedaf540c6054fae1a68cf0120 100644 (file)
@@ -1,2 +1,3 @@
 DIST latexmk-456.zip 425179 BLAKE2B 1cd2fcaff070bb9809a263763164f364f13146ba4a5115494824dfe422b2b58906aa9e9ee7ce02238961c77da2e828e6a73a56e7397efa77003b8237fa949fe5 SHA512 ff169ff677367125b32e7641e9fabc66d9fb015e6cf1433d39c598baf17a926e0d29c975c4a8fa8ed482b4bc57ff177cfedc058ebdc83a3abadde50f9a490d91
 DIST latexmk-465.zip 447290 BLAKE2B 2f11667e674122aad88604aad3f61da1503d220b27bae9b95c29922fc6304c227c5c5257666a6de3da6f6dee77b466d7e3c6f06fc6c03f4102cce43879765dd0 SHA512 132cdd95c0274f98946b37a0c1554a82bb649dcd61284386f3005aa78895d51c382d5d8f6cf1ecd8ece60c1877a0dc80660367e0ad82a44036334b3f4634ee86
+DIST latexmk-469.zip 455039 BLAKE2B 373ce1c6fca0c57fd7350149fa5c1ecc4a301d4305adad79dda230f0a4c3c7ad4b6c8b8b07a9d76749f000251389673f152c7a56b97c552369f1f258cb869460 SHA512 b1ca496cc424167296b3a5305d1a6fcf4a35d33020dcbbac88d14c102ec3d92be100c5daca54168b69846e3f8b6a3ac326e2e35b0c9a84ff141ed31592aec857
diff --git a/dev-tex/latexmk/latexmk-469.ebuild b/dev-tex/latexmk/latexmk-469.ebuild
new file mode 100644 (file)
index 0000000..9ac10cb
--- /dev/null
@@ -0,0 +1,31 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit bash-completion-r1
+
+DESCRIPTION="Perl script for automatically building LaTeX documents"
+HOMEPAGE="http://www.phys.psu.edu/~collins/software/latexmk/"
+SRC_URI="http://personal.psu.edu/jcc8/software/latexmk/${PN}-${PV/a}.zip"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~ppc-macos ~x64-macos ~x86-macos"
+
+RDEPEND="virtual/latex-base
+       dev-lang/perl"
+
+DEPEND="${RDEPEND}"
+
+BDEPDND="app-arch/unzip"
+
+S="${WORKDIR}/${PN}"
+
+src_install() {
+       newbin latexmk.pl latexmk
+       doman latexmk.1
+       dodoc CHANGES README latexmk.pdf latexmk.txt
+       dodoc -r example_rcfiles extra-scripts
+       newbashcomp "${FILESDIR}"/completion.bash-2 ${PN}
+}