net-print/cups-filters: Bump to version 1.27.1
authorLars Wendler <polynomial-c@gentoo.org>
Mon, 17 Feb 2020 09:15:05 +0000 (10:15 +0100)
committerLars Wendler <polynomial-c@gentoo.org>
Mon, 17 Feb 2020 09:31:22 +0000 (10:31 +0100)
Package-Manager: Portage-2.3.89, Repoman-2.3.20
Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
net-print/cups-filters/Manifest
net-print/cups-filters/cups-filters-1.27.1.ebuild [new file with mode: 0644]

index d08bd15c89b64f48d6ed68753853d22178e05643..f8f8f17350207c5aefff1d5fbef4b596c7496071 100644 (file)
@@ -2,3 +2,4 @@ DIST cups-filters-1.25.11.tar.xz 1482792 BLAKE2B 67801904dbe025933d1209817e23ff7
 DIST cups-filters-1.25.13.tar.xz 1485860 BLAKE2B 03fbbbefdd36e8f619fabf17e6e13d051f48f68f87260747a181f6976ff88728d7d01b646227cd5f054e0321f6fe0e64e4c6b1bdba631d9d703304ad98a625eb SHA512 4b5ef647870235436276db68f3ef1879b578807338a025100a1d43115a7330a8f506be631df9c43edb2f1ec15f9a42f15f7cdc725bb5d39612b37bae04631611
 DIST cups-filters-1.26.1.tar.xz 1489804 BLAKE2B 8a5b18cdd192b2847889b4a5ab865152653b443ea01246b52a12fc20b022d6d0d09187cb9c2483d684452a8d7308ae60cb8217efe3e2e13de5001f43b727fe8d SHA512 0aaad7ceeb763aa3da4f961c99f85c0200cf4fcd071617506daf97dad4914de38fa744ae692b6fbc1d00a0eec62b4de4d7c5f865fd0e32e4155ab3f0c5a21ede
 DIST cups-filters-1.26.2.tar.xz 1490192 BLAKE2B 6bc5033c648e42a4590a941fd089c3bf3a901a36e26f12b3cdc892ea41943071903b2df2ef5730b7948270f4f59419083c9423af9482e032958360144fb04e9b SHA512 59a5eaba00e0f384f2b1498e58ea3d7272e42923a69eaa0c107ac103dc539c9bf14a94b7a91a73e7185d8a347b4ac7f4a7a655b1ffc373983da807c582e10264
+DIST cups-filters-1.27.1.tar.xz 1492256 BLAKE2B 30e4915bfc9a4f308defdcf13acc246330499008648edbce4df3efcf29fc960ac2c9a868ebe7cafcffb16b07763a2235ddd3d29a849ea18892b8da1d0f167775 SHA512 3fde635735138fa5ef511466b07f396f96860efcc51d9a01f5b95e86fc71ef48b9d17ba1bbe2eeb29585c3afc8bf26370b8f07df76a3adea2335be90e3fdb91b
diff --git a/net-print/cups-filters/cups-filters-1.27.1.ebuild b/net-print/cups-filters/cups-filters-1.27.1.ebuild
new file mode 100644 (file)
index 0000000..7d3a324
--- /dev/null
@@ -0,0 +1,139 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+GENTOO_DEPEND_ON_PERL=no
+
+inherit perl-module systemd flag-o-matic
+
+if [[ "${PV}" == "9999" ]] ; then
+       inherit autotools git-r3
+       EGIT_REPO_URI="https://github.com/OpenPrinting/cups-filters.git"
+else
+       SRC_URI="http://www.openprinting.org/download/${PN}/${P}.tar.xz"
+       KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~m68k-mint"
+fi
+DESCRIPTION="Cups filters"
+HOMEPAGE="https://wiki.linuxfoundation.org/openprinting/cups-filters"
+
+LICENSE="MIT GPL-2"
+SLOT="0"
+IUSE="dbus +foomatic ipp_autosetup jpeg ldap pclm pdf perl png +postscript static-libs test tiff zeroconf"
+
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+       >=app-text/poppler-0.32:=[cxx,jpeg?,lcms,tiff?,utils]
+       >=app-text/qpdf-8.3.0:=
+       dev-libs/glib:2
+       media-libs/fontconfig
+       media-libs/freetype:2
+       media-libs/lcms:2
+       >=net-print/cups-1.7.3
+       !<=net-print/cups-1.5.9999
+       sys-devel/bc
+       sys-libs/zlib
+       dbus? ( sys-apps/dbus )
+       foomatic? ( !net-print/foomatic-filters )
+       jpeg? ( virtual/jpeg:0 )
+       ldap? ( net-nds/openldap )
+       pdf? ( app-text/mupdf )
+       perl? ( dev-lang/perl:= )
+       png? ( media-libs/libpng:0= )
+       postscript? ( >=app-text/ghostscript-gpl-9.09[cups] )
+       tiff? ( media-libs/tiff:0 )
+       zeroconf? ( net-dns/avahi[dbus] )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+       dev-util/gdbus-codegen
+       >=sys-devel/gettext-0.18.3
+       virtual/pkgconfig
+       test? ( media-fonts/dejavu )
+"
+
+src_prepare() {
+       default
+       [[ "${PV}" == "9999" ]] && eautoreconf
+
+       # Bug #626800
+       append-cxxflags -std=c++11
+}
+
+src_configure() {
+       local myeconfargs=(
+               --enable-imagefilters
+               --localstatedir="${EPREFIX}"/var
+               --with-browseremoteprotocols=DNSSD,CUPS
+               --with-cups-rundir="${EPREFIX}"/run/cups
+               --with-fontdir="fonts/conf.avail"
+               --with-pdftops=pdftops
+               --with-rcdir=no
+               --without-php
+               $(use_enable dbus)
+               $(use_enable foomatic)
+               $(use_enable ipp_autosetup auto-setup-driverless)
+               $(use_enable ldap)
+               $(use_enable pclm)
+               $(use_enable pdf mutool)
+               $(use_enable postscript ghostscript)
+               $(use_enable static-libs static)
+               $(use_enable zeroconf avahi)
+               $(use_with jpeg)
+               $(use_with png)
+               $(use_with tiff)
+       )
+       econf "${myeconfargs[@]}"
+}
+
+src_compile() {
+       default
+
+       if use perl; then
+               pushd "${S}/scripting/perl" > /dev/null
+               perl-module_src_configure
+               perl-module_src_compile
+               popd > /dev/null
+       fi
+}
+
+src_install() {
+       default
+
+       if use perl; then
+               pushd "${S}/scripting/perl" > /dev/null
+               perl-module_src_install
+               perl_delete_localpod
+               popd > /dev/null
+       fi
+
+       if use postscript; then
+               # workaround: some printer drivers still require pstoraster and pstopxl, bug #383831
+               dosym gstoraster /usr/libexec/cups/filter/pstoraster
+               dosym gstopxl /usr/libexec/cups/filter/pstopxl
+       fi
+
+       find "${ED}" \( -name "*.a" -o -name "*.la" \) -delete || die
+
+       cp "${FILESDIR}"/cups-browsed.init.d-r1 "${T}"/cups-browsed || die
+
+       if ! use zeroconf ; then
+               sed -i -e 's:need cupsd avahi-daemon:need cupsd:g' "${T}"/cups-browsed || die
+               sed -i -e 's:cups\.service avahi-daemon\.service:cups.service:g' "${S}"/utils/cups-browsed.service || die
+       fi
+
+       doinitd "${T}"/cups-browsed
+       systemd_dounit "${S}/utils/cups-browsed.service"
+}
+
+src_test() {
+       emake check
+}
+
+pkg_postinst() {
+       if ! use foomatic ; then
+               ewarn "You are disabling the foomatic code in cups-filters. Please do that ONLY if absolutely."
+               ewarn "necessary. net-print/foomatic-filters as replacement is deprecated and unmaintained."
+       fi
+}