dev-util/patchelf: Reduce test fails by building tests with -no-pie
authorJames Le Cuirot <chewi@gentoo.org>
Fri, 3 May 2019 20:44:09 +0000 (21:44 +0100)
committerJames Le Cuirot <chewi@gentoo.org>
Fri, 3 May 2019 20:45:01 +0000 (21:45 +0100)
Now 0.8 passes and 0.10 has one 1 failure.

Package-Manager: Portage-2.3.66, Repoman-2.3.12
Signed-off-by: James Le Cuirot <chewi@gentoo.org>
dev-util/patchelf/patchelf-0.10.ebuild
dev-util/patchelf/patchelf-0.8.ebuild

index dfc0d88d15f9058ebf4f5f1b5283a8998fd9b338..36271cd5f471508de44098e877e3856ce283236a 100644 (file)
@@ -22,3 +22,9 @@ src_prepare() {
 
        eautoreconf
 }
+
+src_test() {
+       emake check \
+                 CFLAGS+=" -no-pie" \
+                 CXXFLAGS+=" -no-pie"
+}
index 92c86cecf1a4fce1b620df1f0ed535d51cba692b..369a698a0395effdba7f427f3bef74e8408cc43c 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=5
@@ -32,5 +32,7 @@ src_configure() {
 }
 
 src_test() {
-       autotools-utils_src_test -j1
+       autotools-utils_src_test -j1 \
+                                                        CFLAGS+=" -no-pie" \
+                                                        CXXFLAGS+=" -no-pie"
 }