dev-ruby/*: add missing 'versionator' inherit
authorSergei Trofimovich <slyfox@gentoo.org>
Sat, 20 Jul 2019 08:21:48 +0000 (09:21 +0100)
committerSergei Trofimovich <slyfox@gentoo.org>
Sat, 20 Jul 2019 09:21:36 +0000 (10:21 +0100)
Noticed failure when ran

 $ PORTAGE_ELOG_CLASSES="qa" egencache --repo=gentoo --update --update-use-local-desc --jobs=$(nproc)
 * ERROR: dev-ruby/rspec-expectations-3.7.0::gentoo failed (depend phase):
 *   External commands disallowed while sourcing ebuild: get_version_component_range 1-2
 *
 * Call stack:
 *                         ebuild.sh, line 624:  Called source '/gentoo-ebuilds/gentoo/dev-ruby/rspec-expectations/rspec-expectations-3.7.0.ebuild'
 *   rspec-expectations-3.7.0.ebuild, line  25:  Called command_not_found_handle 'get_version_component_range' '1-2'
 *                         ebuild.sh, line  89:  Called die
 * The specific snippet of code:
 *              die "External commands disallowed while sourcing ebuild: ${*}"

Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
dev-ruby/rspec-core/rspec-core-3.7.1.ebuild
dev-ruby/rspec-expectations/rspec-expectations-3.7.0.ebuild
dev-ruby/rspec-mocks/rspec-mocks-3.7.0.ebuild

index b04ba6011506df5bac1dc49fe9896d989f60eff6..dcaf66c0833c626be4eefa359f23b0ad6c7a9c17 100644 (file)
@@ -14,7 +14,7 @@ RUBY_FAKEGEM_EXTRAINSTALL="exe"
 
 RUBY_FAKEGEM_GEMSPEC="rspec-core.gemspec"
 
-inherit ruby-fakegem
+inherit ruby-fakegem versionator
 
 DESCRIPTION="A Behaviour Driven Development (BDD) framework for Ruby"
 HOMEPAGE="https://github.com/rspec/rspec-core"
index 4eb12ad1379a3fe89ec53ed1c89f69c89a4ad666..f7e06817c865b95fcb6c2e118338442adbaba721 100644 (file)
@@ -11,7 +11,7 @@ RUBY_FAKEGEM_EXTRADOC="Changelog.md README.md"
 
 RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
 
-inherit ruby-fakegem
+inherit ruby-fakegem versionator
 
 DESCRIPTION="A Behaviour Driven Development (BDD) framework for Ruby"
 HOMEPAGE="https://github.com/rspec/rspec-expectations"
index 0ff7248e354b97a25e1186bfa05a07ad94a016cd..c348ca0f575e92c5c367424cdb71dbef58492c10 100644 (file)
@@ -9,7 +9,7 @@ RUBY_FAKEGEM_RECIPE_TEST="rspec3"
 RUBY_FAKEGEM_RECIPE_DOC="none"
 RUBY_FAKEGEM_EXTRADOC="Changelog.md README.md"
 
-inherit ruby-fakegem
+inherit ruby-fakegem versionator
 
 DESCRIPTION="A Behaviour Driven Development (BDD) framework for Ruby"
 HOMEPAGE="https://github.com/rspec/rspec-mocks"