dev-python/sphinxcontrib-newsfeed: fix for sphinxcontrib namespace, added prefix...
authorSébastien Fabbro <bicatali@gentoo.org>
Wed, 2 Aug 2017 02:20:34 +0000 (02:20 +0000)
committerSébastien Fabbro <bicatali@gentoo.org>
Wed, 2 Aug 2017 04:06:25 +0000 (04:06 +0000)
Package-Manager: Portage-2.3.6, Repoman-2.3.3

dev-python/sphinxcontrib-newsfeed/sphinxcontrib-newsfeed-0.1.4.ebuild

index b31cfd58c28b02a237c17f62f0284206f460d037..b53938a825e987bf96cafa1aa0fa87d85d4ca5a3 100644 (file)
@@ -1,7 +1,7 @@
 # Copyright 1999-2017 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI=5
+EAPI=6
 PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
 
 inherit distutils-r1
@@ -12,14 +12,19 @@ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
 
 LICENSE="BSD-2"
 SLOT="0"
-KEYWORDS="~amd64 ~x86"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
 IUSE="examples"
 
 DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
-RDEPEND="dev-python/sphinx[${PYTHON_USEDEP}]"
+RDEPEND="dev-python/sphinx[${PYTHON_USEDEP}]
+       dev-python/namespace-sphinxcontrib[${PYTHON_USEDEP}]"
 
 python_install_all() {
-       use examples && local EXAMPLES=( demo/. )
-
        distutils-r1_python_install_all
+       find "${ED}" -name '*.pth' -delete || die
+       if use examples; then
+               insinto /usr/share/doc/${PF}/examples
+               doins -r demo/.
+               docompress -x /usr/share/doc/${PF}/examples
+       fi
 }