sys-apps/iproute2: QAfix emptydir /var/lib/arpd (take 2)
authorRobin H. Johnson <robbat2@gentoo.org>
Fri, 17 Apr 2020 19:39:33 +0000 (12:39 -0700)
committerRobin H. Johnson <robbat2@gentoo.org>
Fri, 17 Apr 2020 19:47:58 +0000 (12:47 -0700)
Also cleanup parent directories as much as possible.

Closes: https://bugs.gentoo.org/647032
Signed-off-by: Robin H. Johnson <robbat2@gentoo.org>
sys-apps/iproute2/iproute2-5.6.0.ebuild

index 7670dd448c2efcf4d99ec9afc02d49d935880771..622ac0d68948399aaa8bc90215fae5f1abbce31e 100644 (file)
@@ -159,6 +159,6 @@ src_install() {
                dodir /usr/bin
                mv "${ED}"/sbin/arpd "${ED}"/usr/bin/ || die
        elif [[ -d "${ED}"/var/lib/arpd ]]; then
-               rmdir "${ED}"/var/lib/arpd || die
+               rmdir --ignore-fail-on-non-empty -p "${ED}"/var/lib/arpd || die
        fi
 }