dev-perl/Carp-Assert-More: Bump to version 1.200.0
authorKent Fredric <kentnl@gentoo.org>
Thu, 21 May 2020 23:06:35 +0000 (11:06 +1200)
committerKent Fredric <kentnl@gentoo.org>
Thu, 21 May 2020 23:06:35 +0000 (11:06 +1200)
- EAPI7
- Remove bad tests unconditionally

Upstream:
- Add assert_datetime() for asserting DateTime objects
- Add assert_aoh() for asserting an arrayref of hashrefs

Package-Manager: Portage-2.3.99, Repoman-2.3.22
Signed-off-by: Kent Fredric <kentnl@gentoo.org>
dev-perl/Carp-Assert-More/Carp-Assert-More-1.200.0.ebuild [new file with mode: 0644]
dev-perl/Carp-Assert-More/Manifest

diff --git a/dev-perl/Carp-Assert-More/Carp-Assert-More-1.200.0.ebuild b/dev-perl/Carp-Assert-More/Carp-Assert-More-1.200.0.ebuild
new file mode 100644 (file)
index 0000000..05c4293
--- /dev/null
@@ -0,0 +1,41 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DIST_AUTHOR=PETDANCE
+DIST_VERSION=1.20
+inherit perl-module
+
+DESCRIPTION="convenience wrappers around Carp::Assert"
+
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~ppc ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+       virtual/perl-Carp
+       dev-perl/Carp-Assert
+       virtual/perl-Scalar-List-Utils
+"
+BDEPEND="${RDEPEND}
+       virtual/perl-ExtUtils-MakeMaker
+       test? (
+               dev-perl/Test-Exception
+       )
+"
+PERL_RM_FILES=(
+       "t/pod-coverage.t"
+       "t/pod.t"
+)
+src_test() {
+       perl-module_src_test
+       local MODULES=(
+               "Carp::Assert::More ${DIST_VERSION}"
+       )
+       for dep in "${MODULES[@]}"; do
+               perl -Mblib="${S}" -M"${dep} ()" -e1 ||
+                       die "Could not load ${dep}"
+       done
+}
index 47447242f6a2ef8f011869d06b6e265a3deefd7c..1394bfc74e06c0e2d47a1176952b12709f632984 100644 (file)
@@ -1 +1,2 @@
 DIST Carp-Assert-More-1.16.tar.gz 12290 BLAKE2B 818badbd216e70813993ea859796a16c531c767211ed6b294fab870dd342117b5445db73601f4fc955ec907d1340bfce6f17a784580bac8823a9d72153af38ea SHA512 9f81604574eab5a0a5003ad747ffec3a3dd33bc63e67d12697e4e30de8cb234a73e225f82a4d0f31576e19382cc2d6a402962f5fe1e4c5289e080ca23b30c0fe
+DIST Carp-Assert-More-1.20.tar.gz 13282 BLAKE2B aa85111f076f78d0de2e4568b2ddb3c1318c5dae76da3b29f442e07e7b4f729c62abf94bc320477f1c572c6ff64d87c30793fb64e88f0774cba873c7f5aa8ffd SHA512 9caacf2cc4acb190b071a7312e5e1cdee5a0b7a0e9db0efc6dca0fa19167524a3bd6beecc4bb8e68eace719fc1d918063e9d259a24cb28e81dd628ea75ba541b