app-misc/mosquitto: Drop old versions
authorMatt Turner <mattst88@gentoo.org>
Fri, 1 Nov 2019 19:58:22 +0000 (12:58 -0700)
committerMatt Turner <mattst88@gentoo.org>
Fri, 1 Nov 2019 19:59:09 +0000 (12:59 -0700)
Signed-off-by: Matt Turner <mattst88@gentoo.org>
app-misc/mosquitto/Manifest
app-misc/mosquitto/mosquitto-1.5.6.ebuild [deleted file]

index 84e48c74f074f8688c0b2a9a6819be9094fe9c43..ae2670ea268db49c755383060c137921435ba7de 100644 (file)
@@ -1,2 +1 @@
-DIST mosquitto-1.5.6.tar.gz 439402 BLAKE2B 7d887d7d2e02d9891613d441c76705c40744cd8c7acae330648e5a00560b4ba1fbc28b92ac84bf85d423c84de875c5309f364d04fca72516ab2276fe42512b0c SHA512 99bd935f93ae25f0c7992870780cce4748b35ffd58fd0d39e20ee69f34c28d3eac289cf0c7dec078dbdced3bda12da4569d4b5e84ebdaa5514640f331ca3238b
 DIST mosquitto-1.6.7.tar.gz 591062 BLAKE2B a215e311197fd84f1fa1ff0b681c8d1157db1a3e538a5a16afa1f11d17a08a720d44ae16b306cb08d6b585c8c4d4b2e38df972ceebc4634c727f4c8e0994c170 SHA512 0a75cf192483053ce78c6d9e3be158bdf66366d7731a68cf29e24731f6936027af1d86045c2b973f642e42e58efa033dbfd17842e3e95550bac4c1f44ab346e9
diff --git a/app-misc/mosquitto/mosquitto-1.5.6.ebuild b/app-misc/mosquitto/mosquitto-1.5.6.ebuild
deleted file mode 100644 (file)
index 6f319fe..0000000
+++ /dev/null
@@ -1,106 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-PYTHON_COMPAT=( python2_7 )
-
-inherit systemd user toolchain-funcs python-any-r1
-
-DESCRIPTION="An Open Source MQTT v3 Broker"
-HOMEPAGE="https://mosquitto.org/"
-SRC_URI="https://mosquitto.org/files/source/${P}.tar.gz"
-
-LICENSE="EPL-1.0"
-SLOT="0"
-KEYWORDS="amd64 arm x86"
-IUSE="bridge examples libressl +persistence +srv ssl tcpd test websockets"
-
-REQUIRED_USE="
-       test? ( bridge )
-"
-
-RDEPEND="tcpd? ( sys-apps/tcp-wrappers )
-       srv? ( net-dns/c-ares )
-       ssl? (
-               !libressl? ( dev-libs/openssl:0= )
-               libressl? ( dev-libs/libressl:0= )
-       )"
-DEPEND="${RDEPEND}
-       ${PYTHON_DEPS}
-       websockets? ( net-libs/libwebsockets )"
-
-_emake() {
-       LIBDIR=$(get_libdir)
-       emake \
-               CC="$(tc-getCC)" \
-               LIB_SUFFIX="${LIBDIR:3}" \
-               WITH_BRIDGE="$(usex bridge)" \
-               WITH_PERSISTENCE="$(usex persistence)" \
-               WITH_SRV="$(usex srv)" \
-               WITH_TLS="$(usex ssl)" \
-               WITH_WEBSOCKETS="$(usex websockets)" \
-               WITH_WRAP="$(usex tcpd)" \
-               "$@"
-}
-
-pkg_setup() {
-       enewgroup mosquitto
-       enewuser mosquitto -1 -1 -1 mosquitto
-}
-
-src_prepare() {
-       default
-       if use persistence; then
-               sed -i -e "/^#autosave_interval/s|^#||" \
-                       -e "s|^#persistence false$|persistence true|" \
-                       -e "/^#persistence_file/s|^#||" \
-                       -e "s|#persistence_location|persistence_location /var/lib/mosquitto/|" \
-                       mosquitto.conf || die
-       fi
-
-       # Remove prestripping
-       sed -i -e 's/-s --strip-program=${CROSS_COMPILE}${STRIP}//'\
-               client/Makefile lib/cpp/Makefile src/Makefile lib/Makefile || die
-
-       python_setup
-       rm test/{broker,lib}/ptest.py || die
-       python_fix_shebang test
-}
-
-src_compile() {
-       _emake
-}
-
-src_test() {
-       _emake test
-}
-
-src_install() {
-       _emake DESTDIR="${D}" prefix=/usr install
-       keepdir /var/lib/mosquitto
-       fowners mosquitto:mosquitto /var/lib/mosquitto
-       dodoc readme.md CONTRIBUTING.md ChangeLog.txt
-       doinitd "${FILESDIR}"/mosquitto
-       insinto /etc/mosquitto
-       doins mosquitto.conf
-       systemd_dounit "${FILESDIR}/mosquitto.service"
-
-       if use examples; then
-               docompress -x "/usr/share/doc/${PF}/examples"
-               docinto "/usr/share/doc/${PF}"
-               doins -r examples
-       fi
-}
-
-pkg_postinst() {
-       if [[ -z "${REPLACING_VERSIONS}" ]]; then
-               elog "The Python module has been moved out of mosquitto."
-               elog "See https://mosquitto.org/documentation/python/"
-       else
-               elog "To start the mosquitto daemon at boot, add it to the default runlevel with:"
-               elog ""
-               elog "    rc-update add mosquitto default"
-               elog "    or"
-               elog "    systemctl enable mosquitto"
-       fi
-}