x11-wm/windowmaker: drop old stable
authorBernard Cafarelli <voyageur@gentoo.org>
Tue, 7 Apr 2020 15:18:53 +0000 (17:18 +0200)
committerBernard Cafarelli <voyageur@gentoo.org>
Tue, 7 Apr 2020 15:18:53 +0000 (17:18 +0200)
Package-Manager: Portage-2.3.96, Repoman-2.3.22
Signed-off-by: Bernard Cafarelli <voyageur@gentoo.org>
x11-wm/windowmaker/Manifest
x11-wm/windowmaker/windowmaker-0.95.7.ebuild [deleted file]

index 0ed27da2d384cfa8a51f35975ae24ad41e65f20e..d1a8f49c43d74f5bc4893c368b23770a9dc589e3 100644 (file)
@@ -1,3 +1,2 @@
-DIST WindowMaker-0.95.7.tar.gz 3238325 BLAKE2B 68a26e8b1281a4ff387fa87517efb46995e5339e2e6e7f71303d3e3e0d75316740d2458067dc4159f23bf1e1b4e1e0bfc22b1428ee4933e4d474a79a147baaf7 SHA512 9c1190503efdc58c11a90d5ba80796979cdc9f2beb69a6d233ffc8d531a54c877c5270841bf6318738069098cd488e5ab77ac19f661ac888e892bf05ac22d93f
 DIST WindowMaker-0.95.8.tar.gz 3253515 BLAKE2B 225dae9eb10f913931e129fdf78860123a14406ad8e61ba42fe4eadcf5d3f03c88040a2b982e74abaf79088f4a063291ccfb7b7d42f1bf211adb7b02c765a664 SHA512 6ab16ed4304aba20f0f3a4083adf63a47fa674ade7bc39aaa8aa6466c7842e3f10ab73af96e2afce0842b11c57a35eb69f43183a4044d8cd95d4e2a4d2c079a2
 DIST WindowMaker-extra-0.1.tar.gz 238018 BLAKE2B 865b12975d0cdefc1f05a76344b449fdcf8a2841d6a7adf1ab6435857d89cbc4fda22bb62432a1bbba921267380d00a0cded718bfbd344bbb5e6207e59b76096 SHA512 0fe9b3ffc093942db167d8a01e15c0f6741f3a40959d1434ea4f23e7b9d4a9c13935a61eabef9691e5fdfd4e407564caafce15c2d65d66499960a6764a874ab8
diff --git a/x11-wm/windowmaker/windowmaker-0.95.7.ebuild b/x11-wm/windowmaker/windowmaker-0.95.7.ebuild
deleted file mode 100644 (file)
index 529214e..0000000
+++ /dev/null
@@ -1,104 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-inherit eutils
-
-DESCRIPTION="The fast and light GNUstep window manager"
-HOMEPAGE="http://www.windowmaker.org/"
-SRC_URI="http://windowmaker.org/pub/source/release/${P/windowm/WindowM}.tar.gz
-       http://www.windowmaker.org/pub/source/release/WindowMaker-extra-0.1.tar.gz"
-
-SLOT="0"
-LICENSE="GPL-2"
-IUSE="gif imagemagick jpeg modelock nls png tiff webp xinerama +xpm xrandr"
-KEYWORDS="~alpha amd64 ~arm hppa ~mips ppc ~ppc64 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
-
-DEPEND="media-libs/fontconfig
-       >=x11-libs/libXft-2.1.0
-       x11-libs/libXmu
-       x11-libs/libXpm
-       x11-libs/libXt
-       x11-libs/libXv
-       gif? ( >=media-libs/giflib-4.1.0-r3 )
-       imagemagick? ( media-gfx/imagemagick )
-       jpeg? ( virtual/jpeg:0= )
-       png? ( media-libs/libpng:0= )
-       tiff? ( media-libs/tiff:0 )
-       webp? ( media-libs/libwebp )
-       xinerama? ( x11-libs/libXinerama )
-       xrandr? ( x11-libs/libXrandr )"
-RDEPEND="${DEPEND}
-       nls? ( >=sys-devel/gettext-0.10.39 )"
-
-S=${WORKDIR}/${P/windowm/WindowM}
-
-src_prepare() {
-       # Fix some paths
-       for file in WindowMaker/*menu* util/wmgenmenu.c; do
-               if [[ -r $file ]] ; then
-                       sed -i -e "s:/usr/local/GNUstep/Applications/WPrefs.app:${EPREFIX}/usr/bin/:g;" "$file" || die
-                       sed -i -e "s:/usr/local/share/WindowMaker:${EPREFIX}/usr/share/WindowMaker:g;" "$file" || die
-                       sed -i -e "s:/opt/share/WindowMaker:${EPREFIX}/usr/share/WindowMaker:g;" "$file" || die
-               fi;
-       done;
-}
-
-src_configure() {
-       local myconf
-
-       # image format types
-       myconf="$(use_enable imagemagick magick) $(use_enable jpeg) $(use_enable gif) $(use_enable png) $(use_enable tiff) $(use_enable webp) $(use_enable xpm)"
-
-       # non required X capabilities
-       myconf="${myconf} $(use_enable modelock) $(use_enable xrandr randr) $(use_enable xinerama)"
-
-       if use nls; then
-               [[ -z $LINGUAS ]] && export LINGUAS="$(ls po/*.po | sed 's:po/\(.*\)\.po$:\1:' | xargs)"
-       else
-               myconf="${myconf} --disable-locale"
-       fi
-
-       # default settings with $myconf appended
-       econf \
-               --sysconfdir="${EPREFIX}"/etc/X11 \
-               --with-x \
-               --enable-usermenu \
-               --with-pixmapdir="${EPREFIX}"/usr/share/pixmaps \
-               --localedir="${EPREFIX}"/usr/share/locale \
-               ${myconf}
-
-       cd ../WindowMaker-extra-0.1
-       econf
-}
-
-src_compile() {
-       emake
-
-       # WindowMaker Extra Package (themes and icons)
-       cd ../WindowMaker-extra-0.1
-       emake
-}
-
-src_install() {
-       emake DESTDIR="${D}" install
-
-       dodoc AUTHORS BUGFORM BUGS ChangeLog INSTALL* FAQ* \
-                 README* NEWS TODO
-
-       # WindowMaker Extra
-       cd ../WindowMaker-extra-0.1
-       emake DESTDIR="${D}" install
-
-       newdoc README README.extra
-
-       # create wmaker session shell script
-       echo "#!/usr/bin/env bash" > wmaker
-       echo "${EPREFIX}/usr/bin/wmaker" >> wmaker
-       exeinto /etc/X11/Sessions/
-       doexe wmaker
-
-       insinto /usr/share/xsessions
-       doins "${FILESDIR}"/wmaker.desktop
-       make_desktop_entry /usr/bin/wmaker
-}