dev-python/debtcollector: adding for liberty
authorMatthew Thode <mthode@mthode.org>
Tue, 1 Sep 2015 15:24:15 +0000 (10:24 -0500)
committerMatthew Thode <mthode@mthode.org>
Tue, 1 Sep 2015 15:24:15 +0000 (10:24 -0500)
Package-Manager: portage-2.2.20.1

dev-python/debtcollector/Manifest [new file with mode: 0644]
dev-python/debtcollector/debtcollector-0.7.0.ebuild [new file with mode: 0644]
dev-python/debtcollector/metadata.xml [new file with mode: 0644]

diff --git a/dev-python/debtcollector/Manifest b/dev-python/debtcollector/Manifest
new file mode 100644 (file)
index 0000000..63e4627
--- /dev/null
@@ -0,0 +1 @@
+DIST debtcollector-0.7.0.tar.gz 17151 SHA256 03ef06604e666a9f4a1506ffcfa887068bdb9f16e33657f9211a7b4e8bc753ea SHA512 684bea62b17843717c6aa19f36e538bd62bfe101693394eb66d6d6f408f32a0c9e458dee8c81324f4503fab952b73654f2eca24c51ef67594c51657fcdca9dad WHIRLPOOL 32cb704719ae3ea00f3d5e4e1df225604e226c5c4882afcf136fdfe035c367b334f1409c35b079214f8ab8b04608ef8a1f648a38632fc9fef9a8f312ce76d3c0
diff --git a/dev-python/debtcollector/debtcollector-0.7.0.ebuild b/dev-python/debtcollector/debtcollector-0.7.0.ebuild
new file mode 100644 (file)
index 0000000..fae6fae
--- /dev/null
@@ -0,0 +1,65 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 python3_3 python3_4 )
+
+inherit distutils-r1
+
+DESCRIPTION="... Python deprecation patterns and strategies that help you collect your technical debt ...."
+HOMEPAGE="http://www.openstack.org/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc test"
+
+CDEPEND="
+       >=dev-python/pbr-1.6[${PYTHON_USEDEP}]
+       <dev-python/pbr-2.0[${PYTHON_USEDEP}]
+"
+DEPEND="
+       dev-python/setuptools[${PYTHON_USEDEP}]
+       ${CDEPEND}
+       test? (
+               >=dev-python/subunit-0.0.18[${PYTHON_USEDEP}]
+               >=dev-python/oslotest-1.9.0[${PYTHON_USEDEP}]
+               >=dev-python/testrepository-0.0.18[${PYTHON_USEDEP}]
+               >=dev-python/testscenarios-0.4[${PYTHON_USEDEP}]
+               !~dev-python/testtools-1.4.0[${PYTHON_USEDEP}]
+       )
+       doc? (
+               >=dev-python/oslo-sphinx-2.5.0[${PYTHON_USEDEP}]
+               >=dev-python/sphinx-1.1.2[${PYTHON_USEDEP}]
+               !~dev-python/sphinx-1.2.0[${PYTHON_USEDEP}]
+               <dev-python/sphinx-1.3[${PYTHON_USEDEP}]
+       )
+"
+RDEPEND="
+       ${CDEPEND}
+       >=dev-python/Babel-1.3[${PYTHON_USEDEP}]
+       >=dev-python/six-1.9.0[${PYTHON_USEDEP}]
+       >=dev-python/wrapt-1.7.0[${PYTHON_USEDEP}]
+"
+
+python_compile_all() {
+       sed -i '/^hacking/d' test-requirements.txt || die
+       use doc && esetup.py build_sphinx
+}
+
+python_test() {
+       distutils_install_for_testing
+
+       rm -rf .testrepository || die "couldn't remove '.testrepository' under ${EPYTHON}"
+
+       testr init || die "testr init failed under ${EPYTHON}"
+       testr run || die "testr run failed under ${EPYTHON}"
+}
+
+python_install_all() {
+       use doc && local HTML_DOCS=( docs/build/html/. )
+
+       distutils-r1_python_install_all
+}
diff --git a/dev-python/debtcollector/metadata.xml b/dev-python/debtcollector/metadata.xml
new file mode 100644 (file)
index 0000000..d5dfd32
--- /dev/null
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+       <maintainer>
+               <email>prometheanfire@gentoo.org</email>
+               <name>Matthew Thode</name>
+       </maintainer>
+       <longdescription lang="en">
+       </longdescription>
+</pkgmetadata>