Change which to type -P for QA.
authorChris Gianelloni <wolf31o2@gentoo.org>
Tue, 13 Mar 2007 01:30:25 +0000 (01:30 +0000)
committerChris Gianelloni <wolf31o2@gentoo.org>
Tue, 13 Mar 2007 01:30:25 +0000 (01:30 +0000)
Package-Manager: portage-2.1.2.1

games-fps/doomsday/ChangeLog
games-fps/doomsday/doomsday-1.9.0_beta5.ebuild
games-fps/quake2-icculus/ChangeLog
games-fps/quake2-icculus/quake2-icculus-0.16.1-r1.ebuild
games-fps/quake2-icculus/quake2-icculus-0.16.1.ebuild

index c3ac020d480a309b314145007582af1df049121e..bf28ad60f19f41ed12e6ad49afe4560ba41b244b 100644 (file)
@@ -1,6 +1,10 @@
 # ChangeLog for games-fps/doomsday
 # Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-fps/doomsday/ChangeLog,v 1.20 2007/02/01 23:57:06 nyhm Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-fps/doomsday/ChangeLog,v 1.21 2007/03/13 01:29:19 wolf31o2 Exp $
+
+  13 Mar 2007; Chris Gianelloni <wolf31o2@gentoo.org>
+  doomsday-1.9.0_beta5.ebuild:
+  Change which to type -P for QA.
 
 *doomsday-1.9.0_beta5 (01 Feb 2007)
 
index 89e9007fc5bd13a53f190e62f126ef897ddd0e0e..0ed3e6cef05d6972671681efb097692e2b65f3fd 100644 (file)
@@ -1,6 +1,6 @@
 # Copyright 1999-2007 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-fps/doomsday/doomsday-1.9.0_beta5.ebuild,v 1.1 2007/02/01 23:57:06 nyhm Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-fps/doomsday/doomsday-1.9.0_beta5.ebuild,v 1.2 2007/03/13 01:29:19 wolf31o2 Exp $
 
 inherit toolchain-funcs games
 
@@ -29,7 +29,7 @@ S=${WORKDIR}/${MY_P}/${PN}/build
 
 src_compile() {
        cmake \
-               -DCMAKE_C_COMPILER=$(which $(tc-getCC)) \
+               -DCMAKE_C_COMPILER=$(type -P $(tc-getCC)) \
                -DCMAKE_INSTALL_PREFIX=/usr \
                -Ddatadir="${GAMES_DATADIR}"/${PN} \
                -Dbindir="${GAMES_BINDIR}" \
index 159fa1115c7febafbc08ae51b4a231d975c72d50..3309928cf42fac49b32c93d06640e35cdf5f5ab7 100644 (file)
@@ -1,6 +1,10 @@
 # ChangeLog for games-fps/quake2-icculus
 # Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-fps/quake2-icculus/ChangeLog,v 1.26 2007/02/22 00:01:50 peper Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-fps/quake2-icculus/ChangeLog,v 1.27 2007/03/13 01:30:25 wolf31o2 Exp $
+
+  13 Mar 2007; Chris Gianelloni <wolf31o2@gentoo.org>
+  quake2-icculus-0.16.1.ebuild, quake2-icculus-0.16.1-r1.ebuild:
+  Change which to type -P for QA.
 
   22 Feb 2007; Piotr JaroszyƄski <peper@gentoo.org> ChangeLog:
   Transition to Manifest2.
index 8bba40af396f523804a9030414db5287d89ae7c6..479f06230b401d5250b70bdd6e98066b1564244a 100644 (file)
@@ -1,6 +1,6 @@
 # Copyright 1999-2007 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-fps/quake2-icculus/quake2-icculus-0.16.1-r1.ebuild,v 1.4 2007/01/09 23:34:10 wolf31o2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-fps/quake2-icculus/quake2-icculus-0.16.1-r1.ebuild,v 1.5 2007/03/13 01:30:25 wolf31o2 Exp $
 
 inherit eutils toolchain-funcs games
 
@@ -69,7 +69,7 @@ src_unpack() {
        epatch "${FILESDIR}"/${P}-gentoo-paths.patch
 
        # Now we deal with the silly rogue / xatrix addons ... this is ugly :/
-       ln -s $(which echo) "${T}"/more
+       ln -s $(type -P echo) "${T}"/more
        for g in rogue xatrix ; do
                use ${g} || continue
                mkdir -p "${S}"/src/${g}
index 436a35445adf026763a4ea0f8b3e30cd9028df9c..6d0959eafb03210a2d24381c3547df46722e2610 100644 (file)
@@ -1,6 +1,6 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-fps/quake2-icculus/quake2-icculus-0.16.1.ebuild,v 1.17 2006/12/05 17:22:39 wolf31o2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-fps/quake2-icculus/quake2-icculus-0.16.1.ebuild,v 1.18 2007/03/13 01:30:25 wolf31o2 Exp $
 
 inherit eutils toolchain-funcs games
 
@@ -48,7 +48,7 @@ src_unpack() {
        epatch "${FILESDIR}"/${P}-gentoo-paths.patch
 
        # Now we deal with the silly rogue / xatrix addons ... this is ugly :/
-       ln -s $(which echo) "${T}"/more
+       ln -s $(type -P echo) "${T}"/more
        for g in rogue xatrix ; do
                use ${g} || continue
                mkdir -p "${S}"/src/${g}