app-crypt/libnitrokey: Remove old
authorDavid Seifert <soap@gentoo.org>
Mon, 8 Jul 2019 07:51:12 +0000 (09:51 +0200)
committerDavid Seifert <soap@gentoo.org>
Mon, 8 Jul 2019 07:51:12 +0000 (09:51 +0200)
Package-Manager: Portage-2.3.68, Repoman-2.3.16
Signed-off-by: David Seifert <soap@gentoo.org>
app-crypt/libnitrokey/Manifest
app-crypt/libnitrokey/libnitrokey-3.3.ebuild [deleted file]

index 800ed44bbad8f2259a120e50e3a0d013d3e10224..abed557f9936e66acacea5f406d8502cb6407ad5 100644 (file)
@@ -1,2 +1 @@
-DIST libnitrokey-3.3.tar.gz 76581 BLAKE2B 1a662fb94184355dc5cae2f8e3109fc82a96aed06c726e04c4fcfef3aef0423150ac1f4647e4bf3585de7805e70cd67534d72f1255c9f80b57afa2aec36fc9d3 SHA512 fe3b6c7bdeb78f736fe7aa7475880a293c516119ac049ff47ddbaba626f2d70addee4d0cd3a38ea706b94717f51c4fb56f687d5a9bb9f10895836c5adc98b11b
 DIST libnitrokey-3.5.tar.gz 94356 BLAKE2B 9e53213f309e903d26e0e8e01ab213d6bc42c5b8d720e4b19f27adb607f20ad0c6e1707bf7b55c525efbd6a4fbf7b9c87983decf6b05dab7d03701ae0ea8277f SHA512 d2a95071e92d839c8cde4ac1435158bb469c25662f2988a4e824dbc0dfe83af841e6d04589293deddd77746dbec17b30c50fab69af58cc727ed5e0f2dbd0b5e7
diff --git a/app-crypt/libnitrokey/libnitrokey-3.3.ebuild b/app-crypt/libnitrokey/libnitrokey-3.3.ebuild
deleted file mode 100644 (file)
index a9e23e3..0000000
+++ /dev/null
@@ -1,50 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-: ${CMAKE_MAKEFILE_GENERATOR:=ninja}
-inherit cmake-utils udev
-
-DESCRIPTION="Support library for the Nitrokey"
-HOMEPAGE="https://github.com/Nitrokey/libnitrokey"
-
-if [[ ${PV} == *9999 ]]; then
-       inherit git-r3
-       EGIT_REPO_URI="https://github.com/Nitrokey/libnitrokey.git"
-
-       # Disable pulling in bundled dependencies
-       EGIT_SUBMODULES=()
-else
-       SRC_URI="https://github.com/Nitrokey/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-       KEYWORDS="~amd64"
-fi
-
-LICENSE="GPL-3"
-SLOT="0"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
-       dev-libs/hidapi:=
-       virtual/udev"
-DEPEND="
-       ${RDEPEND}
-       virtual/pkgconfig
-       test? ( >=dev-cpp/catch-2.2.0:0 )"
-
-src_configure() {
-       local mycmakeargs=(
-               -DCMAKE_INSTALL_UDEVRULESDIR="$(get_udevdir)"/rules.d
-               -DCMAKE_INSTALL_DOCDIR="share/doc/${PF}"
-               -DBUILD_SHARED_LIBS=ON
-
-               # actual hardware tests
-               #   1. require a connected Nitrokey
-               #   2. may kill data on your Nitrokey
-               # hence the main testsuite is disabled
-               -DCOMPILE_TESTS=OFF
-               -DCOMPILE_OFFLINE_TESTS=$(usex test)
-       )
-       cmake-utils_src_configure
-}