ros-meta/ament_cmake: specify transitive deps for usedeps
authorAlexis Ballier <aballier@gentoo.org>
Fri, 13 Dec 2019 12:13:29 +0000 (13:13 +0100)
committerAlexis Ballier <aballier@gentoo.org>
Fri, 13 Dec 2019 12:13:29 +0000 (13:13 +0100)
Package-Manager: Portage-2.3.81, Repoman-2.3.20
Signed-off-by: Alexis Ballier <aballier@gentoo.org>
ros-meta/ament_cmake/ament_cmake-0.8.1.ebuild
ros-meta/ament_cmake/ament_cmake-9999.ebuild

index 9424ebe9198e6c3bd7f7a645b25fc587743e40bf..916839c82df121f29f7d1aedfe028ee45134ea34 100644 (file)
@@ -44,7 +44,11 @@ DEPEND="
        dev-ros/ament_cmake_test[${PYTHON_USEDEP}]
        dev-ros/ament_cmake_version[${PYTHON_USEDEP}]
        ${PYTHON_DEPS}
+
+       dev-python/ament_package[${PYTHON_USEDEP}]
+       dev-python/catkin_pkg[${PYTHON_USEDEP}]
 "
+# Last batch of deps above are transitive (from ament_cmake_core) but we need this to propagate proper deps
 RDEPEND="${DEPEND}"
 BDEPEND="${DEPEND}"
 REQUIRED_USE="${PYTHON_REQUIRED_USE}"
index 9424ebe9198e6c3bd7f7a645b25fc587743e40bf..916839c82df121f29f7d1aedfe028ee45134ea34 100644 (file)
@@ -44,7 +44,11 @@ DEPEND="
        dev-ros/ament_cmake_test[${PYTHON_USEDEP}]
        dev-ros/ament_cmake_version[${PYTHON_USEDEP}]
        ${PYTHON_DEPS}
+
+       dev-python/ament_package[${PYTHON_USEDEP}]
+       dev-python/catkin_pkg[${PYTHON_USEDEP}]
 "
+# Last batch of deps above are transitive (from ament_cmake_core) but we need this to propagate proper deps
 RDEPEND="${DEPEND}"
 BDEPEND="${DEPEND}"
 REQUIRED_USE="${PYTHON_REQUIRED_USE}"