net-libs/ldns: fix build with perl 5.22
authorMarc Schiffbauer <mschiff@gentoo.org>
Tue, 11 Aug 2015 18:14:55 +0000 (20:14 +0200)
committerMarc Schiffbauer <mschiff@gentoo.org>
Tue, 11 Aug 2015 18:27:18 +0000 (20:27 +0200)
Fixes #554982. Thanks to Paolo Pedroni for the patch.

Signed-off-by: Marc Schiffbauer <mschiff@gentoo.org>
net-libs/ldns/files/ldns-1.6.17_perl522.patch [new file with mode: 0644]
net-libs/ldns/ldns-1.6.17.ebuild

diff --git a/net-libs/ldns/files/ldns-1.6.17_perl522.patch b/net-libs/ldns/files/ldns-1.6.17_perl522.patch
new file mode 100644 (file)
index 0000000..ef9c82c
--- /dev/null
@@ -0,0 +1,11 @@
+--- a/doc/doxyparse.pl 2014-01-10 22:04:41.000000000 +0100
++++ b/doc/doxyparse.pl 2015-07-15 18:31:33.744755996 +0200
+@@ -273,7 +273,7 @@
+       print MAN $MAN_MIDDLE;
+-      if (defined(@$also)) {
++      if (@$also) {
+               print MAN "\n.SH SEE ALSO\n\\fI";
+               print MAN join "\\fR, \\fI", @$also;
+               print MAN "\\fR.\nAnd ";
index 97e28ad61c0e4cadc973fe0ddbe1835b167545c1..64bbea885ccdfbbf726d2cde31866cdc73fad27c 100644 (file)
@@ -42,6 +42,10 @@ pkg_setup() {
        use python && python-single-r1_pkg_setup
 }
 
+src_prepare() {
+       epatch "${FILESDIR}/${P}_perl522.patch"
+}
+
 multilib_src_configure() {
        ECONF_SOURCE=${S} \
        econf \