kde-apps/kopete: Fix DEPEND, silence cmake warnings
authorAndreas Sturmlechner <asturm@gentoo.org>
Tue, 28 Mar 2017 12:15:38 +0000 (14:15 +0200)
committerAndreas Sturmlechner <asturm@gentoo.org>
Tue, 28 Mar 2017 12:16:20 +0000 (14:16 +0200)
Package-Manager: Portage-2.3.3, Repoman-2.3.1

kde-apps/kopete/kopete-16.12.3-r1.ebuild

index fb5807f9319dcdd02b5cd9ad0978602d6e3c433b..be9563fab702225f0d3b52b7cab9d86112722034 100644 (file)
@@ -86,7 +86,6 @@ COMMONDEPEND="
                dev-libs/expat
                dev-libs/openssl:0
                >=media-libs/mediastreamer-2.3.0
-               media-libs/speex
                net-libs/libsrtp:=
                net-libs/ortp:=
        )
@@ -107,6 +106,7 @@ COMMONDEPEND="
        yahoo? ( media-libs/jasper )
 "
 RDEPEND="${COMMONDEPEND}
+       jingle? ( media-libs/speex )
        latex? (
                virtual/imagemagick-tools
                virtual/latex-base
@@ -123,17 +123,16 @@ src_configure() {
        local x x2
        # Handle common stuff
        local mycmakeargs=(
-               -DWITH_GOOGLETALK=$(usex jingle)
                -DWITH_LiboRTP=$(usex jingle)
                -DWITH_Mediastreamer=$(usex jingle)
-               -DWITH_Speex=$(usex jingle)
                -DDISABLE_VIDEOSUPPORT=$(usex !v4l)
        )
        # enable protocols
        for x in ${PROTOCOLS}; do
                case ${x/+/} in
-                       zeroconf) x2=bonjour ;;
+                       jingle) x2=libjingle ;;
                        xmpp) x2=jabber ;;
+                       zeroconf) x2=bonjour ;;
                        *) x2=${x/+/} ;;
                esac
                mycmakeargs+=( -DWITH_${x2}=$(usex ${x/+/}) )