dev-perl/Archive-Zip: Bump to version 1.680.0
authorKent Fredric <kentnl@gentoo.org>
Tue, 28 Apr 2020 17:22:29 +0000 (05:22 +1200)
committerKent Fredric <kentnl@gentoo.org>
Tue, 28 Apr 2020 17:23:08 +0000 (05:23 +1200)
- EAPI7
- Add app-arch/unzip for tests
- Dropped keywords:
  - amd64-linux m68k-mint ppc-aix
    sparc-solaris sparc64-solaris x64-solaris x86-solaris
    ppc-macos x64-macos x86-macos
  - Due to app-arch/unzip

Upstream:
- Fix for members using bzip compression
- Expect NetBSD unzip not minding empty zips
- Add diag for Solaris test failures
- Fix skip line for Windows
- Skip tests that assume /tmp on windows
- Improved Zip64 support
- Set 'compressedSize' after writing central directory header
- Add $noFormatError parameter for _readSignature
- Add error handling for failing object conversion after calling
  A:Z:Member::_become
- A:Z:{Archive,Member}::contents now consistently returns a
  ($contents,$status) in list context, and just $contents in scalar
  context
- A:Z:Member::extractToFileHandle now supports file names when
  extracting symbolic links
- Remove need for Test::MockModule
- examples/zipcheck.pl now skips symbolic links
- Tests now less picky about OS-specific unzip -t quirks
- Various other test suite overhauls and improvements

Package-Manager: Portage-2.3.97, Repoman-2.3.22
Signed-off-by: Kent Fredric <kentnl@gentoo.org>
dev-perl/Archive-Zip/Archive-Zip-1.680.0.ebuild [new file with mode: 0644]
dev-perl/Archive-Zip/Manifest

diff --git a/dev-perl/Archive-Zip/Archive-Zip-1.680.0.ebuild b/dev-perl/Archive-Zip/Archive-Zip-1.680.0.ebuild
new file mode 100644 (file)
index 0000000..2844488
--- /dev/null
@@ -0,0 +1,33 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DIST_AUTHOR=PHRED
+DIST_VERSION=1.68
+DIST_EXAMPLES=("examples/*")
+inherit perl-module
+
+DESCRIPTION="A wrapper that lets you read Zip archive members as if they were files"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x86-linux"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+       >=virtual/perl-Compress-Raw-Zlib-2.17.0
+       virtual/perl-Encode
+       virtual/perl-File-Path
+       >=virtual/perl-File-Spec-0.800.0
+       virtual/perl-File-Temp
+       virtual/perl-IO
+       virtual/perl-Time-Local
+"
+BDEPEND="${RDEPEND}
+       virtual/perl-ExtUtils-MakeMaker
+       test? (
+               app-arch/unzip
+               >=virtual/perl-Test-Simple-0.880.0
+       )
+"
index ef3c8d4d559b5e17da9de5fcc70a9a191df51515..fe9c26cf3075ba856a6cee6b89d93417ecaac86b 100644 (file)
@@ -1 +1,2 @@
 DIST Archive-Zip-1.64.tar.gz 192005 BLAKE2B 0a9d4c9a7b74fe2136fe42cd10b667813e6528129452b7db72dc42af56ec7187491365ae65653bd475afeaa55440370c23a06ff842d9ebb3dbeaaaab14527ca3 SHA512 7ae4c87ad50b30e764a79ada8f39ea2d698cfba957294d28dc15a2f3b2497923266a00574c5e43ddd59d6ec76d911f39007851920e0f09bfe3f466d46e17d6fc
+DIST Archive-Zip-1.68.tar.gz 163490 BLAKE2B e40d1c029aaf96214cfd91eb56fc200e4128d482d3d05f8e0a787014c9e124bf3618d53ad62a67f32a5404e8b4683cc63aec748c51934199597e7c22a8b1f24f SHA512 40c3ba26b1c27a8b15b919934e7fcd531f208bec73de3454e123ac1fb771831e287b8fade421be40e243498beb6dad9b6133ef07d2e5d407afbd1f3d6a30b916