games-rpg/sakura-spirit: New package
authorJames Le Cuirot <chewi@gentoo.org>
Sun, 7 Jul 2019 20:11:46 +0000 (21:11 +0100)
committerJames Le Cuirot <chewi@gentoo.org>
Sun, 7 Jul 2019 20:11:46 +0000 (21:11 +0100)
Package-Manager: Portage-2.3.68, Repoman-2.3.13
Signed-off-by: James Le Cuirot <chewi@gentoo.org>
games-rpg/sakura-spirit/Manifest [new file with mode: 0644]
games-rpg/sakura-spirit/metadata.xml [new file with mode: 0644]
games-rpg/sakura-spirit/sakura-spirit-0.ebuild [new file with mode: 0644]

diff --git a/games-rpg/sakura-spirit/Manifest b/games-rpg/sakura-spirit/Manifest
new file mode 100644 (file)
index 0000000..dbec862
--- /dev/null
@@ -0,0 +1 @@
+DIST Sakura_Spirit-linux.tar 132434253 BLAKE2B a8ea7d111b755cdcf82ca8e4d8cd1c4a41aed661998f77eefd237f748c187e77f43de701f203a97ca24b98665a7a876c458f67646e8f100c014178d8adb58790 SHA512 94c42c7252fd871915ef89535d3d28321496f3e813fd71e9fa6bf3c264421b9c10c445dff1fef64f63d60255e89fb2c1085351c85d5c1279467134e5ef5e7011
diff --git a/games-rpg/sakura-spirit/metadata.xml b/games-rpg/sakura-spirit/metadata.xml
new file mode 100644 (file)
index 0000000..26079e6
--- /dev/null
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+       <maintainer type="project">
+               <email>games@gentoo.org</email>
+               <name>Gentoo Games Project</name>
+       </maintainer>
+</pkgmetadata>
diff --git a/games-rpg/sakura-spirit/sakura-spirit-0.ebuild b/games-rpg/sakura-spirit/sakura-spirit-0.ebuild
new file mode 100644 (file)
index 0000000..2cc4e8c
--- /dev/null
@@ -0,0 +1,41 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit desktop eutils xdg-utils
+
+RENPY_SLOT="6.99"
+MY_PN="Sakura Spirit"
+
+DESCRIPTION="Adult-themed visual novel and dating simulator set in Japan"
+HOMEPAGE="http://wingedcloud.com"
+SRC_URI="${MY_PN/ /_}-linux.tar"
+LICENSE="all-rights-reserved"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+RESTRICT="bindist fetch"
+
+RDEPEND="games-engines/renpy:${RENPY_SLOT}"
+
+S="${WORKDIR}/${MY_PN/ /_}-linux"
+
+pkg_nofetch() {
+       einfo "If you have ${SRC_URI} as distributed by Humble Bundle then move"
+       einfo "it to your distfiles directory. If you have some other version then"
+       einfo "please contact the Gentoo Games team."
+}
+
+src_install() {
+       insinto /usr/share/${PN}
+       doins -r game/*
+
+       make_wrapper ${PN} "renpy-${RENPY_SLOT} '${EPREFIX}/usr/share/${PN}'"
+       make_desktop_entry ${PN} "${MY_PN}" applications-games
+
+       docinto html
+       dodoc README.html
+}
+
+pkg_postinst() { xdg_icon_cache_update; }
+pkg_postrm() { xdg_icon_cache_update; }