app-admin/testdisk: cleanup per bug 548258
authorRobin H. Johnson <robbat2@gentoo.org>
Mon, 14 Sep 2015 01:40:00 +0000 (18:40 -0700)
committerRobin H. Johnson <robbat2@gentoo.org>
Mon, 14 Sep 2015 01:40:00 +0000 (18:40 -0700)
X-Gentoo-Bug: 548258
Signed-off-by: Robin H. Johnson <robbat2@gentoo.org>
app-admin/testdisk/Manifest
app-admin/testdisk/testdisk-6.12.ebuild [deleted file]
app-admin/testdisk/testdisk-6.13.ebuild [deleted file]
app-admin/testdisk/testdisk-6.14-r1.ebuild [deleted file]
app-admin/testdisk/testdisk-6.14-r2.ebuild [deleted file]
app-admin/testdisk/testdisk-6.14.ebuild [deleted file]

index 945fff01816f8ad4e5867244d967e7fe11c5e383..2f2df7b27b63aacb11491199887870ce5ea7b8d4 100644 (file)
@@ -1,4 +1 @@
-DIST testdisk-6.12.tar.bz2 554633 SHA256 bdfbe679146518a1321d64f512d6ec8980ac3a9f2296ef27a46c7743d0f9ea16 SHA512 5cd17d1ad851515dcd1f3ef5dfb7435aff2f89e2b0467e84552809d203688a47731e23a602dc10355861414eb2d8c6b9edd48225ccc6229ab59810803a59da4c WHIRLPOOL f667fa6e61990cd6c6532301e461fc1cdcd9303a96566cc501dc1945fd9328b234b8c3f5a760a839a9d4b026da29d03c3189fa9afc58b7f7efa6e96b15008a49
-DIST testdisk-6.13.tar.bz2 560696 SHA256 48275ccddfc9445b6c3e6e181728dae9e49bd25b824a6b5670d58f1f88cdf220 SHA512 30889b8afed5b0fac93ce028e8c95bfa3e14b72d39cc4f86659edcce0b8820c5ce0c2b7e1d09f23f0da977b5d1cb275551069a87b109d05538e63e9b76200442 WHIRLPOOL b9bcf93df5b42a26b4206969ee968122f194338a28c6a500e540e3cafec2ae84d0734624c58b3581fc9ac71f2ea1038f2997e3f91278d6eed18abf786cd31200
-DIST testdisk-6.14.tar.bz2 620077 SHA256 a597c3ebc375acdf0ff60f44ed8935a301132aae78ec00f64f091637d055326c SHA512 f479c7863e1a39bf747a0b73b37eba1016e4762373b9b68747fed6141aa8faa7703c89dddc975df18904759292cd7d333ca0619eacb3c1eea76790a917e95774 WHIRLPOOL def7c9506747c68e5fb786ab0725c8ca2e15ccd53fc7f336d77f72067a6a6094c716c57ec3652a8386bf176b40e2fb1504925c6734bc3037799a4bbef3c8e67d
 DIST testdisk-7.0.tar.bz2 676990 SHA256 00bb3b6b22e6aba88580eeb887037aef026968c21a87b5f906c6652cbee3442d SHA512 b1ebe1d2fca453660a17623b70c06e0195cb5f07056fb7bc683d575c034fb71dfb793582c804dcff0ca57789a6de84bbf13b1a554353811660996e42199102e2 WHIRLPOOL 9ef3ed733f13477435123089cbd6168c189591284aa72dc9636470b35a21a32222d6871916b43e3c2ba4ac6da85979d6ec249b22c2573b77db7b2bcc280b85f1
diff --git a/app-admin/testdisk/testdisk-6.12.ebuild b/app-admin/testdisk/testdisk-6.12.ebuild
deleted file mode 100644 (file)
index 5a33676..0000000
+++ /dev/null
@@ -1,59 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=4
-
-inherit eutils flag-o-matic
-
-DESCRIPTION="Checks and undeletes partitions + PhotoRec, signature based recovery tool"
-HOMEPAGE="http://www.cgsecurity.org/wiki/TestDisk"
-SRC_URI="http://www.cgsecurity.org/${P}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 ppc x86"
-IUSE="jpeg ntfs reiserfs static"
-
-# WARNING: reiserfs support does NOT work with reiserfsprogs
-# you MUST use progsreiserfs-0.3.1_rc8 (the last version ever released).
-DEPEND="
-               >=sys-libs/ncurses-5.2
-               jpeg? ( virtual/jpeg )
-               ntfs? ( sys-fs/ntfs3g )
-               reiserfs? ( >=sys-fs/progsreiserfs-0.3.1_rc8 )
-               >=sys-fs/e2fsprogs-1.35
-               sys-libs/zlib"
-RDEPEND="!static? ( ${DEPEND} )"
-
-src_configure() {
-       local myconf
-
-       # this is static method is the same used by upstream for their 'static' make
-       # target, but better, as it doesn't break.
-       use static && append-ldflags -static
-
-       # --with-foo are broken, any use of --with/--without disable the
-       # functionality.
-       # The following variation must be used.
-       use reiserfs || myconf+=" --without-reiserfs"
-       use ntfs || myconf+=" --without-ntfs"
-       use jpeg || myconf+=" --without-jpeg"
-
-       econf \
-               --docdir="${ED}/usr/share/doc/${PF}" \
-               --without-ewf \
-               --enable-sudo \
-               ${myconf}
-
-       # perform safety checks for NTFS, REISERFS and JPEG
-       if use ntfs && ! egrep -q '^#define HAVE_LIBNTFS(3G)? 1$' "${S}"/config.h ; then
-               die "Failed to find either NTFS or NTFS-3G library."
-       fi
-       if use reiserfs && egrep -q 'undef HAVE_LIBREISERFS\>' "${S}"/config.h ; then
-               die "Failed to find reiserfs library."
-       fi
-       if use jpeg && egrep -q 'undef HAVE_LIBJPEG\>' "${S}"/config.h ; then
-               die "Failed to find jpeg library."
-       fi
-}
diff --git a/app-admin/testdisk/testdisk-6.13.ebuild b/app-admin/testdisk/testdisk-6.13.ebuild
deleted file mode 100644 (file)
index fd2eafa..0000000
+++ /dev/null
@@ -1,59 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=4
-
-inherit eutils flag-o-matic
-
-DESCRIPTION="Checks and undeletes partitions + PhotoRec, signature based recovery tool"
-HOMEPAGE="http://www.cgsecurity.org/wiki/TestDisk"
-SRC_URI="http://www.cgsecurity.org/${P}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~x86"
-IUSE="jpeg ntfs reiserfs static"
-
-# WARNING: reiserfs support does NOT work with reiserfsprogs
-# you MUST use progsreiserfs-0.3.1_rc8 (the last version ever released).
-DEPEND="
-               >=sys-libs/ncurses-5.2
-               jpeg? ( virtual/jpeg )
-               ntfs? ( sys-fs/ntfs3g )
-               reiserfs? ( >=sys-fs/progsreiserfs-0.3.1_rc8 )
-               >=sys-fs/e2fsprogs-1.35
-               sys-libs/zlib"
-RDEPEND="!static? ( ${DEPEND} )"
-
-src_configure() {
-       local myconf
-
-       # this is static method is the same used by upstream for their 'static' make
-       # target, but better, as it doesn't break.
-       use static && append-ldflags -static
-
-       # --with-foo are broken, any use of --with/--without disable the
-       # functionality.
-       # The following variation must be used.
-       use reiserfs || myconf+=" --without-reiserfs"
-       use ntfs || myconf+=" --without-ntfs"
-       use jpeg || myconf+=" --without-jpeg"
-
-       econf \
-               --docdir="${ED}/usr/share/doc/${PF}" \
-               --without-ewf \
-               --enable-sudo \
-               ${myconf}
-
-       # perform safety checks for NTFS, REISERFS and JPEG
-       if use ntfs && ! egrep -q '^#define HAVE_LIBNTFS(3G)? 1$' "${S}"/config.h ; then
-               die "Failed to find either NTFS or NTFS-3G library."
-       fi
-       if use reiserfs && egrep -q 'undef HAVE_LIBREISERFS\>' "${S}"/config.h ; then
-               die "Failed to find reiserfs library."
-       fi
-       if use jpeg && egrep -q 'undef HAVE_LIBJPEG\>' "${S}"/config.h ; then
-               die "Failed to find jpeg library."
-       fi
-}
diff --git a/app-admin/testdisk/testdisk-6.14-r1.ebuild b/app-admin/testdisk/testdisk-6.14-r1.ebuild
deleted file mode 100644 (file)
index b38dab5..0000000
+++ /dev/null
@@ -1,83 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-
-AUTOTOOLS_AUTORECONF=1
-
-inherit autotools-utils eutils flag-o-matic
-
-DESCRIPTION="Checks and undeletes partitions + PhotoRec, signature based recovery tool"
-HOMEPAGE="http://www.cgsecurity.org/wiki/TestDisk"
-SRC_URI="http://www.cgsecurity.org/${P}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 ~arm ~ppc ~x86"
-IUSE="ewf jpeg ntfs reiserfs static qt4"
-
-REQUIRED_USE="static? ( !qt4 )"
-
-# WARNING: reiserfs support does NOT work with reiserfsprogs
-# you MUST use progsreiserfs-0.3.1_rc8 (the last version ever released).
-DEPEND="
-               static? (
-                       sys-apps/util-linux[static-libs]
-                       >=sys-libs/ncurses-5.2[static-libs]
-                       jpeg? ( virtual/jpeg:*[static-libs] )
-                       ntfs? ( sys-fs/ntfs3g[static-libs] )
-                       reiserfs? ( >=sys-fs/progsreiserfs-0.3.1_rc8[static-libs] )
-                       >=sys-fs/e2fsprogs-1.35[static-libs]
-                       sys-libs/zlib[static-libs]
-                       !arm? ( ewf? ( app-forensics/libewf:*[static-libs] ) )
-                       )
-               !static? (
-                       sys-apps/util-linux
-                       >=sys-libs/ncurses-5.2
-                       jpeg? ( virtual/jpeg:* )
-                       ntfs? ( sys-fs/ntfs3g )
-                       reiserfs? ( >=sys-fs/progsreiserfs-0.3.1_rc8 )
-                       >=sys-fs/e2fsprogs-1.35
-                       sys-libs/zlib
-                       !arm? ( ewf? ( app-forensics/libewf:* ) )
-                       qt4? ( >=dev-qt/qtgui-4.0.1:* )
-                       )"
-RDEPEND="!static? ( ${DEPEND} )"
-
-AUTOTOOLS_IN_SOURCE_BUILD=1
-DOCS=( )
-PATCHES=( "${FILESDIR}/fix_rare_crash-6.14.patch" )
-
-src_configure() {
-       local myconf
-
-       # this is static method is the same used by upstream for their 'static' make
-       # target, but better, as it doesn't break.
-       use static && append-ldflags -static
-
-       # --with-foo are broken, any use of --with/--without disable the
-       # functionality.
-       # The following variation must be used.
-       use reiserfs || myconf+=" --without-reiserfs"
-       use ntfs || myconf+=" --without-ntfs --without-ntfs3g"
-       use jpeg || myconf+=" --without-jpeg"
-       use ewf || myconf+=" --without-ewf"
-       myconf+=$(usex qt4 " --enable-qt" " --disable-qt")
-
-       econf \
-               --docdir "${ROOT}/usr/share/doc/${P}" \
-               --enable-sudo \
-               ${myconf}
-
-       # perform safety checks for NTFS, REISERFS and JPEG
-       if use ntfs && ! egrep -q '^#define HAVE_LIBNTFS(3G)? 1$' "${S}"/config.h ; then
-               die "Failed to find either NTFS or NTFS-3G library."
-       fi
-       if use reiserfs && egrep -q 'undef HAVE_LIBREISERFS\>' "${S}"/config.h ; then
-               die "Failed to find reiserfs library."
-       fi
-       if use jpeg && egrep -q 'undef HAVE_LIBJPEG\>' "${S}"/config.h ; then
-               die "Failed to find jpeg library."
-       fi
-}
diff --git a/app-admin/testdisk/testdisk-6.14-r2.ebuild b/app-admin/testdisk/testdisk-6.14-r2.ebuild
deleted file mode 100644 (file)
index 067ea20..0000000
+++ /dev/null
@@ -1,83 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-
-AUTOTOOLS_AUTORECONF=1
-
-inherit autotools-utils eutils flag-o-matic
-
-DESCRIPTION="Checks and undeletes partitions + PhotoRec, signature based recovery tool"
-HOMEPAGE="http://www.cgsecurity.org/wiki/TestDisk"
-SRC_URI="http://www.cgsecurity.org/${P}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~ppc ~x86"
-IUSE="ewf jpeg ntfs reiserfs static qt4"
-
-REQUIRED_USE="static? ( !qt4 )"
-
-# WARNING: reiserfs support does NOT work with reiserfsprogs
-# you MUST use progsreiserfs-0.3.1_rc8 (the last version ever released).
-DEPEND="
-               static? (
-                       sys-apps/util-linux[static-libs]
-                       >=sys-libs/ncurses-5.2[static-libs]
-                       jpeg? ( virtual/jpeg:0[static-libs] )
-                       ntfs? ( sys-fs/ntfs3g[static-libs] )
-                       reiserfs? ( >=sys-fs/progsreiserfs-0.3.1_rc8[static-libs] )
-                       >=sys-fs/e2fsprogs-1.35[static-libs]
-                       sys-libs/zlib[static-libs]
-                       !arm? ( ewf? ( app-forensics/libewf:=[static-libs] ) )
-                       )
-               !static? (
-                       sys-apps/util-linux
-                       >=sys-libs/ncurses-5.2
-                       jpeg? ( virtual/jpeg:0 )
-                       ntfs? ( sys-fs/ntfs3g )
-                       reiserfs? ( >=sys-fs/progsreiserfs-0.3.1_rc8 )
-                       >=sys-fs/e2fsprogs-1.35
-                       sys-libs/zlib
-                       !arm? ( ewf? ( app-forensics/libewf:= ) )
-                       qt4? ( dev-qt/qtgui:4 )
-                       )"
-RDEPEND="!static? ( ${DEPEND} )"
-
-AUTOTOOLS_IN_SOURCE_BUILD=1
-DOCS=( )
-PATCHES=( "${FILESDIR}/fix_rare_crash-6.14.patch" )
-
-src_configure() {
-       local myconf
-
-       # this is static method is the same used by upstream for their 'static' make
-       # target, but better, as it doesn't break.
-       use static && append-ldflags -static
-
-       # --with-foo are broken, any use of --with/--without disable the
-       # functionality.
-       # The following variation must be used.
-       use reiserfs || myconf+=" --without-reiserfs"
-       use ntfs || myconf+=" --without-ntfs --without-ntfs3g"
-       use jpeg || myconf+=" --without-jpeg"
-       use ewf || myconf+=" --without-ewf"
-       myconf+=$(usex qt4 " --enable-qt" " --disable-qt")
-
-       econf \
-               --docdir "${ROOT}/usr/share/doc/${P}" \
-               --enable-sudo \
-               ${myconf}
-
-       # perform safety checks for NTFS, REISERFS and JPEG
-       if use ntfs && ! egrep -q '^#define HAVE_LIBNTFS(3G)? 1$' "${S}"/config.h ; then
-               die "Failed to find either NTFS or NTFS-3G library."
-       fi
-       if use reiserfs && egrep -q 'undef HAVE_LIBREISERFS\>' "${S}"/config.h ; then
-               die "Failed to find reiserfs library."
-       fi
-       if use jpeg && egrep -q 'undef HAVE_LIBJPEG\>' "${S}"/config.h ; then
-               die "Failed to find jpeg library."
-       fi
-}
diff --git a/app-admin/testdisk/testdisk-6.14.ebuild b/app-admin/testdisk/testdisk-6.14.ebuild
deleted file mode 100644 (file)
index 425b384..0000000
+++ /dev/null
@@ -1,60 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-
-inherit eutils flag-o-matic
-
-DESCRIPTION="Checks and undeletes partitions + PhotoRec, signature based recovery tool"
-HOMEPAGE="http://www.cgsecurity.org/wiki/TestDisk"
-SRC_URI="http://www.cgsecurity.org/${P}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 ~arm ppc x86"
-IUSE="jpeg ntfs reiserfs static"
-
-# WARNING: reiserfs support does NOT work with reiserfsprogs
-# you MUST use progsreiserfs-0.3.1_rc8 (the last version ever released).
-DEPEND="
-               sys-apps/util-linux
-               >=sys-libs/ncurses-5.2
-               jpeg? ( virtual/jpeg:* )
-               ntfs? ( sys-fs/ntfs3g )
-               reiserfs? ( >=sys-fs/progsreiserfs-0.3.1_rc8 )
-               >=sys-fs/e2fsprogs-1.35
-               sys-libs/zlib"
-RDEPEND="!static? ( ${DEPEND} )"
-
-src_configure() {
-       local myconf
-
-       # this is static method is the same used by upstream for their 'static' make
-       # target, but better, as it doesn't break.
-       use static && append-ldflags -static
-
-       # --with-foo are broken, any use of --with/--without disable the
-       # functionality.
-       # The following variation must be used.
-       use reiserfs || myconf+=" --without-reiserfs"
-       use ntfs || myconf+=" --without-ntfs"
-       use jpeg || myconf+=" --without-jpeg"
-
-       econf \
-               --docdir="${ED}/usr/share/doc/${PF}" \
-               --without-ewf \
-               --enable-sudo \
-               ${myconf}
-
-       # perform safety checks for NTFS, REISERFS and JPEG
-       if use ntfs && ! egrep -q '^#define HAVE_LIBNTFS(3G)? 1$' "${S}"/config.h ; then
-               die "Failed to find either NTFS or NTFS-3G library."
-       fi
-       if use reiserfs && egrep -q 'undef HAVE_LIBREISERFS\>' "${S}"/config.h ; then
-               die "Failed to find reiserfs library."
-       fi
-       if use jpeg && egrep -q 'undef HAVE_LIBJPEG\>' "${S}"/config.h ; then
-               die "Failed to find jpeg library."
-       fi
-}