x11-libs/pixman: Reintroduce static-libs USE flag
authorJames Le Cuirot <chewi@gentoo.org>
Sat, 14 Sep 2019 13:27:59 +0000 (14:27 +0100)
committerMatt Turner <mattst88@gentoo.org>
Sun, 19 Apr 2020 22:07:58 +0000 (15:07 -0700)
A couple of packages actually depend on this, even though it looks
static libs have not been installed since the transition to Meson. The
tree hasn't broken because they use [static-libs(+)].

Closes: https://bugs.gentoo.org/698548
Closes: https://github.com/gentoo/gentoo/pull/12925
Signed-off-by: James Le Cuirot <chewi@gentoo.org>
Signed-off-by: Matt Turner <mattst88@gentoo.org>
x11-libs/pixman/pixman-9999.ebuild

index ee4a7b6b0de5f7982cbe8724ded30281bb4e773b..296db0dbcb16802471f6ee3e141a7c7dee583986 100644 (file)
@@ -22,7 +22,7 @@ fi
 
 LICENSE="MIT"
 SLOT="0"
-IUSE="cpu_flags_ppc_altivec cpu_flags_arm_iwmmxt cpu_flags_arm_iwmmxt2 cpu_flags_arm_neon loongson2f cpu_flags_x86_mmxext cpu_flags_x86_sse2 cpu_flags_x86_ssse3"
+IUSE="cpu_flags_ppc_altivec cpu_flags_arm_iwmmxt cpu_flags_arm_iwmmxt2 cpu_flags_arm_neon loongson2f cpu_flags_x86_mmxext cpu_flags_x86_sse2 cpu_flags_x86_ssse3 static-libs"
 
 multilib_src_configure() {
        local openmp=disabled
@@ -37,6 +37,7 @@ multilib_src_configure() {
                $(meson_feature cpu_flags_ppc_altivec vmx)
                $(meson_feature cpu_flags_arm_neon neon)
                $(meson_feature loongson2f loongson-mmi)
+               -Ddefault_library=$(usex static-libs both shared)
                -Dgtk=disabled
                -Dlibpng=disabled
                -Dopenmp=$openmp # only used in unit tests