app-admin/keepass: remove 2.43
authorMichael Palimaka <kensington@gentoo.org>
Sat, 28 Mar 2020 03:05:55 +0000 (14:05 +1100)
committerMichael Palimaka <kensington@gentoo.org>
Sat, 28 Mar 2020 03:05:55 +0000 (14:05 +1100)
Package-Manager: Portage-2.3.89, Repoman-2.3.21
Signed-off-by: Michael Palimaka <kensington@gentoo.org>
app-admin/keepass/Manifest
app-admin/keepass/keepass-2.43.ebuild [deleted file]

index 58a2544fefc2833da34850a04250c757f413122f..022fd5fc18a8a02b10c90572b8672af10be294a0 100644 (file)
@@ -1,2 +1 @@
-DIST KeePass-2.43-Source.zip 5177684 BLAKE2B 72530afd37139d250fe7378ccfec9056e9f2210aa9dfc4cc082d977ccfc517697bc52dad3d487ebabc796977cdbb9679df32a79a6be807c21ceab5931d464df0 SHA512 c403ae5d7b2a997e1aadffd6a522c8292d01a5803371af8b30734414ca5d47871b53a15067251d4cb072215fd41396465b0b16351e76dad7a48044b7ed62a7e8
 DIST KeePass-2.44-Source.zip 5182922 BLAKE2B 092d1b982d748ea1b13f26fe5423a491855cb491c80cae7632429d488f80fd730df5d2f1613bab528d55a3aadcf0cb4f4055a637d2b14b68a468e4baf9ab1837 SHA512 ef2ca69e40c0787b63fc30a2b222dd77fd9f0addf8593511dcd0a47580cc8de5e0900c7d4e6f77c0e5a49d1728286cf1b5856cdc65ef175e4acfdd1ffc54b55e
diff --git a/app-admin/keepass/keepass-2.43.ebuild b/app-admin/keepass/keepass-2.43.ebuild
deleted file mode 100644 (file)
index 25c9b9a..0000000
+++ /dev/null
@@ -1,117 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit eutils gnome2-utils xdg-utils
-
-MY_PN="KeePass"
-DESCRIPTION="A free, open source, light-weight and easy-to-use password manager"
-HOMEPAGE="https://keepass.info/"
-SRC_URI="mirror://sourceforge/${PN}/${MY_PN}-${PV}-Source.zip"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE="aot"
-
-COMMON_DEPEND="dev-lang/mono"
-DEPEND="${COMMON_DEPEND}
-       app-arch/unzip
-"
-RDEPEND="${COMMON_DEPEND}
-       dev-dotnet/libgdiplus[cairo]
-"
-
-S="${WORKDIR}"
-PATCHES=( "${FILESDIR}/${PN}-2.36-xsl-path-detection.patch" )
-
-# bug #687052
-# file generated by mono --aot where *FLAGS don't make sense
-QA_PREBUILT="usr/lib64/keepass/KeePass.exe.so"
-
-src_prepare() {
-       # KeePass looks for some XSL files in the same folder as the executable,
-       # we prefer to have it in /usr/share/KeePass. Apply patch using base function.
-       # This XSL file will not be upstreamed since the KeePass creator said that
-       # including this patch would break the Portable USB version of KeePass
-       # (which keeps/looks for xsl files in its own folder)
-       default
-
-       # Switch into build dir so the mono prepration script works correctly
-       pushd Build || die
-       source PrepMonoDev.sh || die
-       popd || die
-}
-
-src_compile() {
-       export MONO_REGISTRY_PATH=/dev/null # bug 659808
-
-       # Build with Release target
-       xbuild /target:KeePass /property:Configuration=Release || die
-
-       # Run Ahead Of Time compiler on the binary
-       if use aot; then
-               cp Ext/KeePass.exe.config Build/KeePass/Release/ || die
-               mono --aot -O=all Build/KeePass/Release/KeePass.exe || die
-       fi
-}
-
-src_install() {
-       # Wrapper script to launch mono
-       make_wrapper "${PN}" "mono /usr/$(get_libdir)/${PN}/KeePass.exe"
-
-       # Some XSL files
-       insinto "/usr/share/${PN}/XSL"
-       doins Ext/XSL/*
-
-       insinto "/usr/$(get_libdir)/${PN}"
-       exeinto "/usr/$(get_libdir)/${PN}"
-
-       doins Ext/KeePass.exe.config
-
-       # Default configuration, simply says to use user-specific configuration
-       doins Ext/KeePass.config.xml
-
-       # The actual executable
-       doexe Build/KeePass/Release/KeePass.exe
-
-       # Copy the AOT compilation result
-       if use aot; then
-               doexe Build/KeePass/Release/KeePass.exe.so
-       fi
-
-       # Prepare the icons
-       newicon -s 256 Ext/Icons_04_CB/Finals/plockb.png "${PN}.png"
-       newicon -s 256 -t gnome -c mimetypes Ext/Icons_04_CB/Finals/plockb.png "application-x-${PN}2.png"
-
-       # Create a desktop entry and associate it with the KeePass mime type
-       make_desktop_entry "${PN}" "${MY_PN}" "${PN}" "System;Security" "MimeType=application/x-keepass2;\nStartupWMClass=KeePass2;"
-
-       # MIME descriptor for .kdbx files
-       insinto /usr/share/mime/packages
-       doins "${FILESDIR}/${PN}.xml"
-
-       # sed, because patching this really sucks
-       sed -i 's/mono/mono --verify-all/g' "${D}/usr/bin/keepass" || die
-}
-
-pkg_postinst() {
-       gnome2_icon_cache_update
-       xdg_desktop_database_update
-       xdg_mimeinfo_database_update
-
-       if ! has_version x11-misc/xdotool ; then
-               elog "Optional dependencies:"
-               elog "  x11-misc/xdotool (enables autotype/autofill)"
-       fi
-
-       elog "Some systems may experience issues with copy and paste operations."
-       elog "If you encounter this, please install x11-misc/xsel."
-}
-
-pkg_postrm() {
-       gnome2_icon_cache_update
-       xdg_desktop_database_update
-       xdg_mimeinfo_database_update
-}