dev-libs/libpqxx: Cleanup
authorAaron W. Swenson <titanofold@gentoo.org>
Tue, 15 May 2018 20:01:00 +0000 (16:01 -0400)
committerAaron W. Swenson <titanofold@gentoo.org>
Tue, 15 May 2018 20:01:00 +0000 (16:01 -0400)
Closes: https://bugs.gentoo.org/642434
Closes: https://bugs.gentoo.org/640154
Package-Manager: Portage-2.3.24, Repoman-2.3.6

dev-libs/libpqxx/Manifest
dev-libs/libpqxx/libpqxx-4.0.1.ebuild [deleted file]
dev-libs/libpqxx/libpqxx-5.1.0.ebuild [deleted file]
dev-libs/libpqxx/libpqxx-5.1.1.ebuild [deleted file]

index 4218eaa60532cb5b5aa7e6fd8d82ae7818676c7d..a926d45549a96e5351fe9f7a64c2f268641e1528 100644 (file)
@@ -1,4 +1 @@
-DIST libpqxx-4.0.1.tar.gz 1582532 BLAKE2B e84f455de3cdce1bbcdb29ae0ff5fea6e5c624f910a3612976eea1f50e054b785b9b7f2b816fa5d0e11ec4f53498404eb2ec1d9c80fc60a8be27d0e0cef0de14 SHA512 00204985097ef8bb0a3376d6ba541dbb471d7c52d7135f6244a9f4acbf6c8e5254d6f813e4411421e49bb56f4a520fc6ac67e300141d724396ce0ac11bd3a95e
-DIST libpqxx-5.1.0.tar.gz 677998 BLAKE2B 5d486beff9d45249d191b380b2a552dcab621c0509c318e8745abfcb5d6d30b0c31dbe3431fea0c1c212b7a3d6d48abf15d537c6f5a6b3869963dd7615f3e4d3 SHA512 4e881bb509b36b6b48d18dddd0895ab6864ba0430630d3e1417036ff8ff0008b446467868f2672e0b49b46cc3a86c6a61a8a3e5c6b63e0bf422be3268d7f9702
-DIST libpqxx-5.1.1.tar.gz 678031 BLAKE2B c615094b7d872355ad45eb49c3f2e9776f314bca0fbf393ab9ec96daeae5732082c9907eef4793f575cf2cbb95ffa30e1d83cbfb9c4a2938019d9d207ebcc9cf SHA512 fbbefe37d01ef58dd7f73629b5174c7285c0fe7d2f2ae10d3118d55d944f7e92b88d0e9c8ac72425c3bc55bdcc12f3e110e1974b303b7fb227be805e935982dd
 DIST libpqxx-6.0.0.tar.gz 676528 BLAKE2B a40095ba9851acde1296d93af7e4c4414f334a734b5062874b63a146836105fdde24672707caf623f2073dc1caf87b1053f25c80b10c3fa779fc91a52f9ec7ae SHA512 f237cc03c01a8262eee44a9428206c1cc11b6034dddf540afef145f58eee5c32b880d84832563480d73d834c24311170e2ef6789e100793afbe0b6e393bd4169
diff --git a/dev-libs/libpqxx/libpqxx-4.0.1.ebuild b/dev-libs/libpqxx/libpqxx-4.0.1.ebuild
deleted file mode 100644 (file)
index 1be9171..0000000
+++ /dev/null
@@ -1,84 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="4"
-
-PYTHON_COMPAT=( python2_7 )
-inherit python-any-r1
-
-KEYWORDS="alpha amd64 hppa ia64 ppc ppc64 sparc x86 ~x86-fbsd"
-
-DESCRIPTION="Standard front end for writing C++ programs that use PostgreSQL"
-SRC_URI="http://pqxx.org/download/software/${PN}/${P}.tar.gz"
-HOMEPAGE="http://pqxx.org/development/libpqxx/"
-LICENSE="BSD"
-SLOT="0"
-IUSE="doc static-libs"
-
-RDEPEND="dev-db/postgresql"
-DEPEND="${PYTHON_DEPS}
-               ${RDEPEND}
-"
-
-src_prepare() {
-       sed -e 's/python/python2/' \
-               -i tools/{splitconfig,template2mak.py} \
-               || die "Couldn't fix Python shebangs"
-}
-
-src_configure() {
-       if use static-libs ; then
-               econf --enable-static
-       else
-               econf --enable-shared
-       fi
-}
-
-src_install () {
-       emake DESTDIR="${D}" install
-
-       dodoc AUTHORS ChangeLog NEWS README*
-       use doc && dohtml -r doc/html/*
-}
-
-src_test() {
-       einfo "The tests need a running PostgreSQL server and an existing database."
-       einfo "Test requires PGDATABASE and PGUSER to be set at a minimum. Optionally,"
-       einfo "set PGPORT and PGHOST. Define them at the command line or in:"
-       einfo "    ${EROOT%/}/etc/libpqxx_test_env"
-
-       if [[ -z $PGDATABASE || -z $PGUSER ]] ; then
-               if [[ -f ${EROOT%/}/etc/libpqxx_test_env ]] ; then
-                       source "${EROOT%/}/etc/libpqxx_test_env"
-                       [[ -n $PGDATABASE ]] && export PGDATABASE
-                       [[ -n $PGHOST ]] && export PGHOST
-                       [[ -n $PGPORT ]] && export PGPORT
-                       [[ -n $PGUSER ]] && export PGUSER
-               fi
-       fi
-
-       if [[ -n $PGDATABASE && -n $PGUSER ]] ; then
-               local server_version
-               server_version=$(psql -Aqtc 'SELECT version();' 2> /dev/null)
-               if [[ $? = 0 ]] ; then
-                       # Currently works with highest server version in tree
-                       #server_version=$(echo ${server_version} | cut -d " " -f 2 | cut -d "." -f -2 | tr -d .)
-                       #if [[ $server_version < 92 ]] ; then
-                               cd "${S}/test"
-                               emake check
-                       #else
-                       #       eerror "Server version must be 8.4.x or below."
-                       #       die "Server version isn't 8.4.x or below"
-                       #fi
-               else
-                       eerror "Is the server running?"
-                       eerror "Verify role and database exist, and are permitted in pg_hba.conf for:"
-                       eerror "    Role: ${PGUSER}"
-                       eerror "    Database: ${PGDATABASE}"
-                       die "Couldn't connect to server."
-               fi
-       else
-               eerror "PGDATABASE and PGUSER must be set to perform tests."
-               eerror "Skipping tests."
-       fi
-}
diff --git a/dev-libs/libpqxx/libpqxx-5.1.0.ebuild b/dev-libs/libpqxx/libpqxx-5.1.0.ebuild
deleted file mode 100644 (file)
index 65bd4b7..0000000
+++ /dev/null
@@ -1,86 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="6"
-
-PYTHON_COMPAT=( python2_7 )
-inherit python-any-r1
-
-KEYWORDS="~alpha amd64 ~hppa ia64 ppc ppc64 ~sparc x86 ~x86-fbsd"
-
-DESCRIPTION="Standard front-end for writing C++ programs that use PostgreSQL"
-SRC_URI="https://github.com/jtv/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
-HOMEPAGE="http://pqxx.org/development/libpqxx/"
-LICENSE="BSD"
-SLOT="0"
-IUSE="doc static-libs"
-
-RDEPEND="dev-db/postgresql:="
-DEPEND="${RDEPEND}
-       ${PYTHON_DEPS}
-       doc? (
-               app-doc/doxygen
-               app-text/xmlto
-       )
-"
-
-DOCS=( AUTHORS NEWS README{.md,-UPGRADE} )
-
-src_prepare() {
-       default
-
-       sed -e 's/python/python2/' \
-               -i tools/{splitconfig,template2mak.py} \
-               || die "Couldn't fix Python shebangs"
-}
-
-src_configure() {
-       econf \
-               --enable-shared \
-               $(use_enable doc documentation) \
-               $(use_enable static-libs static)
-}
-
-src_test() {
-       einfo "The tests need a running PostgreSQL server and an existing database."
-       einfo "Test requires PGDATABASE and PGUSER to be set at a minimum. Optionally,"
-       einfo "set PGPORT and PGHOST. Define them at the command line or in:"
-       einfo "    ${EROOT%/}/etc/libpqxx_test_env"
-
-       if [[ -z $PGDATABASE || -z $PGUSER ]] ; then
-               if [[ -f ${EROOT%/}/etc/libpqxx_test_env ]] ; then
-                       source "${EROOT%/}/etc/libpqxx_test_env"
-                       [[ -n $PGDATABASE ]] && export PGDATABASE
-                       [[ -n $PGHOST ]] && export PGHOST
-                       [[ -n $PGPORT ]] && export PGPORT
-                       [[ -n $PGUSER ]] && export PGUSER
-               fi
-       fi
-
-       if [[ -n $PGDATABASE && -n $PGUSER ]] ; then
-               local server_version
-               server_version=$(psql -Aqtc 'SELECT version();' 2> /dev/null)
-               if [[ $? = 0 ]] ; then
-                       cd "${S}/test" || die
-                       emake check
-               else
-                       eerror "Is the server running?"
-                       eerror "Verify role and database exist, and are permitted in pg_hba.conf for:"
-                       eerror "    Role: ${PGUSER}"
-                       eerror "    Database: ${PGDATABASE}"
-                       die "Couldn't connect to server."
-               fi
-       else
-               eerror "PGDATABASE and PGUSER must be set to perform tests."
-               eerror "Skipping tests."
-       fi
-}
-
-src_install () {
-       use doc && HTML_DOCS=( doc/html/. )
-       default
-
-       if ! use static-libs; then
-               find "${D}" -name '*.la' -delete || die
-       fi
-}
diff --git a/dev-libs/libpqxx/libpqxx-5.1.1.ebuild b/dev-libs/libpqxx/libpqxx-5.1.1.ebuild
deleted file mode 100644 (file)
index 83c831e..0000000
+++ /dev/null
@@ -1,86 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="6"
-
-PYTHON_COMPAT=( python2_7 )
-inherit python-any-r1
-
-KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
-
-DESCRIPTION="Standard front-end for writing C++ programs that use PostgreSQL"
-SRC_URI="https://github.com/jtv/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
-HOMEPAGE="http://pqxx.org/development/libpqxx/"
-LICENSE="BSD"
-SLOT="0"
-IUSE="doc static-libs"
-
-RDEPEND="dev-db/postgresql:="
-DEPEND="${RDEPEND}
-       ${PYTHON_DEPS}
-       doc? (
-               app-doc/doxygen
-               app-text/xmlto
-       )
-"
-
-DOCS=( AUTHORS NEWS README{.md,-UPGRADE} )
-
-src_prepare() {
-       default
-
-       sed -e 's/python/python2/' \
-               -i tools/{splitconfig,template2mak.py} \
-               || die "Couldn't fix Python shebangs"
-}
-
-src_configure() {
-       econf \
-               --enable-shared \
-               $(use_enable doc documentation) \
-               $(use_enable static-libs static)
-}
-
-src_test() {
-       einfo "The tests need a running PostgreSQL server and an existing database."
-       einfo "Test requires PGDATABASE and PGUSER to be set at a minimum. Optionally,"
-       einfo "set PGPORT and PGHOST. Define them at the command line or in:"
-       einfo "    ${EROOT%/}/etc/libpqxx_test_env"
-
-       if [[ -z $PGDATABASE || -z $PGUSER ]] ; then
-               if [[ -f ${EROOT%/}/etc/libpqxx_test_env ]] ; then
-                       source "${EROOT%/}/etc/libpqxx_test_env"
-                       [[ -n $PGDATABASE ]] && export PGDATABASE
-                       [[ -n $PGHOST ]] && export PGHOST
-                       [[ -n $PGPORT ]] && export PGPORT
-                       [[ -n $PGUSER ]] && export PGUSER
-               fi
-       fi
-
-       if [[ -n $PGDATABASE && -n $PGUSER ]] ; then
-               local server_version
-               server_version=$(psql -Aqtc 'SELECT version();' 2> /dev/null)
-               if [[ $? = 0 ]] ; then
-                       cd "${S}/test" || die
-                       emake check
-               else
-                       eerror "Is the server running?"
-                       eerror "Verify role and database exist, and are permitted in pg_hba.conf for:"
-                       eerror "    Role: ${PGUSER}"
-                       eerror "    Database: ${PGDATABASE}"
-                       die "Couldn't connect to server."
-               fi
-       else
-               eerror "PGDATABASE and PGUSER must be set to perform tests."
-               eerror "Skipping tests."
-       fi
-}
-
-src_install () {
-       use doc && HTML_DOCS=( doc/html/. )
-       default
-
-       if ! use static-libs; then
-               find "${D}" -name '*.la' -delete || die
-       fi
-}