app-arch/gcab: bump to 1.4
authorMart Raudsepp <leio@gentoo.org>
Sun, 15 Mar 2020 07:29:01 +0000 (09:29 +0200)
committerMart Raudsepp <leio@gentoo.org>
Sun, 15 Mar 2020 11:39:45 +0000 (13:39 +0200)
Package-Manager: Portage-2.3.84, Repoman-2.3.20
Signed-off-by: Mart Raudsepp <leio@gentoo.org>
app-arch/gcab/Manifest
app-arch/gcab/gcab-1.4.ebuild [new file with mode: 0644]

index 02e23222ce61faa884a5df8ee0d0ffbe922bb3d3..4845bcb7d450ccd6874921a434e2c0bc34f5b49f 100644 (file)
@@ -1 +1,2 @@
 DIST gcab-1.3.tar.xz 77900 BLAKE2B 9ab61c1ab36561cd0bce075c8d491c8e28651c26ff5943a2ddc294a369f7627c300ed698363980dd839b64d512b678d7b3903addeea05657551af308b6e0c5ed SHA512 fd34722bc57a75e9a2aaec354af4629a35936928eb6db5646659c8dd51c8c6fd7fc6786c23f7e91a33a727bf8548327f50725081a8c7b1e0facb877341887b22
+DIST gcab-1.4.tar.xz 78240 BLAKE2B 8b857c116fab636db93463cee7d6b809c3c7b2bdf3896b7b5b5b66ebf270b284b356710933ec17584143bcef5c1f5c555811dd05ea98399f327047476a33fc16 SHA512 66a2e0d0a5888c555153356ce808f602053e71b76af19794db7e3bbf9516fe791805068838b4e208698cd645ada7a08610ac95f846fa81e00a9b955016306299
diff --git a/app-arch/gcab/gcab-1.4.ebuild b/app-arch/gcab/gcab-1.4.ebuild
new file mode 100644 (file)
index 0000000..fc5fcda
--- /dev/null
@@ -0,0 +1,52 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+VALA_USE_DEPEND="vapigen"
+
+inherit gnome.org meson vala xdg
+
+DESCRIPTION="Library and tool for working with Microsoft Cabinet (CAB) files"
+HOMEPAGE="https://wiki.gnome.org/msitools"
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86"
+
+IUSE="gtk-doc +introspection test vala"
+REQUIRED_USE="vala? ( introspection )"
+
+RDEPEND="
+       >=dev-libs/glib-2.62.0:2
+       sys-libs/zlib
+       introspection? ( >=dev-libs/gobject-introspection-1.54:= )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+       >=dev-util/meson-0.50.0
+       dev-util/glib-utils
+       gtk-doc? ( >=dev-util/gtk-doc-1.14
+               app-text/docbook-xml-dtd:4.3 )
+       >=sys-devel/gettext-0.19.8
+       virtual/pkgconfig
+       vala? ( $(vala_depend) )
+"
+
+RESTRICT="!test? ( test )"
+
+src_prepare() {
+       xdg_src_prepare
+       use vala && vala_src_prepare
+}
+
+src_configure() {
+       local emesonargs=(
+               $(meson_use gtk-doc docs)
+               $(meson_use introspection)
+               -Dnls=true
+               $(meson_use vala vapi)
+               $(meson_use test tests)
+               -Dinstalled_tests=false
+       )
+       meson_src_configure
+}