Remove old versions, and remove usage of gnuconfig in latest version. This package...
authorDiego Elio Pettenò <flameeyes@gentoo.org>
Thu, 4 Jan 2007 19:26:16 +0000 (19:26 +0000)
committerDiego Elio Pettenò <flameeyes@gentoo.org>
Thu, 4 Jan 2007 19:26:16 +0000 (19:26 +0000)
Package-Manager: portage-2.1.2_rc4-r5

app-arch/arj/ChangeLog
app-arch/arj/arj-3.10.22-r1.ebuild

index 5af9fc56f24332a5acea7d7f41c009185542c0f7..61ed0163dc1d0ca0c49e0b5bb0fed3e4a6323390 100644 (file)
@@ -1,6 +1,14 @@
 # ChangeLog for app-arch/arj
-# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/arj/ChangeLog,v 1.24 2006/07/15 13:13:10 kloeri Exp $
+# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-arch/arj/ChangeLog,v 1.25 2007/01/04 19:26:16 flameeyes Exp $
+
+  04 Jan 2007; Diego Pettenò <flameeyes@gentoo.org>
+  -files/arj-3.10.18-2.6.headers.patch, -files/arj-3.10.18-fPIC.patch,
+  -arj-3.10.18.ebuild, -arj-3.10.20.ebuild, -arj-3.10.21.ebuild,
+  -arj-3.10.22.ebuild, arj-3.10.22-r1.ebuild:
+  Remove old versions, and remove usage of gnuconfig in latest version. This
+  package should be p.masked and probably removed unless can be built with GCC
+  4.
 
   15 Jul 2006; Bryan Østergaard <kloeri@gentoo.org> metadata.xml:
   Remove aliz from metadata.xml as he's retired.
index 7536a8e7843097184b6ce02beda1938050d3c80b..1a6331feac25083aa6ce4c713db626469c3b9c2e 100644 (file)
@@ -1,8 +1,10 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/arj/arj-3.10.22-r1.ebuild,v 1.5 2005/12/10 00:20:20 herbs Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-arch/arj/arj-3.10.22-r1.ebuild,v 1.6 2007/01/04 19:26:16 flameeyes Exp $
 
-inherit gnuconfig eutils toolchain-funcs
+WANT_AUTOCONF="latest"
+
+inherit eutils toolchain-funcs autotools
 
 DESCRIPTION="Utility for opening arj archives"
 HOMEPAGE="http://arj.sourceforge.net/"
@@ -21,6 +23,9 @@ src_unpack() {
        epatch "${FILESDIR}/001_arches_align.patch"
        epatch "${FILESDIR}/002_no_remove_static_const.patch"
        epatch "${FILESDIR}/003_64_bit_clean.patch"
+
+       cd "${S}/gnu"
+       eautoreconf
 }
 
 src_compile() {
@@ -53,19 +58,16 @@ src_compile() {
                fi
        fi
 
-       gnuconfig_update
-
-       cd ${S}/gnu
-       autoconf
+       cd "${S}/gnu"
        econf || die
 
-       cd ${S}
+       cd "${S}"
        make prepare || die "make prepare failed"
        make package || die "make package failed"
 }
 
 src_install() {
-       cd ${S}/linux-gnu/en/rs/u
+       cd "${S}/linux-gnu/en/rs/u"
        dobin bin/* || die
-       dodoc doc/arj/* ${S}/ChangeLog
+       dodoc doc/arj/* "${S}/ChangeLog"
 }