www-servers/tomcat-8.5.37: bump
authorMiroslav Šulc <fordfrog@gentoo.org>
Wed, 23 Jan 2019 12:41:57 +0000 (13:41 +0100)
committerMiroslav Šulc <fordfrog@gentoo.org>
Wed, 23 Jan 2019 12:49:08 +0000 (13:49 +0100)
Package-Manager: Portage-2.3.58, Repoman-2.3.12
Signed-off-by: Miroslav Šulc <fordfrog@gentoo.org>
www-servers/tomcat/Manifest
www-servers/tomcat/files/tomcat-8.5.37-build.xml.patch [new file with mode: 0644]
www-servers/tomcat/tomcat-8.5.37.ebuild [new file with mode: 0644]

index f8fabd0b3783d0c65fd3e45b8627330c1f519688..f436109e5421d83049a3524a7f9a8d2130b092cb 100644 (file)
@@ -3,4 +3,5 @@ DIST apache-tomcat-7.0.92-src.tar.gz 4778943 BLAKE2B d11b01219a25c303ce791d96590
 DIST apache-tomcat-8.0.52-src.tar.gz 5039683 BLAKE2B 36318d0ae50fbca3f2a97e0210d0a8da8314f1ef79d0b047971bca30a5b0cc937faf013b5090f6e6b8aec4127b6185dc54ae589f5b57143b62c71c09f8bd5e9d SHA512 6d846213db0b15f9add8d80f30f304afdaf879ab6d7f85d212183a93f4f360ebfeeb079813bdea83cbd13f507504473028bbf8279e89b800b6f150b83086fa56
 DIST apache-tomcat-8.0.53-src.tar.gz 5057041 BLAKE2B 3a50d2f61baecb5244909972384e36478c69e7592dd35119d8b7b974273c57a4855082f309146ed160144dbdcced3236fd586b047970bd8558bbe7b7e002e9fd SHA512 0b56bc723277b2888896ab34ec3e49cb56bac94ddf1a9b96bd023982e2ffabd5317f63b3c0971afdc8cd7a6364197409df461d22151dbaab3a2be7daf6858b9e
 DIST apache-tomcat-8.5.31-src.tar.gz 5154531 BLAKE2B cce0388e5c8c5fb5fcb3dba3b5961dc21d9f19d9a2f6177660a41410bddf241f73dda1e52c3875e28cfa13041c85a458a92c9a23c509b645f042cfa472081fde SHA512 659137ef4809af329ae4dd6f5825a603c1408ef3e48153abe7480a722e7f4bebef68a64af9cbef4a4ad9a7e8da76494f825035bbadbb983a097525f476f32f33
+DIST apache-tomcat-8.5.37-src.tar.gz 5233414 BLAKE2B 1848180c3e0a3f4559e5c232bea8bad6d05f09d9c4f2f9f903178012b7b8837d395a5ac73c8ac0504fbd3d1df3c2dc785022e1c97da4441cfdcf8b790170ff7c SHA512 29ddbf7bfef19441a8a043020b5f1149d12590dac8120012a2167b6892e3db7c644990e49ba14cc4b4c7339faed65f010a7b24d660db0fb8adde34f032099cec
 DIST apache-tomcat-9.0.7-src.tar.gz 5106551 BLAKE2B b4552146a40c2e7cbb2e454fb5ec9169425db5c08cf269c391ec3144425ad388a2b6f003a7c05f59a9fd724fb5c848102890a24fcfd43d5fea3d881141aa7798 SHA512 cb7dc5547671d94f7c7fb0b58eeb94d05128349cdabf576fc8ad837a4bf3ea655a8eab3342245dfa84a9db23f1cbee2918846eedd48e3ca372eecebfef13c5b2
diff --git a/www-servers/tomcat/files/tomcat-8.5.37-build.xml.patch b/www-servers/tomcat/files/tomcat-8.5.37-build.xml.patch
new file mode 100644 (file)
index 0000000..4c2d8da
--- /dev/null
@@ -0,0 +1,247 @@
+diff --git a/build.xml b/build.xml
+index 6fbb321..4fb4b42 100644
+--- a/build.xml
++++ b/build.xml
+@@ -722,24 +722,29 @@
+       manifest="${tomcat.manifests}/annotations-api.jar.manifest" />
+     <!-- Servlet 3.1 Implementation JAR File -->
++<!--
+     <jarIt jarfile="${servlet-api.jar}"
+       filesDir="${tomcat.classes}"
+       filesId="files.servlet-api"
+       manifest="${tomcat.manifests}/servlet-api.jar.manifest"
+       notice="${tomcat.manifests}/servlet-api.jar.notice"
+       license="${tomcat.manifests}/servlet-api.jar.license" />
+-
++-->
+     <!-- JSP 2.3 Implementation JAR File -->
++<!--
+     <jarIt jarfile="${jsp-api.jar}"
+       filesDir="${tomcat.classes}"
+       filesId="files.jsp-api"
+       manifest="${tomcat.manifests}/jsp-api.jar.manifest" />
++-->
+     <!-- EL 3.0 Implementation JAR File -->
++<!--
+     <jarIt jarfile="${el-api.jar}"
+       filesDir="${tomcat.classes}"
+       filesId="files.el-api"
+       manifest="${tomcat.manifests}/el-api.jar.manifest" />
++-->
+     <!-- WebSocket 1.1 API JAR File -->
+     <jarIt jarfile="${websocket-api.jar}"
+@@ -1025,9 +1030,9 @@
+   <target name="deploy" depends="package,build-docs,build-tomcat-jdbc,compile-webapp-examples"
+           description="Default. Builds a working Tomcat instance">
+-
++<!--
+     <copy tofile="${tomcat.build}/bin/commons-daemon.jar" file="${commons-daemon.jar}" />
+-
++-->
+     <!-- Copy scripts -->
+     <copy todir="${tomcat.build}/bin">
+       <fileset dir="bin">
+@@ -1087,7 +1092,7 @@
+         <exclude name="${jdt.jar.filename}"/>
+       </fileset>
+     </delete>
+-    <copy file="${jdt.jar}" todir="${tomcat.build}/lib"/>
++<!--    <copy file="${jdt.jar}" todir="${tomcat.build}/lib"/> -->
+     <!-- Add sources for examples -->
+     <antcall target="examples-sources" />
+@@ -1123,7 +1128,7 @@
+     </javac>
+   </target>
+-  <target name="build-tomcat-jdbc" depends="package">
++  <target name="build-tomcat-jdbc" depends="package" unless="noget">
+     <!-- build the jdbc-pool jar and source jar-->
+     <echo message="Building Tomcat JDBC pool libraries"/>
+     <ant antfile="${tomcat.jdbc.dir}/build.xml" dir="${tomcat.jdbc.dir}"
+@@ -1138,7 +1143,7 @@
+     <copy file="${tomcat-jdbc.jar}" todir="${tomcat.build}/lib"/>
+   </target>
+-  <target name="build-tomcat-jdbc-src">
++  <target name="build-tomcat-jdbc-src" unless="noget">
+     <!-- build the jdbc-pool source jar-->
+     <echo message="Building Tomcat JDBC pool src JAR"/>
+     <ant antfile="${tomcat.jdbc.dir}/build.xml" dir="${tomcat.jdbc.dir}"
+@@ -1242,9 +1247,11 @@
+     <copy file="${basedir}/LICENSE" todir="${tomcat.embed}" />
+     <copy file="${basedir}/NOTICE" todir="${tomcat.embed}" />
++<!--
+     <copy file="${tomcat-dbcp.jar}" todir="${tomcat.embed}"
+       failonerror="false"/>
+     <copy file="${jdt.jar}" todir="${tomcat.embed}" />
++-->
+     <copy file="${annotations-api.jar}" todir="${tomcat.embed}" />
+     <!-- Note the meta-inf below will work as long as there is only one JAR
+@@ -1624,7 +1631,7 @@
+   <target name="extras-webservices-prepare"
+           depends="extras-prepare"
+-          description="Prepare to build web services extras package">
++          description="Prepare to build web services extras package" unless="noget">
+     <antcall target="downloadfile">
+       <param name="sourcefile" value="${jaxrpc-lib.loc}"/>
+@@ -1720,6 +1727,7 @@
+   <target name="javadoc" depends="dist-source"
+     description="Create the Tomcat javadoc" >
++<!--
+     <javadoc packagenames="javax.servlet.*"
+       excludepackagenames="javax.servlet.jsp.*"
+       sourcepath="${tomcat.dist}/src/java"
+@@ -1784,6 +1792,7 @@
+         <path location="${ant.core.lib}"/>
+       </classpath>
+     </javadoc>
++-->
+     <javadoc packagenames="javax.websocket.*"
+       sourcepath="${tomcat.dist}/src/java"
+       destdir="${tomcat.dist}/webapps/docs/websocketapi"
+@@ -1824,9 +1833,11 @@
+         <path refid="tomcat.webservices.classpath"/>
+         <path location="${ant.core.lib}"/>
+       </classpath>
++<!--
+       <link href="../servletapi"/>
+       <link href="../jspapi"/>
+       <link href="../elapi"/>
++-->
+       <link href="../websocketapi"/>
+       <link href="http://docs.oracle.com/javase/7/docs/api/"/>
+       <link href="http://commons.apache.org/proper/commons-io/javadocs/api-release/"/>
+@@ -2550,7 +2561,7 @@ skip.installer property in build.properties" />
+   </target>
+   <target name="download-compile"
+-          description="Download (and build) components necessary to compile" >
++          description="Download (and build) components necessary to compile" unless="noget">
+     <!-- Download Commons Daemon -->
+     <antcall target="downloadgz-2">
+@@ -2576,7 +2587,7 @@ skip.installer property in build.properties" />
+   </target>
+   <target name="download-test-compile"
+-          description="Download additional components for the tests" >
++          description="Download additional components for the tests" unless="noget">
+     <antcall target="downloadfile">
+       <param name="sourcefile" value="${junit.loc}"/>
+@@ -2654,7 +2665,7 @@ skip.installer property in build.properties" />
+   </target>
+   <target name="download-dist"
+-          description="Download additional components for a distribution" >
++          description="Download additional components for a distribution" unless="noget">
+     <antcall target="downloadfile-2">
+       <param name="sourcefile.1" value="${tomcat-native.loc.1}"/>
+@@ -2709,13 +2720,13 @@ skip.installer property in build.properties" />
+   <!-- =============== Utility Targets to support downloads ================ -->
+-  <target name="setproxy" if="${proxy.use}">
++  <target name="setproxy" if="${proxy.use}" unless="noget">
+     <setproxy proxyhost="${proxy.host}" proxyport="${proxy.port}"
+               proxyuser="${proxy.user}" proxypassword="${proxy.password}" />
+     <echo message="Using ${proxy.host}:${proxy.port} to download ${sourcefile}"/>
+   </target>
+-  <target name="testexist">
++  <target name="testexist" unless="noget">
+     <echo message="Testing  for ${destfile}"/>
+     <available file="${destfile}" property="exist"/>
+   </target>
+@@ -2837,7 +2848,7 @@ skip.installer property in build.properties" />
+     </sequential>
+   </macrodef>
+-  <target name="downloadgz" unless="exist" depends="testexist,setproxy">
++  <target name="downloadgz" unless="noget" depends="testexist,setproxy">
+     <!-- Download and extract the package -->
+     <local name="temp.file"/>
+     <mkdir dir="${base.path}"/>
+@@ -2854,7 +2865,7 @@ skip.installer property in build.properties" />
+     <delete file="${temp.file}.tar.gz"/>
+   </target>
+-  <target name="downloadgz-2" unless="exist" depends="testexist">
++  <target name="downloadgz-2" unless="noget" depends="testexist">
+     <!-- Download and extract the package from the two alternative locations -->
+     <local name="temp.file"/>
+     <mkdir dir="${base.path}"/>
+@@ -2879,7 +2890,7 @@ skip.installer property in build.properties" />
+     <delete file="${temp.file}.tar.gz"/>
+   </target>
+-  <target name="downloadzip" unless="exist" depends="testexist,setproxy">
++  <target name="downloadzip" unless="noget" depends="testexist,setproxy">
+     <!-- Download and extract the package -->
+     <local name="temp.file"/>
+     <mkdir dir="${base.path}"/>
+@@ -2895,7 +2906,7 @@ skip.installer property in build.properties" />
+     <delete file="${temp.file}"/>
+   </target>
+-  <target name="downloadzip-2" unless="exist" depends="testexist">
++  <target name="downloadzip-2" unless="noget" depends="testexist">
+     <!-- Download and extract the package from the two alternative locations -->
+     <local name="temp.file"/>
+     <mkdir dir="${base.path}"/>
+@@ -2919,7 +2930,7 @@ skip.installer property in build.properties" />
+     <delete file="${temp.file}"/>
+   </target>
+-  <target name="downloadfile" unless="exist" depends="testexist,setproxy">
++  <target name="downloadfile" unless="noget" depends="testexist,setproxy">
+     <!-- Download the file -->
+     <local name="temp.file"/>
+     <mkdir dir="${base.path}"/>
+@@ -2934,7 +2945,7 @@ skip.installer property in build.properties" />
+     <move file="${temp.file}" tofile="${destfile}"/>
+   </target>
+-  <target name="downloadfile-2" unless="exist" depends="testexist">
++  <target name="downloadfile-2" unless="noget" depends="testexist">
+     <!-- Download the file from the two alternative locations -->
+     <local name="temp.file"/>
+     <mkdir dir="${base.path}"/>
+@@ -2962,7 +2973,7 @@ skip.installer property in build.properties" />
+     <move file="${temp.file}" tofile="${destfile}"/>
+   </target>
+-  <target name="trydownload.check" depends="setproxy">
++  <target name="trydownload.check" depends="setproxy" unless="noget">
+     <condition property="trydownload.run">
+       <and>
+         <not>
+@@ -2973,7 +2984,7 @@ skip.installer property in build.properties" />
+     </condition>
+   </target>
+-  <target name="trydownload" if="trydownload.run" depends="trydownload.check">
++  <target name="trydownload" if="trydownload.run" depends="trydownload.check" unless="noget">
+     <!-- Downloads a file if not yet downloaded and the source URL is available -->
+     <get src="${sourcefile}" httpusecaches="${trydownload.httpusecaches}" dest="${destfile}" />
+   </target>
+@@ -2984,7 +2995,7 @@ skip.installer property in build.properties" />
+   <target name="ide-eclipse"
+           depends="download-compile, extras-webservices-prepare, download-test-compile"
+-          description="Prepares the source tree to be built in Eclipse">
++          description="Prepares the source tree to be built in Eclipse" unless="noget">
+     <!-- Copy the sample project files into the root directory -->
+     <copy file="${tomcat.home}/res/ide-support/eclipse/eclipse.project" tofile="${tomcat.home}/.project"/>
diff --git a/www-servers/tomcat/tomcat-8.5.37.ebuild b/www-servers/tomcat/tomcat-8.5.37.ebuild
new file mode 100644 (file)
index 0000000..3d8ad6a
--- /dev/null
@@ -0,0 +1,159 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+JAVA_PKG_IUSE="doc source test"
+
+inherit eutils java-pkg-2 java-ant-2 prefix user
+
+MY_P="apache-${P}-src"
+
+DESCRIPTION="Tomcat Servlet-3.1/JSP-2.3/EL-3.0/WebSocket-1.1/JASPIC-1.1 Container"
+HOMEPAGE="https://tomcat.apache.org/"
+SRC_URI="mirror://apache/${PN}/tomcat-8/v${PV}/src/${MY_P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="8.5"
+KEYWORDS="~amd64 ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~x86-solaris"
+IUSE="extra-webapps"
+
+RESTRICT="test" # can we run them on a production system?
+
+ECJ_SLOT="4.5"
+SAPI_SLOT="3.1"
+
+COMMON_DEP="dev-java/eclipse-ecj:${ECJ_SLOT}
+       >=dev-java/tomcat-servlet-api-${SLOT}:${SAPI_SLOT}"
+RDEPEND="${COMMON_DEP}
+       !<dev-java/tomcat-native-1.1.24
+       >=virtual/jre-1.7"
+DEPEND="${COMMON_DEP}
+       app-admin/pwgen
+       >=dev-java/ant-core-1.9.13
+       >=virtual/jdk-1.7
+       test? (
+               >=dev-java/ant-junit-1.9:0
+               dev-java/easymock:3.2
+       )"
+
+S=${WORKDIR}/${MY_P}
+
+pkg_setup() {
+       java-pkg-2_pkg_setup
+       enewgroup tomcat 265
+       enewuser tomcat 265 -1 /dev/null tomcat
+}
+
+src_prepare() {
+       default
+
+       find -name '*.jar' -type f -delete -print || die
+
+       # Remove bundled servlet-api
+       rm -rv java/javax/{el,servlet} || die
+
+       eapply "${FILESDIR}/${P}-build.xml.patch"
+
+       # For use of catalina.sh in netbeans
+       sed -i -e "/^# ----- Execute The Requested Command/ a\
+               CLASSPATH=\`java-config --classpath ${PN}-${SLOT}\`" \
+               bin/catalina.sh || die
+
+       java-pkg-2_src_prepare
+}
+
+JAVA_ANT_REWRITE_CLASSPATH="true"
+
+EANT_BUILD_TARGET="deploy"
+EANT_GENTOO_CLASSPATH="eclipse-ecj-${ECJ_SLOT},tomcat-servlet-api-${SAPI_SLOT}"
+EANT_TEST_GENTOO_CLASSPATH="easymock-3.2"
+EANT_GENTOO_CLASSPATH_EXTRA="${S}/output/classes"
+EANT_NEEDS_TOOLS="true"
+EANT_EXTRA_ARGS="-Dversion=${PV}-gentoo -Dversion.number=${PV} -Dcompile.debug=false -Dexecute.validate=false"
+
+# revisions of the scripts
+IM_REV="-r2"
+INIT_REV="-r1"
+
+src_compile() {
+       EANT_GENTOO_CLASSPATH_EXTRA+=":$(java-pkg_getjar --build-only ant-core ant.jar)"
+       java-pkg-2_src_compile
+}
+
+src_test() {
+       java-pkg-2_src_test
+}
+
+src_install() {
+       local dest="/usr/share/${PN}-${SLOT}"
+
+       java-pkg_jarinto "${dest}"/bin
+       java-pkg_dojar output/build/bin/*.jar
+       exeinto "${dest}"/bin
+       doexe output/build/bin/*.sh
+
+       java-pkg_jarinto "${dest}"/lib
+       java-pkg_dojar output/build/lib/*.jar
+
+       dodoc RELEASE-NOTES RUNNING.txt
+       use doc && java-pkg_dojavadoc output/dist/webapps/docs/api
+       use source && java-pkg_dosrc java/*
+
+       ### Webapps ###
+
+       # add missing docBase
+       local apps="host-manager manager"
+       for app in ${apps}; do
+               sed -i -e "s|=\"true\" >|=\"true\" docBase=\"\$\{catalina.home\}/webapps/${app}\" >|" \
+                       output/build/webapps/${app}/META-INF/context.xml || die
+       done
+
+       insinto "${dest}"/webapps
+       doins -r output/build/webapps/{host-manager,manager,ROOT}
+       use extra-webapps && doins -r output/build/webapps/{docs,examples}
+
+       ### Config ###
+
+       # create "logs" directory in $CATALINA_BASE
+       # and set correct perms, see #458890
+       dodir "${dest}"/logs
+       fperms 0750 "${dest}"/logs
+
+       # replace the default pw with a random one, see #92281
+       local randpw="$(pwgen -s -B 15 1)"
+       sed -i -e "s|SHUTDOWN|${randpw}|" output/build/conf/server.xml || die
+
+       # prepend gentoo.classpath to common.loader, see #453212
+       sed -i -e 's/^common\.loader=/\0${gentoo.classpath},/' output/build/conf/catalina.properties || die
+
+       insinto "${dest}"
+       doins -r output/build/conf
+
+       ### rc ###
+
+       cp "${FILESDIR}"/tomcat{.conf,${INIT_REV}.init,-instance-manager${IM_REV}.bash} "${T}" || die
+       eprefixify "${T}"/tomcat{.conf,${INIT_REV}.init,-instance-manager${IM_REV}.bash}
+       sed -i -e "s|@SLOT@|${SLOT}|g" "${T}"/tomcat{.conf,${INIT_REV}.init,-instance-manager${IM_REV}.bash} || die
+
+       insinto "${dest}"/gentoo
+       doins "${T}"/tomcat.conf
+       exeinto "${dest}"/gentoo
+       newexe "${T}"/tomcat${INIT_REV}.init tomcat.init
+       newexe "${T}"/tomcat-instance-manager${IM_REV}.bash tomcat-instance-manager.bash
+}
+
+pkg_postinst() {
+       elog "New ebuilds of Tomcat support running multiple instances. If you used prior version"
+       elog "of Tomcat (<7.0.32), you have to migrate your existing instance to work with new Tomcat."
+       elog "You can find more information at https://wiki.gentoo.org/wiki/Apache_Tomcat"
+
+       elog "To manage Tomcat instances, run:"
+       elog "  ${EPREFIX}/usr/share/${PN}-${SLOT}/gentoo/tomcat-instance-manager.bash --help"
+
+       ewarn "tomcat-dbcp.jar is not built at this time. Please fetch jar"
+       ewarn "from upstream binary if you need it. Gentoo Bug # 144276"
+
+       einfo "Please read https://wiki.gentoo.org/wiki/Apache_Tomcat and"
+       einfo "https://wiki.gentoo.org/wiki/Project:Java/Tomcat_6_Guide for more information."
+}