mate-extra/mate-polkit: Bump to 1.24.0
authorAdam Feldman <NP-Hardass@gentoo.org>
Fri, 20 Mar 2020 20:48:54 +0000 (16:48 -0400)
committerAdam Feldman <NP-Hardass@gentoo.org>
Mon, 6 Apr 2020 17:48:05 +0000 (13:48 -0400)
Package-Manager: Portage-2.3.82, Repoman-2.3.18
Signed-off-by: Adam Feldman <NP-Hardass@gentoo.org>
mate-extra/mate-polkit/Manifest
mate-extra/mate-polkit/mate-polkit-1.24.0.ebuild [new file with mode: 0644]

index 39fac35c2e6b924dabb80abf06573f2c273bbf0b..cf0767de6ae178c8d017b49f46252ec13f332552 100644 (file)
@@ -1 +1,2 @@
 DIST mate-polkit-1.22.0.tar.xz 302080 BLAKE2B 374fa5215c57a36fc3a6fa4660866b33bc02d067f1eaf5cbadca8711efe8771e4c59d496e8eb47c75567b5a0e472fd10782c5b5436b9d2a5e7fc834445e5cf06 SHA512 e761ec10842789b5bbb3831f568c64e969429131a893850e8323927b949e115a24b3907fd3def7f31f5f785f0831717d852c61f08a9028a009ea9cca0ba86393
+DIST mate-polkit-1.24.0.tar.xz 332652 BLAKE2B 293d964f2410d2f60047d1e01e2ba864c22e8bda00e5b659329d097391b2988349c70dfbd953f223c4212887d16d54f1f5a7eb21e38b69b553d54b1966647cb1 SHA512 8d759bd5f78750c75dc92ffa27e555ae36ae7199b76483cbfe7e0848d3a66cda5b82c98bf334068eb79a1344757665cf7d1bf403e4e908e332ca929c8ebe2a98
diff --git a/mate-extra/mate-polkit/mate-polkit-1.24.0.ebuild b/mate-extra/mate-polkit/mate-polkit-1.24.0.ebuild
new file mode 100644 (file)
index 0000000..5b5b4f8
--- /dev/null
@@ -0,0 +1,42 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit mate
+
+if [[ ${PV} != 9999 ]]; then
+       KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+fi
+
+DESCRIPTION="A MATE specific DBUS service that is used to bring up authentication dialogs"
+LICENSE="LGPL-2"
+SLOT="0"
+
+IUSE="accountsservice appindicator"
+
+COMMON_DEPEND=">=dev-libs/glib-2.50:2
+       >=sys-auth/polkit-0.102
+       x11-libs/gdk-pixbuf:2
+       >=x11-libs/gtk+-3.22.0:3
+       appindicator? ( dev-libs/libappindicator:3 )"
+
+RDEPEND="${COMMON_DEPEND}
+       accountsservice? ( sys-apps/accountsservice )
+       virtual/libintl
+"
+
+DEPEND="${COMMON_DEPEND}
+       dev-util/gtk-doc
+       dev-util/gtk-doc-am
+       >=sys-devel/gettext-0.19.8:*
+       >=sys-devel/libtool-2.2.6
+       virtual/pkgconfig:*
+       !<gnome-extra/polkit-gnome-0.102:0"
+
+src_configure() {
+       mate_src_configure \
+               --disable-static \
+               $(use_enable accountsservice) \
+               $(use_enable appindicator)
+}