sys-devel/libtool: force disable help2man w/releases #556512
authorMike Frysinger <vapier@gentoo.org>
Fri, 11 Sep 2015 17:26:51 +0000 (13:26 -0400)
committerMike Frysinger <vapier@gentoo.org>
Fri, 11 Sep 2015 18:10:54 +0000 (14:10 -0400)
We want to make sure that help2man isn't run inadvertently (since we
explicitly do not depend on it w/releases), so set HELP2MAN to `false`
so it hard fails immediately.

We also fix the build-aux/ltmain.in patch as it triggers rebuilding of
build-aux/ltmain.sh which triggers rebuilding of doc/libtool.1 which
requires `help2man`.

sys-devel/libtool/files/libtool-2.4.6-fuse-ld.patch
sys-devel/libtool/libtool-2.4.6-r1.ebuild
sys-devel/libtool/libtool-9999.ebuild

index eb8ee07b6c9a65c9a6da5b5f6a8c5ed6696166c2..c352d52aac3bb9cf616028a5144aa8d776b5d8af 100644 (file)
@@ -25,10 +25,29 @@ index d5cf07a..0fc8279 100644
        -t[45]*|-txscale*|-p|-pg|--coverage|-fprofile-*|-F*|@*|-tp=*|--sysroot=*| \
 -      -O*|-g*|-flto*|-fwhopr*|-fuse-linker-plugin|-fstack-protector*|-stdlib=*)
 +      -O*|-g*|-flto*|-fwhopr*|-fuse-linker-plugin|-fstack-protector*|-stdlib=*| \
++      -fuse-ld=*)
+         func_quote_for_eval "$arg"
+       arg=$func_quote_for_eval_result
+         func_append compile_command " $arg"
+
+patch the generated file too to keep help2man from generating man pages
+https://bugs.gentoo.org/556512
+
+--- a/build-aux/ltmain.sh
++++ b/build-aux/ltmain.sh
+@@ -5360,10 +5360,12 @@ func_mode_link ()
+       # -tp=*                Portland pgcc target processor selection
+       # --sysroot=*          for sysroot support
+       # -O*, -g*, -flto*, -fwhopr*, -fuse-linker-plugin GCC link-time optimization
++      # -fuse-ld=*           Linker select flags for GCC
+       # -stdlib=*            select c++ std lib with clang
+       -64|-mips[0-9]|-r[0-9][0-9]*|-xarch=*|-xtarget=*|+DA*|+DD*|-q*|-m*| \
+       -t[45]*|-txscale*|-p|-pg|--coverage|-fprofile-*|-F*|@*|-tp=*|--sysroot=*| \
+-      -O*|-g*|-flto*|-fwhopr*|-fuse-linker-plugin|-fstack-protector*|-stdlib=*)
++      -O*|-g*|-flto*|-fwhopr*|-fuse-linker-plugin|-fstack-protector*|-stdlib=*| \
 +      -fuse-ld=*)
          func_quote_for_eval "$arg"
        arg=$func_quote_for_eval_result
          func_append compile_command " $arg"
 -- 
 2.3.2
-
index 5dbc9f92a2a18c8580a58d951027179ce2500e02..677db335de6592364285ed7fa1d02d56e4a21443 100644 (file)
@@ -53,6 +53,12 @@ src_prepare() {
        popd >/dev/null
        AT_NOELIBTOOLIZE=yes eautoreconf
        epunt_cxx
+
+       # Make sure timestamps don't trigger a rebuild of man pages. #556512
+       if [[ ${PV} != "9999" ]] ; then
+               touch doc/*.1
+               export HELP2MAN=false
+       fi
 }
 
 src_configure() {
index 923f8b49ee577de4057765dcc585e97eda6acd4f..8b6ede52b1cf5962ee5fea67a9ba32fc63b1df57 100644 (file)
@@ -50,6 +50,12 @@ src_prepare() {
        popd >/dev/null
        AT_NOELIBTOOLIZE=yes eautoreconf
        epunt_cxx
+
+       # Make sure timestamps don't trigger a rebuild of man pages. #556512
+       if [[ ${PV} != "9999" ]] ; then
+               touch doc/*.1
+               export HELP2MAN=false
+       fi
 }
 
 src_configure() {