dev-python/spyder: Clean old versions up
authorMichał Górny <mgorny@gentoo.org>
Tue, 2 May 2017 08:08:52 +0000 (10:08 +0200)
committerMichał Górny <mgorny@gentoo.org>
Tue, 2 May 2017 08:46:57 +0000 (10:46 +0200)
dev-python/spyder/Manifest
dev-python/spyder/files/spyder-2.3.1-build.patch [deleted file]
dev-python/spyder/files/spyder-2.3.8-build.patch [deleted file]
dev-python/spyder/spyder-2.3.4.ebuild [deleted file]
dev-python/spyder/spyder-2.3.5.2.ebuild [deleted file]
dev-python/spyder/spyder-2.3.8.ebuild [deleted file]
dev-python/spyder/spyder-3.0.2.ebuild [deleted file]

index 0e39a3c26ed2fd771e41d9e5fbd8b5f3760fe37f..ad028717f13e9ca2eb055ad2eec0d0510d8de1f8 100644 (file)
@@ -1,5 +1,2 @@
-DIST spyder-2.3.4.zip 3707063 SHA256 da4b13d6faed3e8810c0418f8274b26fde4f265ea4f93bee154af128a755c184 SHA512 7a4ea65ea06e9944094fc94db78327f9e23a8fd6dda5d0e9aa0e82ba4cd7d9f50b1eb837395a3fa2fabe814df873ad8ddbcca223144c47af4007b0493575e41e WHIRLPOOL 53e8f42bdafe01072457f27e45a279f92a198f181344f8267be2b3940cbd6d3743685ffe3264b04344f83bcb73b3eb8c9ec0e6bf8ccef26e19901324bfacb682
-DIST spyder-2.3.5.2.zip 3039104 SHA256 40e589467b561af534aac6d8cc2ea0dc244d3ae4457afb41b3aec6db6f8b2336 SHA512 ac8e078991b2889c3359e700bd89d4c8487eeba412512bc9bd7685214f687001bcc411016283bcde4eb73f6186ffc5cadc9614d911acd8b788899ef5aafd66e1 WHIRLPOOL e2b2bca44bd2ec1461875a358868ab34c60f30ac5164ff6312302b495e859000b97afc78ce12c69dbc328fdcbead247a9defce9e29c08de367fc7d3a321ff007
-DIST spyder-2.3.8.zip 3043528 SHA256 99fdae2cea325c0f2842c77bd67dd22db19fef3d9c0dde1545b1a2650eae517e SHA512 7d40e081ce2ea579d8d98e58e31b53afc04360bebcd52a226adc5ed387ed94d1aa24d0372c2e3594689d0f44a81df9986d8c3fbe4ccbae7a493ad039aaba3acc WHIRLPOOL dfd1edb2006c89df1a5bbc9d42a5e4e0042691fbcef71f855af6c0111f2b38bb88aef61ac00cfe8fed574e631af295aacb6d784d184ddb107e46616ce3a65e01
 DIST spyder-2.3.9.zip 3043753 SHA256 9b69df9abc7805fead522a8a1fe5b680bd0d07922564dde51c040e9f3fcb7349 SHA512 8808e0680779ffd0d3fad628bb9675babbede4ff92673786a8f4258ed5a0903a314c8db217e3f7aea0232282548c622df44541e14daa57b167732ff787a96166 WHIRLPOOL 8f8aa136216fe42d3d454211a9f8cf1f69dabce535f8a4fb5841fff3919141f957d90543e21c6809df2d0629e5011a66b5c1bdb6e1fe7fadb95a3081ef3a604e
 DIST spyder-3.0.2.tar.gz 3207709 SHA256 c308cae5d963a7332548db2dd91ebf105263eb493ce208221a59ad77592399c1 SHA512 7f3723bd98876aa4769877327a93aa02510689708012afc72148c67acd91ab134501ae57471d9cf0e17c9e3892a541b7730a2392ace3c6525443058d0ed01612 WHIRLPOOL 5f1f278fa3c6a98b8d7050bb32e9186cd7053e21d9050bf92b29088154ea3494995bf9953e04d63db4c71ccc37d3a2cdd7e38222b1f82decc2b763144cdf3642
diff --git a/dev-python/spyder/files/spyder-2.3.1-build.patch b/dev-python/spyder/files/spyder-2.3.1-build.patch
deleted file mode 100644 (file)
index 4300c30..0000000
+++ /dev/null
@@ -1,154 +0,0 @@
---- setup.py
-+++ setup.py
-@@ -21,8 +21,6 @@
- import shutil
- from distutils.core import setup
--from distutils.command.build import build
--from distutils.command.install_data import install_data
- # Check for Python 3
- PY3 = sys.version_info[0] == 3
-@@ -66,12 +64,7 @@
- def get_data_files():
-     """Return data_files in a platform dependent manner"""
-     if sys.platform.startswith('linux'):
--        if PY3:
--            data_files = [('share/applications', ['scripts/spyder3.desktop']),
--                          ('share/pixmaps', ['img_src/spyder3.png'])]
--        else:
--            data_files = [('share/applications', ['scripts/spyder.desktop']),
--                          ('share/pixmaps', ['img_src/spyder.png'])]
-+        data_files = [('share/pixmaps', ['img_src/spyder.png'])]
-     elif os.name == 'nt':
-         data_files = [('scripts', ['img_src/spyder.ico',
-                                    'img_src/spyder_light.ico'])]
-@@ -80,97 +73,6 @@
-     return data_files
--class MyInstallData(install_data):
--    def run(self):
--        install_data.run(self)
--        if sys.platform.startswith('linux'):
--            try:
--                subprocess.call(['update-desktop-database'])
--            except:
--                print("ERROR: unable to update desktop database",
--                      file=sys.stderr)
--CMDCLASS = {'install_data': MyInstallData}
--
--
--# Sphinx build (documentation)
--def get_html_help_exe():
--    """Return HTML Help Workshop executable path (Windows only)"""
--    if os.name == 'nt':
--        hhc_base = r'C:\Program Files%s\HTML Help Workshop\hhc.exe'
--        for hhc_exe in (hhc_base % '', hhc_base % ' (x86)'):
--            if osp.isfile(hhc_exe):
--                return hhc_exe
--        else:
--            return
--
--try:
--    from sphinx import setup_command
--
--    class MyBuild(build):
--        user_options = [('no-doc', None, "Don't build Spyder documentation")] \
--                       + build.user_options
--        def __init__(self, *args, **kwargs):
--            build.__init__(self, *args, **kwargs)
--            self.no_doc = False
--        def with_doc(self):
--            setup_dir = os.path.dirname(os.path.abspath(__file__))
--            is_doc_dir = os.path.isdir(os.path.join(setup_dir, 'doc'))
--            install_obj = self.distribution.get_command_obj('install')
--            return (is_doc_dir and not self.no_doc and not install_obj.no_doc)
--        sub_commands = build.sub_commands + [('build_doc', with_doc)]
--    CMDCLASS['build'] = MyBuild
--
--
--    class MyInstall(install):
--        user_options = [('no-doc', None, "Don't build Spyder documentation")] \
--                       + install.user_options
--        def __init__(self, *args, **kwargs):
--            install.__init__(self, *args, **kwargs)
--            self.no_doc = False
--    CMDCLASS['install'] = MyInstall
--
--
--    class MyBuildDoc(setup_command.BuildDoc):
--        def run(self):
--            build = self.get_finalized_command('build')
--            sys.path.insert(0, os.path.abspath(build.build_lib))
--            dirname = self.distribution.get_command_obj('build').build_purelib
--            self.builder_target_dir = osp.join(dirname, 'spyderlib', 'doc')
--            
--            if not osp.exists(self.builder_target_dir):
--                os.mkdir(self.builder_target_dir)
--
--            hhc_exe = get_html_help_exe()
--            self.builder = "html" if hhc_exe is None else "htmlhelp"
--
--            try:
--                setup_command.BuildDoc.run(self)
--            except UnicodeDecodeError:
--                print("ERROR: unable to build documentation because Sphinx "\
--                      "do not handle source path with non-ASCII characters. "\
--                      "Please try to move the source package to another "\
--                      "location (path with *only* ASCII characters).",
--                      file=sys.stderr)
--            sys.path.pop(0)
--            
--            # Building chm doc, if HTML Help Workshop is installed
--            if hhc_exe is not None:
--                fname = osp.join(self.builder_target_dir, 'Spyderdoc.chm')
--                subprocess.call('"%s" %s' % (hhc_exe, fname), shell=True)
--                if osp.isfile(fname):
--                    dest = osp.join(dirname, 'spyderlib')
--                    try:
--                        shutil.move(fname, dest)
--                    except shutil.Error:
--                        print("Unable to replace %s" % dest)
--                    shutil.rmtree(self.builder_target_dir)
--
--    CMDCLASS['build_doc'] = MyBuildDoc
--except ImportError:
--    print('WARNING: unable to build documentation because Sphinx '\
--          'is not installed', file=sys.stderr)
--
--
- NAME = 'spyder'
- LIBNAME = 'spyderlib'
- from spyderlib import __version__, __project_url__
-@@ -204,13 +106,7 @@
-     packages = get_subpackages(LIBNAME)+get_subpackages('spyderplugins')
-     return packages
--# NOTE: the '[...]_win_post_install.py' script is installed even on non-Windows
--# platforms due to a bug in pip installation process (see Issue 1158)
--SCRIPTS = ['%s_win_post_install.py' % NAME]
--if PY3 and sys.platform.startswith('linux'):
--    SCRIPTS.append('spyder3')
--else:
--    SCRIPTS.append('spyder')
-+SCRIPTS = ['spyder']
- EXTLIST = ['.mo', '.svg', '.png', '.css', '.html', '.js', '.chm', '.ini',
-            '.txt', '.rst']
- if os.name == 'nt':
-@@ -246,7 +142,7 @@
-       package_data={LIBNAME: get_package_data(LIBNAME, EXTLIST),
-                     'spyderplugins':
-                     get_package_data('spyderplugins', EXTLIST)},
--      requires=["rope (>=0.9.2)", "sphinx (>=0.6.0)", "PyQt4 (>=4.4)"],
-+      requires=["rope (>=0.9.2)", "PyQt4 (>=4.4)"],
-       scripts=[osp.join('scripts', fname) for fname in SCRIPTS],
-       data_files=get_data_files(),
-       options={"bdist_wininst":
-@@ -267,5 +163,4 @@
-                    'Programming Language :: Python :: 3',
-                    'Development Status :: 5 - Production/Stable',
-                    'Topic :: Scientific/Engineering',
--                   'Topic :: Software Development :: Widget Sets'],
--      cmdclass=CMDCLASS)
-+                   'Topic :: Software Development :: Widget Sets'])
diff --git a/dev-python/spyder/files/spyder-2.3.8-build.patch b/dev-python/spyder/files/spyder-2.3.8-build.patch
deleted file mode 100644 (file)
index 2a4646a..0000000
+++ /dev/null
@@ -1,154 +0,0 @@
---- a/setup.py
-+++ b/setup.py
-@@ -21,8 +21,6 @@
- import shutil
- from distutils.core import setup
--from distutils.command.build import build
--from distutils.command.install_data import install_data
- # Check for Python 3
- PY3 = sys.version_info[0] == 3
-@@ -66,12 +64,7 @@
- def get_data_files():
-     """Return data_files in a platform dependent manner"""
-     if sys.platform.startswith('linux'):
--        if PY3:
--            data_files = [('share/applications', ['scripts/spyder3.desktop']),
--                          ('share/pixmaps', ['img_src/spyder3.png'])]
--        else:
--            data_files = [('share/applications', ['scripts/spyder.desktop']),
--                          ('share/pixmaps', ['img_src/spyder.png'])]
-+        data_files = [('share/pixmaps', ['img_src/spyder.png'])]
-     elif os.name == 'nt':
-         data_files = [('scripts', ['img_src/spyder.ico',
-                                    'img_src/spyder_light.ico'])]
-@@ -80,97 +73,6 @@
-     return data_files
--class MyInstallData(install_data):
--    def run(self):
--        install_data.run(self)
--        if sys.platform.startswith('linux'):
--            try:
--                subprocess.call(['update-desktop-database'])
--            except:
--                print("ERROR: unable to update desktop database",
--                      file=sys.stderr)
--CMDCLASS = {'install_data': MyInstallData}
--
--
--# Sphinx build (documentation)
--def get_html_help_exe():
--    """Return HTML Help Workshop executable path (Windows only)"""
--    if os.name == 'nt':
--        hhc_base = r'C:\Program Files%s\HTML Help Workshop\hhc.exe'
--        for hhc_exe in (hhc_base % '', hhc_base % ' (x86)'):
--            if osp.isfile(hhc_exe):
--                return hhc_exe
--        else:
--            return
--
--try:
--    from sphinx import setup_command
--
--    class MyBuild(build):
--        user_options = [('no-doc', None, "Don't build Spyder documentation")] \
--                       + build.user_options
--        def __init__(self, *args, **kwargs):
--            build.__init__(self, *args, **kwargs)
--            self.no_doc = False
--        def with_doc(self):
--            setup_dir = os.path.dirname(os.path.abspath(__file__))
--            is_doc_dir = os.path.isdir(os.path.join(setup_dir, 'doc'))
--            install_obj = self.distribution.get_command_obj('install')
--            return (is_doc_dir and not self.no_doc and not install_obj.no_doc)
--        sub_commands = build.sub_commands + [('build_doc', with_doc)]
--    CMDCLASS['build'] = MyBuild
--
--
--    class MyInstall(install):
--        user_options = [('no-doc', None, "Don't build Spyder documentation")] \
--                       + install.user_options
--        def __init__(self, *args, **kwargs):
--            install.__init__(self, *args, **kwargs)
--            self.no_doc = False
--    CMDCLASS['install'] = MyInstall
--
--
--    class MyBuildDoc(setup_command.BuildDoc):
--        def run(self):
--            build = self.get_finalized_command('build')
--            sys.path.insert(0, os.path.abspath(build.build_lib))
--            dirname = self.distribution.get_command_obj('build').build_purelib
--            self.builder_target_dir = osp.join(dirname, 'spyderlib', 'doc')
--            
--            if not osp.exists(self.builder_target_dir):
--                os.mkdir(self.builder_target_dir)
--
--            hhc_exe = get_html_help_exe()
--            self.builder = "html" if hhc_exe is None else "htmlhelp"
--
--            try:
--                setup_command.BuildDoc.run(self)
--            except UnicodeDecodeError:
--                print("ERROR: unable to build documentation because Sphinx "\
--                      "do not handle source path with non-ASCII characters. "\
--                      "Please try to move the source package to another "\
--                      "location (path with *only* ASCII characters).",
--                      file=sys.stderr)
--            sys.path.pop(0)
--            
--            # Building chm doc, if HTML Help Workshop is installed
--            if hhc_exe is not None:
--                fname = osp.join(self.builder_target_dir, 'Spyderdoc.chm')
--                subprocess.call('"%s" %s' % (hhc_exe, fname), shell=True)
--                if osp.isfile(fname):
--                    dest = osp.join(dirname, 'spyderlib')
--                    try:
--                        shutil.move(fname, dest)
--                    except shutil.Error:
--                        print("Unable to replace %s" % dest)
--                    shutil.rmtree(self.builder_target_dir)
--
--    CMDCLASS['build_doc'] = MyBuildDoc
--except ImportError:
--    print('WARNING: unable to build documentation because Sphinx '\
--          'is not installed', file=sys.stderr)
--
--
- NAME = 'spyder'
- LIBNAME = 'spyderlib'
- from spyderlib import __version__, __project_url__
-@@ -204,13 +106,7 @@
-     packages = get_subpackages(LIBNAME)+get_subpackages('spyderplugins')
-     return packages
--# NOTE: the '[...]_win_post_install.py' script is installed even on non-Windows
--# platforms due to a bug in pip installation process (see Issue 1158)
--SCRIPTS = ['%s_win_post_install.py' % NAME]
--if PY3 and sys.platform.startswith('linux'):
--    SCRIPTS.append('spyder3')
--else:
--    SCRIPTS.append('spyder')
-+SCRIPTS = ['spyder']
- EXTLIST = ['.mo', '.svg', '.png', '.css', '.html', '.js', '.chm', '.ini',
-            '.txt', '.rst']
- if os.name == 'nt':
-@@ -246,7 +142,7 @@
-       package_data={LIBNAME: get_package_data(LIBNAME, EXTLIST),
-                     'spyderplugins':
-                     get_package_data('spyderplugins', EXTLIST)},
--      requires=["rope (>=0.9.2)", "sphinx (>=0.6.0)", "PyQt4 (>=4.4)"],
-+      requires=["rope (>=0.9.2)", "PyQt4 (>=4.4)"],
-       scripts=[osp.join('scripts', fname) for fname in SCRIPTS],
-       data_files=get_data_files(),
-       options={"bdist_wininst":
-@@ -267,5 +163,4 @@
-                    'Programming Language :: Python :: 3',
-                    'Development Status :: 5 - Production/Stable',
-                    'Topic :: Scientific/Engineering',
--                   'Topic :: Software Development :: Widget Sets'],
--      cmdclass=CMDCLASS)
-+                   'Topic :: Software Development :: Widget Sets'])
diff --git a/dev-python/spyder/spyder-2.3.4.ebuild b/dev-python/spyder/spyder-2.3.4.ebuild
deleted file mode 100644 (file)
index 8492dcc..0000000
+++ /dev/null
@@ -1,52 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-PYTHON_COMPAT=( python{2_7,3_4} )
-
-inherit distutils-r1
-
-DESCRIPTION="Python IDE with matlab-like features"
-HOMEPAGE="https://code.google.com/p/spyderlib/ https://bitbucket.org/spyder-ide/spyderlib"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.zip"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="doc ipython matplotlib numpy pep8 +pyflakes pylint +rope scipy sphinx"
-
-# rope requires no version bordering since all are >= miniumum version
-RDEPEND="
-       || ( dev-python/PyQt4[${PYTHON_USEDEP},svg,webkit]
-                dev-python/pyside[${PYTHON_USEDEP},svg,webkit] )
-       ipython? ( dev-python/ipython[qt4,${PYTHON_USEDEP}] )
-       matplotlib? ( dev-python/matplotlib[${PYTHON_USEDEP}] )
-       numpy? ( dev-python/numpy[${PYTHON_USEDEP}] )
-       pep8? ( dev-python/pep8[${PYTHON_USEDEP}] )
-       pyflakes? ( >=dev-python/pyflakes-0.5[${PYTHON_USEDEP}] )
-       pylint? ( dev-python/pylint[${PYTHON_USEDEP}] )
-       rope? ( $(python_gen_cond_dep 'dev-python/rope[${PYTHON_USEDEP}]' python2_7) )
-       scipy? ( sci-libs/scipy[${PYTHON_USEDEP}] )
-       sphinx? ( >=dev-python/sphinx-0.6.0[${PYTHON_USEDEP}] )"
-DEPEND="${RDEPEND}
-       app-arch/unzip
-       doc? ( >=dev-python/sphinx-0.6.0[${PYTHON_USEDEP}] )"
-
-# Courtesy of Arfrever
-PATCHES=( "${FILESDIR}"/${PN}-2.3.1-build.patch )
-
-python_compile_all() {
-       if use doc; then
-               einfo "Generation of documentation"
-               PYTHONPATH="{BUILD_DIR}" \
-                       sphinx-build doc doc/html || die "Generation of documentation failed"
-       fi
-}
-
-python_install_all() {
-       distutils-r1_python_install_all
-       doicon spyderlib/images/spyder.svg
-       make_desktop_entry spyder Spyder spyder "Development;IDE"
-       use doc && dohtml -r doc/html/
-}
diff --git a/dev-python/spyder/spyder-2.3.5.2.ebuild b/dev-python/spyder/spyder-2.3.5.2.ebuild
deleted file mode 100644 (file)
index 59e4e73..0000000
+++ /dev/null
@@ -1,50 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-PYTHON_COMPAT=( python{2_7,3_4} )
-
-inherit distutils-r1
-
-DESCRIPTION="Python IDE with matlab-like features"
-HOMEPAGE="https://code.google.com/p/spyderlib/ https://bitbucket.org/spyder-ide/spyderlib"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.zip"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="doc ipython matplotlib numpy pep8 +pyflakes pylint +rope scipy sphinx"
-
-# rope requires no version bordering since all are >= miniumum version
-RDEPEND="
-       || ( dev-python/PyQt4[${PYTHON_USEDEP},svg,webkit]
-                dev-python/pyside[${PYTHON_USEDEP},svg,webkit] )
-       ipython? ( dev-python/ipython[qt4,${PYTHON_USEDEP}] )
-       matplotlib? ( dev-python/matplotlib[${PYTHON_USEDEP}] )
-       numpy? ( dev-python/numpy[${PYTHON_USEDEP}] )
-       pep8? ( dev-python/pep8[${PYTHON_USEDEP}] )
-       pyflakes? ( >=dev-python/pyflakes-0.5[${PYTHON_USEDEP}] )
-       pylint? ( dev-python/pylint[${PYTHON_USEDEP}] )
-       rope? ( $(python_gen_cond_dep 'dev-python/rope[${PYTHON_USEDEP}]' python2_7) )
-       scipy? ( sci-libs/scipy[${PYTHON_USEDEP}] )
-       sphinx? ( >=dev-python/sphinx-0.6.0[${PYTHON_USEDEP}] )"
-DEPEND="${RDEPEND}
-       app-arch/unzip
-       doc? ( >=dev-python/sphinx-0.6.0[${PYTHON_USEDEP}] )"
-
-# Courtesy of Arfrever
-PATCHES=( "${FILESDIR}"/${PN}-2.3.1-build.patch )
-
-python_compile_all() {
-       if use doc; then
-               sphinx-build doc doc/html || die "Generation of documentation failed"
-       fi
-}
-
-python_install_all() {
-       distutils-r1_python_install_all
-       doicon spyderlib/images/spyder.svg
-       make_desktop_entry spyder Spyder spyder "Development;IDE"
-       use doc && dodoc -r doc/html/
-}
diff --git a/dev-python/spyder/spyder-2.3.8.ebuild b/dev-python/spyder/spyder-2.3.8.ebuild
deleted file mode 100644 (file)
index 33c7eca..0000000
+++ /dev/null
@@ -1,51 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python{2_7,3_4,3_5} )
-
-inherit eutils distutils-r1
-
-DESCRIPTION="Python IDE with matlab-like features"
-HOMEPAGE="https://github.com/spyder-ide/spyder"
-SRC_URI="https://bitbucket.org/${PN}-ide/${PN}lib/downloads/${P}.zip"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="doc ipython matplotlib numpy pep8 +pyflakes pylint qtconsole +rope scipy sphinx"
-
-# rope requires no version bordering since all are >= miniumum version
-RDEPEND="
-       || ( dev-python/PyQt4[${PYTHON_USEDEP},svg,webkit]
-       dev-python/pyside[${PYTHON_USEDEP},svg,webkit] )
-       ipython? ( dev-python/ipython[qt4,${PYTHON_USEDEP}] )
-       qtconsole? ( dev-python/qtconsole[${PYTHON_USEDEP}] )
-       matplotlib? ( dev-python/matplotlib[${PYTHON_USEDEP}] )
-       numpy? ( dev-python/numpy[${PYTHON_USEDEP}] )
-       pep8? ( dev-python/pep8[${PYTHON_USEDEP}] )
-       pyflakes? ( >=dev-python/pyflakes-0.5[${PYTHON_USEDEP}] )
-       pylint? ( dev-python/pylint[${PYTHON_USEDEP}] )
-       rope? ( $(python_gen_cond_dep 'dev-python/rope[${PYTHON_USEDEP}]' python2_7) )
-       scipy? ( sci-libs/scipy[${PYTHON_USEDEP}] )
-       sphinx? ( >=dev-python/sphinx-0.6.0[${PYTHON_USEDEP}] )"
-DEPEND="${RDEPEND}
-       app-arch/unzip
-       doc? ( >=dev-python/sphinx-0.6.0[${PYTHON_USEDEP}] )"
-
-# Courtesy of Arfrever
-PATCHES=( "${FILESDIR}"/${P}-build.patch )
-
-python_compile_all() {
-       if use doc; then
-               sphinx-build doc doc/html || die "Generation of documentation failed"
-       fi
-}
-
-python_install_all() {
-       use doc && local HTML_DOCS=( doc/html/. )
-       distutils-r1_python_install_all
-       doicon spyderlib/images/spyder.svg
-       make_desktop_entry spyder Spyder spyder "Development;IDE"
-}
diff --git a/dev-python/spyder/spyder-3.0.2.ebuild b/dev-python/spyder/spyder-3.0.2.ebuild
deleted file mode 100644 (file)
index 879a758..0000000
+++ /dev/null
@@ -1,57 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python{2_7,3_3,3_4,3_5} )
-
-inherit eutils distutils-r1
-
-DESCRIPTION="Python IDE with matlab-like features"
-HOMEPAGE="https://github.com/spyder-ide/spyder/ https://pypi.python.org/pypi/spyder/ http://pythonhosted.org/spyder/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="doc hdf5"
-
-RDEPEND="
-       || ( dev-python/PyQt5[${PYTHON_USEDEP},svg,webkit]
-               dev-python/PyQt4[${PYTHON_USEDEP},svg,webkit]
-               dev-python/pyside[${PYTHON_USEDEP},svg,webkit] )
-       dev-python/QtPy[${PYTHON_USEDEP},svg,webkit]
-       dev-python/qtconsole[${PYTHON_USEDEP}]
-       $(python_gen_cond_dep 'dev-python/rope[${PYTHON_USEDEP}]' python2_7)
-       $(python_gen_cond_dep 'dev-python/rope_py3k[${PYTHON_USEDEP}]' python3_4 python3_5)
-       dev-python/jedi[${PYTHON_USEDEP}]
-       dev-python/pyflakes[${PYTHON_USEDEP}]
-       dev-python/sphinx[${PYTHON_USEDEP}]
-       dev-python/pygments[${PYTHON_USEDEP}]
-       dev-python/pylint[${PYTHON_USEDEP}]
-       dev-python/pep8[${PYTHON_USEDEP}]
-       dev-python/psutil[${PYTHON_USEDEP}]
-       dev-python/nbconvert[${PYTHON_USEDEP}]
-       dev-python/qtawesome[${PYTHON_USEDEP}]
-       dev-python/pickleshare[${PYTHON_USEDEP}]
-       dev-python/pyzmq[${PYTHON_USEDEP}]
-       dev-python/chardet[${PYTHON_USEDEP}]
-       hdf5? ( dev-python/h5py[${PYTHON_USEDEP}] )"
-DEPEND="${RDEPEND}
-       app-arch/unzip"
-
-# Courtesy of Arfrever
-PATCHES=( "${FILESDIR}"/${P}-build.patch )
-
-python_compile_all() {
-       if use doc; then
-               sphinx-build doc doc/html || die "Generation of documentation failed"
-       fi
-}
-
-python_install_all() {
-       use doc && local HTML_DOCS=( doc/html/. )
-       distutils-r1_python_install_all
-       doicon spyder/images/spyder.svg
-       make_desktop_entry spyder Spyder spyder "Development;IDE"
-}