dev-ruby/whole_history_rating: use ls instead of git ls-files
authorAlessandro Barbieri <lssndrbarbieri@gmail.com>
Fri, 25 Oct 2019 20:36:03 +0000 (22:36 +0200)
committerMichał Górny <mgorny@gentoo.org>
Sun, 27 Oct 2019 09:12:01 +0000 (10:12 +0100)
Closes: https://bugs.gentoo.org/698532
Package-Manager: Portage-2.3.77, Repoman-2.3.17
Signed-off-by: Alessandro Barbieri <lssndrbarbieri@gmail.com>
Closes: https://github.com/gentoo/gentoo/pull/13438
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-ruby/whole_history_rating/whole_history_rating-0.1.2.ebuild

index 709e0ffdac87f53c4f1a86bcc1d12c096907c4c9..a9746bb09ab315a9d30afcc86e71f59c837b20c7 100644 (file)
@@ -24,3 +24,8 @@ ruby_add_bdepend "
                dev-ruby/test-unit:2
        )
 "
+
+all_ruby_prepare (){
+       sed -i 's/git ls-files/ls -1/g' "${RUBY_FAKEGEM_GEMSPEC}" || die
+       default
+}