dev-util/include-what-you-use: drop old
authorSergei Trofimovich <slyfox@gentoo.org>
Wed, 1 Apr 2020 20:50:35 +0000 (21:50 +0100)
committerSergei Trofimovich <slyfox@gentoo.org>
Wed, 1 Apr 2020 21:14:08 +0000 (22:14 +0100)
Package-Manager: Portage-2.3.96, Repoman-2.3.22
Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
dev-util/include-what-you-use/Manifest
dev-util/include-what-you-use/include-what-you-use-7.0.ebuild [deleted file]
dev-util/include-what-you-use/include-what-you-use-8.0.ebuild [deleted file]

index 18d3e0bc4e765a55840d0861428bc0fbdd3368ae..380480c41d90230ea89ec73954195a592f43a50f 100644 (file)
@@ -1,3 +1 @@
-DIST include-what-you-use-7.0.src.tar.gz 541840 BLAKE2B bf20a5598f02f03e5f714582653b8062eab6e414967ef2374c28bb6c1cdce8f73f80e3b2f4953fd943587ce17dc657cf6ab2a9db4208a59030d432f6a40532e5 SHA512 50d186b2e09c3595cc2dc7513e5db74da0038987158c2c45ef4279c67c50de621ca6499b07894ee203f25566aafaddde4b05840946f921678499d2efc131575a
-DIST include-what-you-use-8.0.src.tar.gz 545788 BLAKE2B 7b70d951b7ab2d62a8a6168ebf86dc76fd406159155dd93a509b8c39953506166ac18da3028be8dc7edfbb39eb96613b0e344067154dd8614fe7c63ad3ef04c6 SHA512 e75e91ce198b1ec446ed34afcf9fdbcb0534c5edc5346e4884f0f589c73512d778c428aa71c1b109d45a45543a952438610ab21e32ef1f03ff1a014823ed8425
 DIST include-what-you-use-9.0.src.tar.gz 589377 BLAKE2B b695354787070948d81e3e80b07bbe47a84b5609262df2220b6a62e6d648865b17e060951819f45956c6ca858977614d6e0401640509599b391a1165521b20de SHA512 f2d6ba05121a9968da9e42e8ac66f83ca0f35bfbe7cb1d616e2c6479cf2833c4668cb86e46a04ffcd5e77f10a575da9eeee5272c7609b5afad555d79cb640fb4
diff --git a/dev-util/include-what-you-use/include-what-you-use-7.0.ebuild b/dev-util/include-what-you-use/include-what-you-use-7.0.ebuild
deleted file mode 100644 (file)
index a63ca13..0000000
+++ /dev/null
@@ -1,55 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python3_6 )
-
-inherit cmake-utils flag-o-matic llvm python-single-r1
-
-DESCRIPTION="Find unused include directives in C/C++ programs"
-HOMEPAGE="https://include-what-you-use.org/"
-SRC_URI="https://github.com/${PN}/${PN}/archive/clang_${PV}.tar.gz -> ${P}.src.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-
-LLVM_MAX_SLOT=7
-
-RDEPEND="sys-devel/llvm:${LLVM_MAX_SLOT}
-       sys-devel/clang:${LLVM_MAX_SLOT}
-       ${PYTHON_DEPS}
-"
-DEPEND="${RDEPEND}"
-
-REQUIRED_USE=${PYTHON_REQUIRED_USE}
-
-S=${WORKDIR}/${PN}-clang_${PV}
-
-pkg_setup() {
-       llvm_pkg_setup
-       python-single-r1_pkg_setup
-}
-
-src_prepare() {
-       cmake-utils_src_prepare
-       python_fix_shebang .
-}
-
-src_configure() {
-       local mycmakeargs=(
-               # Note [llvm install path]
-               # Unfortunately all binaries using clang driver
-               # have to reside at the same path depth as
-               # 'clang' binary itself. See bug #625972
-               # Thus as a hack we install it to the same directory
-               # as llvm/clang itself.
-               -DCMAKE_INSTALL_PREFIX="$(get_llvm_prefix "${LLVM_MAX_SLOT}")"
-       )
-       cmake-utils_src_configure
-}
-
-src_test() {
-       "${EPYTHON}" run_iwyu_tests.py
-}
diff --git a/dev-util/include-what-you-use/include-what-you-use-8.0.ebuild b/dev-util/include-what-you-use/include-what-you-use-8.0.ebuild
deleted file mode 100644 (file)
index 8c945d5..0000000
+++ /dev/null
@@ -1,55 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python3_6 )
-
-inherit cmake-utils flag-o-matic llvm python-single-r1
-
-DESCRIPTION="Find unused include directives in C/C++ programs"
-HOMEPAGE="https://include-what-you-use.org/"
-SRC_URI="https://github.com/${PN}/${PN}/archive/clang_${PV}.tar.gz -> ${P}.src.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-
-LLVM_MAX_SLOT=8
-
-RDEPEND="sys-devel/llvm:${LLVM_MAX_SLOT}
-       sys-devel/clang:${LLVM_MAX_SLOT}
-       ${PYTHON_DEPS}
-"
-DEPEND="${RDEPEND}"
-
-REQUIRED_USE=${PYTHON_REQUIRED_USE}
-
-S=${WORKDIR}/${PN}-clang_${PV}
-
-pkg_setup() {
-       llvm_pkg_setup
-       python-single-r1_pkg_setup
-}
-
-src_prepare() {
-       cmake-utils_src_prepare
-       python_fix_shebang .
-}
-
-src_configure() {
-       local mycmakeargs=(
-               # Note [llvm install path]
-               # Unfortunately all binaries using clang driver
-               # have to reside at the same path depth as
-               # 'clang' binary itself. See bug #625972
-               # Thus as a hack we install it to the same directory
-               # as llvm/clang itself.
-               -DCMAKE_INSTALL_PREFIX="$(get_llvm_prefix "${LLVM_MAX_SLOT}")"
-       )
-       cmake-utils_src_configure
-}
-
-src_test() {
-       "${EPYTHON}" run_iwyu_tests.py
-}