dev-libs/oniguruma: version bump to 5.9.6_p1
authorTim Harder <radhermit@gentoo.org>
Mon, 12 Dec 2016 15:05:10 +0000 (10:05 -0500)
committerTim Harder <radhermit@gentoo.org>
Mon, 12 Dec 2016 15:07:03 +0000 (10:07 -0500)
dev-libs/oniguruma/Manifest
dev-libs/oniguruma/oniguruma-5.9.6_p1.ebuild [new file with mode: 0644]

index fa4dc56100d1c4ebff2c805368e5da9b37bc2e32..5c16708829eb6968421a47d3f56b9e06f544032b 100644 (file)
@@ -1 +1,2 @@
 DIST onig-5.9.5.tar.gz 587874 SHA256 9f49ae7819a5f47e25449d0e4b010d479f7868a24a7b9884b47041b49a76438a SHA512 3ba3c94c5e52c80c680ebf1d19be53fa5a94a11d622e0282184c7a9c8cc6676f1926b97d12aafc66514071e65cd7de2bd4632afb053c69b01ddb8b581e878252 WHIRLPOOL 4f8a52fc682c15a96660049159e98ddd9f68170e2cba3948f73f3105a266bce8b4c42329b4dc0d6f94472fd9139bbd9a8ebbf3f7351a95c868e78999ce276ece
+DIST onig-5.9.6_p1.tar.gz 605920 SHA256 ac34ae0624296b59ff9ad9a2e93f2b1cdd775ca87057a42d27e551b7a76ff7b4 SHA512 5c874a92acab19e7b228e855cee2d8c55648d3c0c25213127e67bba7f510ec68cb5d64999cf629ffa509745e1b0bd13dd80afbdcef3ba1d4bb8f3d0ee3616f48 WHIRLPOOL be0f030469cbaef0f196190a18725eb4f516b3b78c1a3484fe602462df1ada48fa848fc59f619f0089a352293825f809034c18e5964802fc964032d94e10f03b
diff --git a/dev-libs/oniguruma/oniguruma-5.9.6_p1.ebuild b/dev-libs/oniguruma/oniguruma-5.9.6_p1.ebuild
new file mode 100644 (file)
index 0000000..39e1a8d
--- /dev/null
@@ -0,0 +1,43 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+# Needed for a sane .so versionning on fbsd, please dont drop
+inherit autotools multilib-minimal
+
+MY_P=onig-${PV}
+
+DESCRIPTION="a regular expression library for different character encodings"
+HOMEPAGE="https://github.com/kkos/oniguruma"
+SRC_URI="https://github.com/kkos/${PN}/releases/download/v${PV}/${MY_P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x86-solaris"
+IUSE="combination-explosion-check crnl-as-line-terminator static-libs"
+
+PATCHES=( "${FILESDIR}"/${PN}-5.9.3-makefile.patch )
+DOCS=( AUTHORS HISTORY README{,.ja} doc/{API,FAQ,RE}{,.ja} )
+
+S=${WORKDIR}/${MY_P/_p1/}
+
+src_prepare() {
+       default
+       mv configure.{in,ac} || die
+       eautoreconf
+}
+
+multilib_src_configure() {
+       ECONF_SOURCE=${S} econf \
+               --enable-shared \
+               $(use_enable static-libs static) \
+               $(use_enable combination-explosion-check) \
+               $(use_enable crnl-as-line-terminator)
+}
+
+multilib_src_install_all() {
+       einstalldocs
+       find "${D}" -name '*.la' -delete || die
+}