net-fs/samba: Revbumps to introduce "snapper" USE flag
authorLars Wendler <polynomial-c@gentoo.org>
Mon, 25 May 2020 10:57:12 +0000 (12:57 +0200)
committerLars Wendler <polynomial-c@gentoo.org>
Mon, 25 May 2020 10:58:27 +0000 (12:58 +0200)
which helps to make sys-apps/dbus optional.

Thanks-to: Matt Taylor <liverbugg@rinux.org>
Closes: https://bugs.gentoo.org/721320
Package-Manager: Portage-2.3.100, Repoman-2.3.22
Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
net-fs/samba/files/samba-4.13-vfs_snapper_configure_option.patch [new file with mode: 0644]
net-fs/samba/metadata.xml
net-fs/samba/samba-4.11.9-r1.ebuild [new file with mode: 0644]
net-fs/samba/samba-4.12.3-r1.ebuild [new file with mode: 0644]

diff --git a/net-fs/samba/files/samba-4.13-vfs_snapper_configure_option.patch b/net-fs/samba/files/samba-4.13-vfs_snapper_configure_option.patch
new file mode 100644 (file)
index 0000000..b472119
--- /dev/null
@@ -0,0 +1,56 @@
+From 7ae03a19b3ca895ba5f97a6bd4f9539d8daa6e0a Mon Sep 17 00:00:00 2001
+From: Matt Taylor <liverbugg@rinux.org>
+Date: Mon, 11 May 2020 15:26:41 -0400
+Subject: [PATCH] build: add configure option to control vfs_snapper build
+
+vfs_snapper is currently built if dbus development headers / libraries
+are detected during configure. This commit adds new --disable-snapper
+and --enable-snapper (default) configure parameters. When enabled,
+configure will fail if the dbus development headers / libraries are
+missing.
+
+Signed-off-by: Matt Taylor <liverbugg@rinux.org>
+Reviewed-by: David Disseldorp <ddiss@samba.org>
+Reviewed-by: Andrew Bartlett <abartlet@samba.org>
+
+Autobuild-User(master): Andrew Bartlett <abartlet@samba.org>
+Autobuild-Date(master): Mon May 25 01:16:46 UTC 2020 on sn-devel-184
+---
+ source3/wscript | 12 +++++++++---
+ 1 file changed, 9 insertions(+), 3 deletions(-)
+
+diff --git a/source3/wscript b/source3/wscript
+index 07991806c63..24ade3b0a2b 100644
+--- a/source3/wscript
++++ b/source3/wscript
+@@ -74,6 +74,7 @@ def options(opt):
+     opt.samba_add_onoff_option('glusterfs', with_name="enable", without_name="disable", default=True)
+     opt.samba_add_onoff_option('cephfs', with_name="enable", without_name="disable", default=True)
++    opt.samba_add_onoff_option('snapper', with_name="enable", without_name="disable", default=True)
+     opt.add_option('--enable-vxfs',
+                   help=("enable support for VxFS (default=no)"),
+@@ -1752,11 +1753,16 @@ main() {
+     if Options.options.enable_vxfs:
+         conf.DEFINE('HAVE_VXFS', '1')
+-    if conf.CHECK_CFG(package='dbus-1', args='--cflags --libs',
++    if Options.options.with_snapper:
++        if conf.CHECK_CFG(package='dbus-1', args='--cflags --libs',
+                       msg='Checking for dbus', uselib_store="DBUS-1"):
+-        if (conf.CHECK_HEADERS('dbus/dbus.h', lib='dbus-1')
++            if (conf.CHECK_HEADERS('dbus/dbus.h', lib='dbus-1')
+                                       and conf.CHECK_LIB('dbus-1', shlib=True)):
+-            conf.DEFINE('HAVE_DBUS', '1')
++                conf.DEFINE('HAVE_DBUS', '1')
++        else:
++            conf.fatal("vfs_snapper is enabled but prerequisite DBUS libraries "
++                       "or headers not found. Use --disable-snapper to disable "
++                       "vfs_snapper support.");
+     if conf.CHECK_CFG(package='liburing', args='--cflags --libs',
+                       msg='Checking for liburing package', uselib_store="URING"):
+-- 
+2.26.2
+
index fb277df6bb3bdb7d64570f46d93a7c070c142247..d1bb8bfdd510584aac41a4a41ec4b288bf67519f 100644 (file)
@@ -21,6 +21,7 @@
                <flag name="iprint">Enabling iPrint technology by Novell</flag>
                <flag name="profiling-data">Enables support for collecting profiling data</flag>
                <flag name="quota">Enables support for user quotas</flag>
+               <flag name="snapper">Enable vfs_snapper module (requires <pkg>sys-apps/dbus</pkg>)</flag>
                <flag name="system-heimdal">Use <pkg>app-crypt/heimdal</pkg> instead of
                        bundled heimdal.</flag>
                <flag name="system-mitkrb5">Use <pkg>app-crypt/mit-krb5</pkg> instead of
diff --git a/net-fs/samba/samba-4.11.9-r1.ebuild b/net-fs/samba/samba-4.11.9-r1.ebuild
new file mode 100644 (file)
index 0000000..9043a94
--- /dev/null
@@ -0,0 +1,318 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+PYTHON_REQ_USE='threads(+),xml(+)'
+inherit python-single-r1 waf-utils multilib-minimal linux-info systemd pam
+
+MY_PV="${PV/_rc/rc}"
+MY_P="${PN}-${MY_PV}"
+
+SRC_PATH="stable"
+[[ ${PV} = *_rc* ]] && SRC_PATH="rc"
+
+SRC_URI="mirror://samba/${SRC_PATH}/${MY_P}.tar.gz"
+[[ ${PV} = *_rc* ]] || \
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+DESCRIPTION="Samba Suite Version 4"
+HOMEPAGE="https://www.samba.org/"
+LICENSE="GPL-3"
+
+SLOT="0"
+
+IUSE="acl addc addns ads ceph client cluster cups debug dmapi fam gpg iprint
+json ldap pam profiling-data python quota selinux snapper syslog
+system-heimdal +system-mitkrb5 systemd test winbind zeroconf"
+
+MULTILIB_WRAPPED_HEADERS=(
+       /usr/include/samba-4.0/policy.h
+       /usr/include/samba-4.0/dcerpc_server.h
+       /usr/include/samba-4.0/ctdb.h
+       /usr/include/samba-4.0/ctdb_client.h
+       /usr/include/samba-4.0/ctdb_protocol.h
+       /usr/include/samba-4.0/ctdb_private.h
+       /usr/include/samba-4.0/ctdb_typesafe_cb.h
+       /usr/include/samba-4.0/ctdb_version.h
+)
+
+CDEPEND="
+       >=app-arch/libarchive-3.1.2[${MULTILIB_USEDEP}]
+       dev-lang/perl:=
+       dev-libs/libbsd[${MULTILIB_USEDEP}]
+       dev-libs/libtasn1[${MULTILIB_USEDEP}]
+       dev-libs/popt[${MULTILIB_USEDEP}]
+       >=net-libs/gnutls-3.2.0[${MULTILIB_USEDEP}]
+       net-libs/libnsl:=[${MULTILIB_USEDEP}]
+       sys-libs/e2fsprogs-libs[${MULTILIB_USEDEP}]
+       >=sys-libs/ldb-2.0.10[ldap(+)?,python?,${PYTHON_SINGLE_USEDEP},${MULTILIB_USEDEP}]
+       <sys-libs/ldb-2.1.0[ldap(+)?,python?,${PYTHON_SINGLE_USEDEP},${MULTILIB_USEDEP}]
+       sys-libs/libcap
+       sys-libs/ncurses:0=
+       sys-libs/readline:0=
+       >=sys-libs/talloc-2.2.0[python?,${PYTHON_SINGLE_USEDEP},${MULTILIB_USEDEP}]
+       >=sys-libs/tdb-1.4.2[python?,${PYTHON_SINGLE_USEDEP},${MULTILIB_USEDEP}]
+       >=sys-libs/tevent-0.10.0[python?,${PYTHON_SINGLE_USEDEP},${MULTILIB_USEDEP}]
+       sys-libs/zlib[${MULTILIB_USEDEP}]
+       virtual/libiconv
+       pam? ( sys-libs/pam )
+       acl? ( virtual/acl )
+       $(python_gen_cond_dep "
+               dev-python/subunit[\${PYTHON_MULTI_USEDEP},${MULTILIB_USEDEP}]
+               addns? (
+                       net-dns/bind-tools[gssapi]
+                       dev-python/dnspython:=[\${PYTHON_MULTI_USEDEP}]
+               )
+       ")
+       ceph? ( sys-cluster/ceph )
+       cluster? (
+               net-libs/rpcsvc-proto
+               !dev-db/ctdb
+       )
+       cups? ( net-print/cups )
+       debug? ( dev-util/lttng-ust )
+       dmapi? ( sys-apps/dmapi )
+       fam? ( virtual/fam )
+       gpg? ( app-crypt/gpgme )
+       json? ( dev-libs/jansson )
+       ldap? ( net-nds/openldap[${MULTILIB_USEDEP}] )
+       snapper? ( sys-apps/dbus )
+       system-heimdal? ( >=app-crypt/heimdal-1.5[-ssl,${MULTILIB_USEDEP}] )
+       system-mitkrb5? ( >=app-crypt/mit-krb5-1.15.1[${MULTILIB_USEDEP}] )
+       systemd? ( sys-apps/systemd:0= )
+       zeroconf? ( net-dns/avahi )
+"
+DEPEND="${CDEPEND}
+       ${PYTHON_DEPS}
+       app-text/docbook-xsl-stylesheets
+       dev-libs/libxslt
+       >=dev-util/cmocka-1.1.1[${MULTILIB_USEDEP}]
+       net-libs/libtirpc[${MULTILIB_USEDEP}]
+       virtual/pkgconfig
+       || (
+               net-libs/rpcsvc-proto
+               <sys-libs/glibc-2.26[rpc(+)]
+       )
+       test? (
+               !system-mitkrb5? (
+                       >=sys-libs/nss_wrapper-1.1.3
+                       >=net-dns/resolv_wrapper-1.1.4
+                       >=net-libs/socket_wrapper-1.1.9
+                       >=sys-libs/uid_wrapper-1.2.1
+               )
+       )"
+RDEPEND="${CDEPEND}
+       python? ( ${PYTHON_DEPS} )
+       client? ( net-fs/cifs-utils[ads?] )
+       selinux? ( sec-policy/selinux-samba )
+       !dev-perl/Parse-Yapp
+"
+
+REQUIRED_USE="
+       addc? ( python json winbind )
+       addns? ( python )
+       ads? ( acl ldap winbind )
+       cluster? ( ads )
+       gpg? ( addc )
+       test? ( python )
+       ?? ( system-heimdal system-mitkrb5 )
+       ${PYTHON_REQUIRED_USE}
+"
+
+# the test suite is messed, it uses system-installed samba
+# bits instead of what was built, tests things disabled via use
+# flags, and generally just fails to work in a way ebuilds could
+# rely on in its current state
+RESTRICT="test"
+
+S="${WORKDIR}/${MY_P}"
+
+PATCHES=(
+       "${FILESDIR}/${PN}-4.4.0-pam.patch"
+       "${FILESDIR}/${PN}-4.9.2-timespec.patch"
+       "${FILESDIR}/${PN}-4.13-winexe_option.patch"
+       "${FILESDIR}/${PN}-4.13-vfs_snapper_configure_option.patch" 
+)
+
+#CONFDIR="${FILESDIR}/$(get_version_component_range 1-2)"
+CONFDIR="${FILESDIR}/4.4"
+
+WAF_BINARY="${S}/buildtools/bin/waf"
+
+SHAREDMODS=""
+
+pkg_setup() {
+       python-single-r1_pkg_setup
+       if use cluster ; then
+               SHAREDMODS="idmap_rid,idmap_tdb2,idmap_ad"
+       elif use ads ; then
+               SHAREDMODS="idmap_ad"
+       fi
+}
+
+src_prepare() {
+       default
+
+       # un-bundle dnspython
+       sed -i -e '/"dns.resolver":/d' "${S}"/third_party/wscript || die
+
+       # unbundle iso8601 unless tests are enabled
+       if ! use test ; then
+               sed -i -e '/"iso8601":/d' "${S}"/third_party/wscript || die
+       fi
+
+       ## ugly hackaround for bug #592502
+       #cp /usr/include/tevent_internal.h "${S}"/lib/tevent/ || die
+
+       sed -e 's:<gpgme\.h>:<gpgme/gpgme.h>:' \
+               -i source4/dsdb/samdb/ldb_modules/password_hash.c \
+               || die
+
+       # Friggin' WAF shit
+       multilib_copy_sources
+}
+
+multilib_src_configure() {
+       # when specifying libs for samba build you must append NONE to the end to
+       # stop it automatically including things
+       local bundled_libs="NONE"
+       if ! use system-heimdal && ! use system-mitkrb5 ; then
+               bundled_libs="heimbase,heimntlm,hdb,kdc,krb5,wind,gssapi,hcrypto,hx509,roken,asn1,com_err,NONE"
+       fi
+
+       local myconf=(
+               --enable-fhs
+               --sysconfdir="${EPREFIX}/etc"
+               --localstatedir="${EPREFIX}/var"
+               --with-modulesdir="${EPREFIX}/usr/$(get_libdir)/samba"
+               --with-piddir="${EPREFIX}/run/${PN}"
+               --bundled-libraries="${bundled_libs}"
+               --builtin-libraries=NONE
+               --disable-rpath
+               --disable-rpath-install
+               --nopyc
+               --nopyo
+               --without-winexe
+               $(multilib_native_use_with acl acl-support)
+               $(multilib_native_usex addc '' '--without-ad-dc')
+               $(multilib_native_use_with addns dnsupdate)
+               $(multilib_native_use_with ads)
+               $(multilib_native_use_enable ceph cephfs)
+               $(multilib_native_use_with cluster cluster-support)
+               $(multilib_native_use_enable cups)
+               $(multilib_native_use_with dmapi)
+               $(multilib_native_use_with fam)
+               $(multilib_native_use_with gpg gpgme)
+               $(multilib_native_use_with json)
+               $(multilib_native_use_enable iprint)
+               $(multilib_native_use_with pam)
+               $(multilib_native_usex pam "--with-pammodulesdir=${EPREFIX}/$(get_libdir)/security" '')
+               $(multilib_native_use_with quota quotas)
+               $(multilib_native_use_enable snapper)
+               $(multilib_native_use_with syslog)
+               $(multilib_native_use_with systemd)
+               --systemd-install-services
+               --with-systemddir="$(systemd_get_systemunitdir)"
+               $(multilib_native_use_with winbind)
+               $(multilib_native_usex python '' '--disable-python')
+               $(multilib_native_use_enable zeroconf avahi)
+               $(multilib_native_usex test '--enable-selftest' '')
+               $(usex system-mitkrb5 "--with-system-mitkrb5 $(multilib_native_usex addc --with-experimental-mit-ad-dc '')" '')
+               $(use_with debug lttng)
+               $(use_with ldap)
+               $(use_with profiling-data)
+               # bug #683148
+               --jobs 1
+       )
+
+       multilib_is_native_abi && myconf+=( --with-shared-modules=${SHAREDMODS} )
+
+       CPPFLAGS="-I${SYSROOT}${EPREFIX}/usr/include/et ${CPPFLAGS}" \
+               waf-utils_src_configure ${myconf[@]}
+}
+
+multilib_src_compile() {
+       waf-utils_src_compile
+}
+
+multilib_src_install() {
+       waf-utils_src_install
+
+       # Make all .so files executable
+       find "${ED}" -type f -name "*.so" -exec chmod +x {} + || die
+
+       if multilib_is_native_abi ; then
+               # install ldap schema for server (bug #491002)
+               if use ldap ; then
+                       insinto /etc/openldap/schema
+                       doins examples/LDAP/samba.schema
+               fi
+
+               # create symlink for cups (bug #552310)
+               if use cups ; then
+                       dosym ../../../bin/smbspool /usr/libexec/cups/backend/smb
+               fi
+
+               # install example config file
+               insinto /etc/samba
+               doins examples/smb.conf.default
+
+               # Fix paths in example file (#603964)
+               sed \
+                       -e '/log file =/s@/usr/local/samba/var/@/var/log/samba/@' \
+                       -e '/include =/s@/usr/local/samba/lib/@/etc/samba/@' \
+                       -e '/path =/s@/usr/local/samba/lib/@/var/lib/samba/@' \
+                       -e '/path =/s@/usr/local/samba/@/var/lib/samba/@' \
+                       -e '/path =/s@/usr/spool/samba@/var/spool/samba@' \
+                       -i "${ED%/}"/etc/samba/smb.conf.default || die
+
+               # Install init script and conf.d file
+               newinitd "${CONFDIR}/samba4.initd-r1" samba
+               newconfd "${CONFDIR}/samba4.confd" samba
+
+               systemd_dotmpfilesd "${FILESDIR}"/samba.conf
+               use addc || rm "${D}/$(systemd_get_systemunitdir)/samba.service" || die
+
+               # Preserve functionality for old gentoo-specific unit names
+               dosym nmb.service "$(systemd_get_systemunitdir)/nmbd.service"
+               dosym smb.service "$(systemd_get_systemunitdir)/smbd.service"
+               dosym winbind.service "$(systemd_get_systemunitdir)/winbindd.service"
+       fi
+
+       if use pam && use winbind ; then
+               newpamd "${CONFDIR}/system-auth-winbind.pam" system-auth-winbind
+               # bugs #376853 and #590374
+               insinto /etc/security
+               doins examples/pam_winbind/pam_winbind.conf
+       fi
+
+       keepdir /var/cache/samba
+       keepdir /var/lib/ctdb
+       keepdir /var/lib/samba/{bind-dns,private}
+       keepdir /var/log/samba
+}
+
+multilib_src_install_all() {
+       # Attempt to fix bug #673168
+       find "${ED}" -type d -name "Yapp" -print0 \
+               | xargs -0 --no-run-if-empty rm -r || die
+}
+
+multilib_src_test() {
+       if multilib_is_native_abi ; then
+               "${WAF_BINARY}" test || die "test failed"
+       fi
+}
+
+pkg_postinst() {
+       ewarn "Be aware that this release contains the best of all of Samba's"
+       ewarn "technology parts, both a file server (that you can reasonably expect"
+       ewarn "to upgrade existing Samba 3.x releases to) and the AD domain"
+       ewarn "controller work previously known as 'samba4'."
+
+       elog "For further information and migration steps make sure to read "
+       elog "https://samba.org/samba/history/${P}.html "
+       elog "https://wiki.samba.org/index.php/Samba4/HOWTO "
+}
diff --git a/net-fs/samba/samba-4.12.3-r1.ebuild b/net-fs/samba/samba-4.12.3-r1.ebuild
new file mode 100644 (file)
index 0000000..aabbf85
--- /dev/null
@@ -0,0 +1,316 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+PYTHON_REQ_USE='threads(+),xml(+)'
+inherit python-single-r1 waf-utils multilib-minimal linux-info systemd pam
+
+MY_PV="${PV/_rc/rc}"
+MY_P="${PN}-${MY_PV}"
+
+SRC_PATH="stable"
+[[ ${PV} = *_rc* ]] && SRC_PATH="rc"
+
+SRC_URI="mirror://samba/${SRC_PATH}/${MY_P}.tar.gz"
+[[ ${PV} = *_rc* ]] || \
+KEYWORDS="~amd64 ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+DESCRIPTION="Samba Suite Version 4"
+HOMEPAGE="https://www.samba.org/"
+LICENSE="GPL-3"
+
+SLOT="0"
+
+IUSE="acl addc addns ads ceph client cluster cups debug dmapi fam gpg iprint
+json ldap pam profiling-data python quota selinux snapper syslog
+system-heimdal +system-mitkrb5 systemd test winbind zeroconf"
+
+MULTILIB_WRAPPED_HEADERS=(
+       /usr/include/samba-4.0/policy.h
+       /usr/include/samba-4.0/dcerpc_server.h
+       /usr/include/samba-4.0/ctdb.h
+       /usr/include/samba-4.0/ctdb_client.h
+       /usr/include/samba-4.0/ctdb_protocol.h
+       /usr/include/samba-4.0/ctdb_private.h
+       /usr/include/samba-4.0/ctdb_typesafe_cb.h
+       /usr/include/samba-4.0/ctdb_version.h
+)
+
+CDEPEND="
+       >=app-arch/libarchive-3.1.2[${MULTILIB_USEDEP}]
+       dev-lang/perl:=
+       dev-libs/icu:=[${MULTILIB_USEDEP}]
+       dev-libs/libbsd[${MULTILIB_USEDEP}]
+       dev-libs/libtasn1[${MULTILIB_USEDEP}]
+       dev-libs/popt[${MULTILIB_USEDEP}]
+       dev-perl/Parse-Yapp
+       >=net-libs/gnutls-3.4.7[${MULTILIB_USEDEP}]
+       net-libs/libnsl:=[${MULTILIB_USEDEP}]
+       sys-libs/e2fsprogs-libs[${MULTILIB_USEDEP}]
+       >=sys-libs/ldb-2.1.3[ldap(+)?,python?,${PYTHON_SINGLE_USEDEP},${MULTILIB_USEDEP}]
+       <sys-libs/ldb-2.2.0[ldap(+)?,python?,${PYTHON_SINGLE_USEDEP},${MULTILIB_USEDEP}]
+       sys-libs/libcap[${MULTILIB_USEDEP}]
+       sys-libs/liburing[${MULTILIB_USEDEP}]
+       sys-libs/ncurses:0=
+       sys-libs/readline:0=
+       >=sys-libs/talloc-2.3.1[python?,${PYTHON_SINGLE_USEDEP},${MULTILIB_USEDEP}]
+       >=sys-libs/tdb-1.4.3[python?,${PYTHON_SINGLE_USEDEP},${MULTILIB_USEDEP}]
+       >=sys-libs/tevent-0.10.2[python?,${PYTHON_SINGLE_USEDEP},${MULTILIB_USEDEP}]
+       sys-libs/zlib[${MULTILIB_USEDEP}]
+       virtual/libiconv
+       pam? ( sys-libs/pam )
+       acl? ( virtual/acl )
+       $(python_gen_cond_dep "
+               dev-python/subunit[\${PYTHON_MULTI_USEDEP},${MULTILIB_USEDEP}]
+               addns? (
+                       net-dns/bind-tools[gssapi]
+                       dev-python/dnspython:=[\${PYTHON_MULTI_USEDEP}]
+               )
+       ")
+       ceph? ( sys-cluster/ceph )
+       cluster? (
+               net-libs/rpcsvc-proto
+               !dev-db/ctdb
+       )
+       cups? ( net-print/cups )
+       debug? ( dev-util/lttng-ust )
+       dmapi? ( sys-apps/dmapi )
+       fam? ( virtual/fam )
+       gpg? ( app-crypt/gpgme )
+       json? ( dev-libs/jansson )
+       ldap? ( net-nds/openldap[${MULTILIB_USEDEP}] )
+       snapper? ( sys-apps/dbus )
+       system-heimdal? ( >=app-crypt/heimdal-1.5[-ssl,${MULTILIB_USEDEP}] )
+       system-mitkrb5? ( >=app-crypt/mit-krb5-1.15.1[${MULTILIB_USEDEP}] )
+       systemd? ( sys-apps/systemd:0= )
+       zeroconf? ( net-dns/avahi )
+"
+DEPEND="${CDEPEND}
+       ${PYTHON_DEPS}
+       app-text/docbook-xsl-stylesheets
+       dev-libs/libxslt
+       >=dev-util/cmocka-1.1.3[${MULTILIB_USEDEP}]
+       net-libs/libtirpc[${MULTILIB_USEDEP}]
+       virtual/pkgconfig
+       || (
+               net-libs/rpcsvc-proto
+               <sys-libs/glibc-2.26[rpc(+)]
+       )
+       test? (
+               !system-mitkrb5? (
+                       >=sys-libs/nss_wrapper-1.1.3
+                       >=net-dns/resolv_wrapper-1.1.4
+                       >=net-libs/socket_wrapper-1.1.9
+                       >=sys-libs/uid_wrapper-1.2.1
+               )
+       )"
+RDEPEND="${CDEPEND}
+       python? ( ${PYTHON_DEPS} )
+       client? ( net-fs/cifs-utils[ads?] )
+       selinux? ( sec-policy/selinux-samba )
+"
+
+REQUIRED_USE="
+       addc? ( python json winbind )
+       addns? ( python )
+       ads? ( acl ldap winbind )
+       cluster? ( ads )
+       gpg? ( addc )
+       test? ( python )
+       ?? ( system-heimdal system-mitkrb5 )
+       ${PYTHON_REQUIRED_USE}
+"
+
+# the test suite is messed, it uses system-installed samba
+# bits instead of what was built, tests things disabled via use
+# flags, and generally just fails to work in a way ebuilds could
+# rely on in its current state
+RESTRICT="test"
+
+S="${WORKDIR}/${MY_P}"
+
+PATCHES=(
+       "${FILESDIR}/${PN}-4.4.0-pam.patch"
+       "${FILESDIR}/${PN}-4.9.2-timespec.patch"
+       "${FILESDIR}/${PN}-4.13-winexe_option.patch"
+       "${FILESDIR}/${PN}-4.13-vfs_snapper_configure_option.patch" 
+)
+
+#CONFDIR="${FILESDIR}/$(get_version_component_range 1-2)"
+CONFDIR="${FILESDIR}/4.4"
+
+WAF_BINARY="${S}/buildtools/bin/waf"
+
+SHAREDMODS=""
+
+pkg_setup() {
+       python-single-r1_pkg_setup
+       if use cluster ; then
+               SHAREDMODS="idmap_rid,idmap_tdb2,idmap_ad"
+       elif use ads ; then
+               SHAREDMODS="idmap_ad"
+       fi
+}
+
+src_prepare() {
+       default
+
+       # un-bundle dnspython
+       sed -i -e '/"dns.resolver":/d' "${S}"/third_party/wscript || die
+
+       # unbundle iso8601 unless tests are enabled
+       if ! use test ; then
+               sed -i -e '/"iso8601":/d' "${S}"/third_party/wscript || die
+       fi
+
+       ## ugly hackaround for bug #592502
+       #cp /usr/include/tevent_internal.h "${S}"/lib/tevent/ || die
+
+       sed -e 's:<gpgme\.h>:<gpgme/gpgme.h>:' \
+               -i source4/dsdb/samdb/ldb_modules/password_hash.c \
+               || die
+
+       # Friggin' WAF shit
+       multilib_copy_sources
+}
+
+multilib_src_configure() {
+       # when specifying libs for samba build you must append NONE to the end to
+       # stop it automatically including things
+       local bundled_libs="NONE"
+       if ! use system-heimdal && ! use system-mitkrb5 ; then
+               bundled_libs="heimbase,heimntlm,hdb,kdc,krb5,wind,gssapi,hcrypto,hx509,roken,asn1,com_err,NONE"
+       fi
+
+       local myconf=(
+               --enable-fhs
+               --sysconfdir="${EPREFIX}/etc"
+               --localstatedir="${EPREFIX}/var"
+               --with-modulesdir="${EPREFIX}/usr/$(get_libdir)/samba"
+               --with-piddir="${EPREFIX}/run/${PN}"
+               --bundled-libraries="${bundled_libs}"
+               --builtin-libraries=NONE
+               --disable-rpath
+               --disable-rpath-install
+               --nopyc
+               --nopyo
+               --without-winexe
+               $(multilib_native_use_with acl acl-support)
+               $(multilib_native_usex addc '' '--without-ad-dc')
+               $(multilib_native_use_with addns dnsupdate)
+               $(multilib_native_use_with ads)
+               $(multilib_native_use_enable ceph cephfs)
+               $(multilib_native_use_with cluster cluster-support)
+               $(multilib_native_use_enable cups)
+               $(multilib_native_use_with dmapi)
+               $(multilib_native_use_with fam)
+               $(multilib_native_use_with gpg gpgme)
+               $(multilib_native_use_with json)
+               $(multilib_native_use_enable iprint)
+               $(multilib_native_use_with pam)
+               $(multilib_native_usex pam "--with-pammodulesdir=${EPREFIX}/$(get_libdir)/security" '')
+               $(multilib_native_use_with quota quotas)
+               $(multilib_native_use_enable snapper)
+               $(multilib_native_use_with syslog)
+               $(multilib_native_use_with systemd)
+               --systemd-install-services
+               --with-systemddir="$(systemd_get_systemunitdir)"
+               $(multilib_native_use_with winbind)
+               $(multilib_native_usex python '' '--disable-python')
+               $(multilib_native_use_enable zeroconf avahi)
+               $(multilib_native_usex test '--enable-selftest' '')
+               $(usex system-mitkrb5 "--with-system-mitkrb5 $(multilib_native_usex addc --with-experimental-mit-ad-dc '')" '')
+               $(use_with debug lttng)
+               $(use_with ldap)
+               $(use_with profiling-data)
+               # bug #683148
+               --jobs 1
+       )
+
+       multilib_is_native_abi && myconf+=( --with-shared-modules=${SHAREDMODS} )
+
+       CPPFLAGS="-I${SYSROOT}${EPREFIX}/usr/include/et ${CPPFLAGS}" \
+               waf-utils_src_configure ${myconf[@]}
+}
+
+multilib_src_compile() {
+       waf-utils_src_compile
+}
+
+multilib_src_install() {
+       waf-utils_src_install
+
+       # Make all .so files executable
+       find "${ED}" -type f -name "*.so" -exec chmod +x {} + || die
+
+       if multilib_is_native_abi ; then
+               # install ldap schema for server (bug #491002)
+               if use ldap ; then
+                       insinto /etc/openldap/schema
+                       doins examples/LDAP/samba.schema
+               fi
+
+               # create symlink for cups (bug #552310)
+               if use cups ; then
+                       dosym ../../../bin/smbspool /usr/libexec/cups/backend/smb
+               fi
+
+               # install example config file
+               insinto /etc/samba
+               doins examples/smb.conf.default
+
+               # Fix paths in example file (#603964)
+               sed \
+                       -e '/log file =/s@/usr/local/samba/var/@/var/log/samba/@' \
+                       -e '/include =/s@/usr/local/samba/lib/@/etc/samba/@' \
+                       -e '/path =/s@/usr/local/samba/lib/@/var/lib/samba/@' \
+                       -e '/path =/s@/usr/local/samba/@/var/lib/samba/@' \
+                       -e '/path =/s@/usr/spool/samba@/var/spool/samba@' \
+                       -i "${ED%/}"/etc/samba/smb.conf.default || die
+
+               # Install init script and conf.d file
+               newinitd "${CONFDIR}/samba4.initd-r1" samba
+               newconfd "${CONFDIR}/samba4.confd" samba
+
+               systemd_dotmpfilesd "${FILESDIR}"/samba.conf
+               use addc || rm "${D}/$(systemd_get_systemunitdir)/samba.service" || die
+
+               # Preserve functionality for old gentoo-specific unit names
+               dosym nmb.service "$(systemd_get_systemunitdir)/nmbd.service"
+               dosym smb.service "$(systemd_get_systemunitdir)/smbd.service"
+               dosym winbind.service "$(systemd_get_systemunitdir)/winbindd.service"
+       fi
+
+       if use pam && use winbind ; then
+               newpamd "${CONFDIR}/system-auth-winbind.pam" system-auth-winbind
+               # bugs #376853 and #590374
+               insinto /etc/security
+               doins examples/pam_winbind/pam_winbind.conf
+       fi
+
+       keepdir /var/cache/samba
+       keepdir /var/lib/ctdb
+       keepdir /var/lib/samba/{bind-dns,private}
+       keepdir /var/lock/samba
+       keepdir /var/log/samba
+       keepdir /var/run/samba
+}
+
+multilib_src_test() {
+       if multilib_is_native_abi ; then
+               "${WAF_BINARY}" test || die "test failed"
+       fi
+}
+
+pkg_postinst() {
+       ewarn "Be aware that this release contains the best of all of Samba's"
+       ewarn "technology parts, both a file server (that you can reasonably expect"
+       ewarn "to upgrade existing Samba 3.x releases to) and the AD domain"
+       ewarn "controller work previously known as 'samba4'."
+
+       elog "For further information and migration steps make sure to read "
+       elog "https://samba.org/samba/history/${P}.html "
+       elog "https://wiki.samba.org/index.php/Samba4/HOWTO "
+}