gnome-extra/gnome-documents: Version bump
authorPacho Ramos <pacho@gentoo.org>
Sat, 25 Jun 2016 17:39:04 +0000 (19:39 +0200)
committerPacho Ramos <pacho@gentoo.org>
Sat, 25 Jun 2016 18:42:30 +0000 (20:42 +0200)
Package-Manager: portage-2.3.0_rc1

gnome-extra/gnome-documents/Manifest
gnome-extra/gnome-documents/gnome-documents-3.20.0.ebuild [new file with mode: 0644]

index 393adbec8e13c20ceafe853f72188defe85c1772..e6d6020c923786e00f867c54a1dc86a88aac40b1 100644 (file)
@@ -1 +1,2 @@
 DIST gnome-documents-3.18.3.tar.xz 2297720 SHA256 16a50d509d43009d58b44b5f6d4d92e155a55dcb22bd8e0fdfd63b8d2ab48b91 SHA512 69129100858434c99d3a47bfa776637e8d26eda5eb40d089f1c32da6ef1ecc3265c17cbcb657e944559dbca788445a66956c7aabbb24167ec095d8af4f4d29de WHIRLPOOL b5be7ad7ed8bc1ad484a94a1b83dc53389277181a63ccf16519b7bcf798e471082fa4d133173a6dc55628ba3a7ad2e37c8063f987ffd00a38c59efdea7749942
+DIST gnome-documents-3.20.0.tar.xz 2319732 SHA256 a5fa496c5e80eccb8d2e5bba7f4d7dc4cc6c9f53d5bc028402428771be1237d2 SHA512 f69c48f8c343e674aca77f3334ce1a10d30f90f2dade5722d7c0b759e67d2c633199d510ff3c70a202e7ed6b309d93035eb35c4ae554a8da83aefb78fafeacaa WHIRLPOOL 5d7a537bfc19130646e43239acd51fa21154b4a648e0be895252c55ea84714d2a26c876862781c56d365222d1ad36fa71bac7d6d40edd31ec5ea951b06e7edb9
diff --git a/gnome-extra/gnome-documents/gnome-documents-3.20.0.ebuild b/gnome-extra/gnome-documents/gnome-documents-3.20.0.ebuild
new file mode 100644 (file)
index 0000000..104aee2
--- /dev/null
@@ -0,0 +1,47 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+inherit gnome2
+
+DESCRIPTION="A document manager application for GNOME"
+HOMEPAGE="https://wiki.gnome.org/Apps/Documents"
+
+LICENSE="GPL-2+"
+SLOT="0"
+IUSE=""
+KEYWORDS="~amd64 ~x86"
+
+# Need gdk-pixbuf-2.25 for gdk_pixbuf_get_pixels_with_length
+COMMON_DEPEND="
+       >=app-misc/tracker-1:=[miner-fs]
+       >=app-text/evince-3.13.3[introspection]
+       dev-libs/gjs
+       >=dev-libs/glib-2.39.3:2
+       >=dev-libs/gobject-introspection-1.31.6:=
+       >=dev-libs/libgdata-0.13.3:=[crypt,gnome-online-accounts,introspection]
+       gnome-base/gnome-desktop:3=
+       >=media-libs/clutter-1.10:1.0
+       >=media-libs/clutter-gtk-1.3.2:1.0[introspection]
+       >=net-libs/gnome-online-accounts-3.2.0
+       >=net-libs/libsoup-2.41.3:2.4
+       >=net-libs/libzapojit-0.0.2
+       >=net-libs/webkit-gtk-2.6:4
+       >=x11-libs/gdk-pixbuf-2.25:2[introspection]
+       >=x11-libs/gtk+-3.19.1:3[introspection]
+       x11-libs/pango[introspection]
+"
+RDEPEND="${COMMON_DEPEND}
+       media-libs/clutter[introspection]
+       net-misc/gnome-online-miners
+       sys-apps/dbus
+       x11-themes/adwaita-icon-theme
+"
+DEPEND="${COMMON_DEPEND}
+       dev-libs/libxslt
+       >=dev-util/intltool-0.50.1
+       dev-util/itstool
+       virtual/pkgconfig
+"
+# eautoreconf requires yelp-tools