dev-ros/rqt_launch: bump to 0.4.8 and update to split repos
authorAlexis Ballier <aballier@gentoo.org>
Tue, 25 Apr 2017 05:42:00 +0000 (07:42 +0200)
committerAlexis Ballier <aballier@gentoo.org>
Tue, 25 Apr 2017 06:40:05 +0000 (08:40 +0200)
Package-Manager: Portage-2.3.5, Repoman-2.3.2

dev-ros/rqt_launch/Manifest
dev-ros/rqt_launch/metadata.xml
dev-ros/rqt_launch/rqt_launch-0.4.8.ebuild [new file with mode: 0644]
dev-ros/rqt_launch/rqt_launch-9999.ebuild

index 7bb8c4d74093009871a7fac050b5df5b997ec913..ae8fbb05362801004d884d9c7eb9db7f6402e8bf 100644 (file)
@@ -1 +1,2 @@
 DIST rqt_common_plugins-0.4.7.tar.gz 246977 SHA256 83153ad89c67551c3fb4f36cad7f056d90c559958ac80203e2aa4605beb49a7f SHA512 eb10a7c03bb079d939a9705a08e9194c83e020235a13ed2d4ff8e9c3c73e5abbd0a9bd7c00587135767497b155bb9516d7b4c2240fbe2118d7b0668d6ee32ab7 WHIRLPOOL b002f836ee0f5ea213ec31be8e59910c7c3c9508301389309e60eeb7dd35989ae4e4dfa5fa9ee592371f05e6cd842a6e3b0ccd6ac4ed7a9efd8d60c36b1e6d65
+DIST rqt_launch-0.4.8.tar.gz 11471 SHA256 6c3fcde64a2a4458a010ec5dbd7217cf61170ff3a90529ba0d000f43437c2c54 SHA512 83a40eca2c2282f2e5e397332b5b61b60ac27312b31ad21c21f03243e1b28961d96ba93f4e8c5043e05791c85d1fa88fee461f4b457934fcb68e47a60239cc89 WHIRLPOOL c7bfdec8d9d08ccab16f026a15a33393bf37acef158df3b90bc746df2bb9af8d2e94d80dd33cfd97ee15b6d020b3c26b374351087218c0374b3b6fab4e1d807a
index cb473d142b8e7ce5b6c875e4ff9f5c2ac8c49e79..ca85215d435cb8934f5e329cf602509cc36748d3 100644 (file)
@@ -6,6 +6,6 @@
                <name>Gentoo ROS Project</name>
        </maintainer>
        <upstream>
-               <remote-id type="github">ros-visualization/rqt_common_plugins</remote-id>
+               <remote-id type="github">ros-visualization/rqt_launch</remote-id>
        </upstream>
 </pkgmetadata>
diff --git a/dev-ros/rqt_launch/rqt_launch-0.4.8.ebuild b/dev-ros/rqt_launch/rqt_launch-0.4.8.ebuild
new file mode 100644 (file)
index 0000000..17b433a
--- /dev/null
@@ -0,0 +1,26 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+KEYWORDS="~amd64"
+ROS_REPO_URI="https://github.com/ros-visualization/rqt_launch"
+PYTHON_COMPAT=( python2_7 )
+
+inherit ros-catkin
+
+DESCRIPTION="Easy view of .launch files"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+       dev-ros/rqt_py_common[${PYTHON_USEDEP}]
+       dev-ros/roslaunch[${PYTHON_USEDEP}]
+       dev-ros/rospy[${PYTHON_USEDEP}]
+       dev-ros/rqt_console[${PYTHON_USEDEP}]
+       dev-ros/rqt_gui[${PYTHON_USEDEP}]
+       dev-ros/rqt_gui_py[${PYTHON_USEDEP}]
+       dev-ros/rqt_py_common[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"
index 3af3fdee2d47086bb329d268e846f09fa11e56a8..17b433a783aec56d8082304e3766b6d8b73c6442 100644 (file)
@@ -1,12 +1,11 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=5
 
 KEYWORDS="~amd64"
-ROS_REPO_URI="https://github.com/ros-visualization/rqt_common_plugins"
+ROS_REPO_URI="https://github.com/ros-visualization/rqt_launch"
 PYTHON_COMPAT=( python2_7 )
-ROS_SUBDIR=${PN}
 
 inherit ros-catkin