sys-power/sispmctl: Version 4.1
authorJeroen Roovers <jer@gentoo.org>
Fri, 29 May 2020 07:10:48 +0000 (09:10 +0200)
committerJeroen Roovers <jer@gentoo.org>
Fri, 29 May 2020 07:16:01 +0000 (09:16 +0200)
- EAPI=7
- Remove obsolete USE=gemplug (bug #632476)
- Add USE=static-libs (bug #725974) and drop .la file
- Do not install empty NEWS
- Use udev.eclass to install rules file
- Install systemd thingamy

Package-Manager: Portage-2.3.100, Repoman-2.3.22
Closes: https://bugs.gentoo.org/632476
Closes: https://bugs.gentoo.org/725974
Signed-off-by: Jeroen Roovers <jer@gentoo.org>
sys-power/sispmctl/Manifest
sys-power/sispmctl/sispmctl-4.1.ebuild [new file with mode: 0644]

index 75f9d417b367fb0881ab9738688af0378c06c04d..24b85c8bd4762e000eddf889ca8dbee1678b1084 100644 (file)
@@ -1 +1,2 @@
 DIST sispmctl-4.0.tar.gz 517985 BLAKE2B 61e709031f6c5bec5ef011cb33b03661f004cce2ec57986f887daf346dda4cd86e280a7350e118baf2a7b6b2f0ecf22aebd9b28661828b9edfb7b8ddea3f88b5 SHA512 0fc643b627ccfa10f085b37702933fe9b7c2ef448bcbb32c22cacda57f7f710437c413bd02f510a3acb085f99a513a891e815981ee4ffbe7fed691492a335e96
+DIST sispmctl-4.1.tar.gz 429477 BLAKE2B fe9231a5a0b22456d81166ae5dbaf98c86a636e79ff09112438c769daa503996128d31609bd90f66a5414459c9fce66956b1ee001ac3d57f8f472a09b34aee20 SHA512 52cf6e7d4df76c1d28d196a81a06dec59047f2d43571bc72ff08a22359c3e5d7a36fd446118036fe35f9c26e59a07563ac15d9e05285e7b09214b68aab5ef488
diff --git a/sys-power/sispmctl/sispmctl-4.1.ebuild b/sys-power/sispmctl/sispmctl-4.1.ebuild
new file mode 100644 (file)
index 0000000..693002d
--- /dev/null
@@ -0,0 +1,46 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit bash-completion-r1 systemd udev user
+
+DESCRIPTION="GEMBIRD SiS-PM control utility"
+HOMEPAGE="http://sispmctl.sourceforge.net/"
+SRC_URI="mirror://sourceforge/sispmctl/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="static-libs"
+
+RDEPEND="
+       virtual/libusb:0
+"
+DEPEND="
+       ${RDEPEND}
+"
+DOCS="AUTHORS README ChangeLog"
+
+pkg_setup() {
+       enewgroup ${PN}
+}
+
+src_configure() {
+       econf \
+               $(use_enable static-libs static) \
+               --enable-webless
+}
+
+src_install() {
+       default
+
+       find "${ED}" -name '*.la' -delete || die
+
+       ## install udev rules which make the device files writable
+       ## by the members of the group sispmctl
+       udev_dorules examples/60-sispmctl.rules
+
+       systemd_dounit examples/${PN}.service
+
+       einfo "Add users who may run ${PN} to the group '${PN}'"
+}