net-proxy/ufdbguard: Remove last-rited pkg
authorMichał Górny <mgorny@gentoo.org>
Sat, 20 Apr 2019 07:50:45 +0000 (09:50 +0200)
committerMichał Górny <mgorny@gentoo.org>
Sat, 20 Apr 2019 07:50:45 +0000 (09:50 +0200)
Closes: https://bugs.gentoo.org/677482
Signed-off-by: Michał Górny <mgorny@gentoo.org>
net-proxy/ufdbguard/Manifest [deleted file]
net-proxy/ufdbguard/files/ufdb.confd [deleted file]
net-proxy/ufdbguard/files/ufdb.initd [deleted file]
net-proxy/ufdbguard/files/ufdb.initd.2 [deleted file]
net-proxy/ufdbguard/files/ufdbUpdate.cron [deleted file]
net-proxy/ufdbguard/files/ufdbguard-1.24-gentoo.patch [deleted file]
net-proxy/ufdbguard/metadata.xml [deleted file]
net-proxy/ufdbguard/ufdbguard-1.32.4.ebuild [deleted file]
profiles/package.mask

diff --git a/net-proxy/ufdbguard/Manifest b/net-proxy/ufdbguard/Manifest
deleted file mode 100644 (file)
index e66ae91..0000000
+++ /dev/null
@@ -1,2 +0,0 @@
-DIST ufdbGuard-1.32.4.tar.gz 2499206 BLAKE2B 02070298cecdb93e189054d129235f391b7de94d1476f61b55cb7c1a38362b55817dfda1805d593a8939421889084135c3dfa7c3e72699d46667ad7263123aef SHA512 189cb67c533ab71ba1d3292a376d746e0565a3bf5de17f4407c5892ee24c20cd2574752bdcb08be19621a93114cc69a89767c581d531027ecbf6487ef3119d91
-DIST ufdbguard-1.32.4-manual.pdf 642626 BLAKE2B 335effd8443b005e4df067778bdbbd9fe2e4442009a8f59de70dec87aa265e3f134bed36006864bcea7381179d67619eeab6eb932815e3feb91e45fc492b3a89 SHA512 98444689c07da3ce9937675b45607ea88fc5a10c65051746cd821650788ec21cbc836a043a486de51813b85d836e255bb3a64a62252808dfe93310e6e169fdb1
diff --git a/net-proxy/ufdbguard/files/ufdb.confd b/net-proxy/ufdbguard/files/ufdb.confd
deleted file mode 100644 (file)
index 08c7e5f..0000000
+++ /dev/null
@@ -1,20 +0,0 @@
-# -*- sh -*-
-
-# Tables to re-generate when starting or reloading ufdbguard
-UFDB_GT="alwaysallow alwaysdeny"
-
-# Options passed to ufdbGenTable when generating the tables listed in
-# UFDB_GT
-GENTABLE_OPTIONS="-W"
-
-# User under which to run ufdbguard; it should be the same as the
-# proxy server you're using, so by default it is squid.
-UFDB_USER="squid"
-
-# Options to pass to ufdbguardd; see /usr/libexec/ufdbguard/ufdbguardd
-# -h for a brief list.
-UFDB_OPTS=""
-
-# Options used by the modified ufdbUpdate script in Gentoo
-DOWNLOAD_USER=""
-DOWNLOAD_PASSWORD=""
diff --git a/net-proxy/ufdbguard/files/ufdb.initd b/net-proxy/ufdbguard/files/ufdb.initd
deleted file mode 100644 (file)
index e55c0e7..0000000
+++ /dev/null
@@ -1,82 +0,0 @@
-#!/sbin/openrc-run
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-# reconfig is what the upstream documentation suggests, so let's
-# provide it for compatibility.
-extra_started_commands="reload reconfig"
-
-depend() {
-       need net
-       before squid
-       use logger
-}
-
-get_config() {
-       awk '$1 == "'$1'" { print $2 }' "/etc/ufdbGuard.conf"
-}
-
-gentables() {
-       local dbhome=$(get_config dbhome)
-
-       for gt in ${UFDB_GT} ; do
-               [ -f "${dbhome}/${gt}/domains" ] || continue
-
-               urls=
-               [ -f "${dbhome}/${gt}/urls" ] && urls="${dbhome}/${gt}/urls"
-
-               ebegin "Generating domainlist ${gt}"
-               ufdbGenTable ${GENTABLE_OPTIONS} -t "${gt}" -d "${dbhome}/${gt}/domains" ${urls:+-u "${urls}"}
-               eend $?
-       done
-}
-
-start() {
-       gentables
-
-    local logdir=$(get_config logdir)
-
-       if [ ! -d "${logdir}" ] ; then
-               mkdir -p ${logdir}
-               chown -R ${UFDB_USER} ${logdir}
-       fi
-
-       if [ ! -d /var/run/ufdbguardd ] ; then
-               mkdir -p /var/run/ufdbguard
-               chown -R ${UFDB_USER} /var/run/ufdbguard
-       fi
-
-       ebegin "Starting ufdbGuard"
-       start-stop-daemon --start \
-               --user ${UFDB_USER} \
-               --wait 1500 \
-               --exec /usr/libexec/ufdbguard/ufdbguardd \
-               --pidfile /var/run/ufdbguard/ufdbguardd.pid -- \
-               -c /etc/ufdbGuard.conf ${UFDB_OPTS}
-       eend $? "Failed to start ufdbGuard"
-}
-
-stop() {
-       ebegin "Stopping ufdbGuard"
-       start-stop-daemon --stop \
-               --exec /usr/libexec/ufdbguard/ufdbguardd \
-               --pidfile /var/run/ufdbguard/ufdbguardd.pid
-       eend $? "Failed to stop ufdbGuard"
-}
-
-reload() {
-       if ! [ -f /var/run/ufdbguard/ufdbguardd.pid ]; then
-               eerror "Unable to find PID file for ufdbguardd, was it just started?"
-               return 1
-       fi
-
-       gentables
-
-       ebegin "Reloading ufdbGuard"
-       kill -HUP "$(cat /var/run/ufdbguard/ufdbguardd.pid)"
-       eend $? "Failed to reload ufdbGuard"
-}
-
-reconfig() {
-       reload
-}
diff --git a/net-proxy/ufdbguard/files/ufdb.initd.2 b/net-proxy/ufdbguard/files/ufdb.initd.2
deleted file mode 100644 (file)
index 44a7f59..0000000
+++ /dev/null
@@ -1,67 +0,0 @@
-#!/sbin/openrc-run
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-# reconfig is what the upstream documentation suggests, so let's
-# provide it for compatibility.
-extra_started_commands="reload reconfig"
-
-: ${configfile:=/etc/ufdbGuard.conf}
-
-pidfile=/var/run/ufdbguard/ufdbguardd.pid
-command=/usr/libexec/ufdbguard/ufdbguardd
-command_arguments="-c ${configfile} ${FUDB_OPTS}"
-
-start_stop_daemon_args="--user ${UFDB_USER} --wait 1500"
-
-name="ufdbGuard Daemon"
-
-depend() {
-       need localmount
-       before squid
-       use logger
-}
-
-get_config() {
-       # Okay this sounds silly, but it is important because the settings
-       # in ufdbGuard are quoted, so this unquotes them.
-       eval echo $(awk '$1 == "'$1'" { print $2 }' "${configfile}")
-}
-
-gentables() {
-       local dbhome=$(get_config dbhome)
-
-       for gt in ${UFDB_GT} ; do
-               [ -f "${dbhome}/${gt}/domains" ] || continue
-
-               urls=
-               [ -f "${dbhome}/${gt}/urls" ] && urls="${dbhome}/${gt}/urls"
-
-               ebegin "Generating domainlist ${gt}"
-               ufdbGenTable ${GENTABLE_OPTIONS} -t "${gt}" -d "${dbhome}/${gt}/domains" ${urls:+-u "${urls}"}
-               eend $?
-       done
-}
-
-start_pre() {
-       gentables
-
-       checkpath -d -m 0755 -o ${UFDB_USER} $(get_config logdir) "$(dirname "${pidfile}")"
-}
-
-reload() {
-       if ! [ -f ${pidfile} ]; then
-               eerror "Unable to find PID file for ufdbguardd, was it just started?"
-               return 1
-       fi
-
-       gentables
-
-       ebegin "Reloading ufdbGuard"
-       kill -HUP "$(cat ${pidfile})"
-       eend $? "Failed to reload ufdbGuard"
-}
-
-reconfig() {
-       reload
-}
diff --git a/net-proxy/ufdbguard/files/ufdbUpdate.cron b/net-proxy/ufdbguard/files/ufdbUpdate.cron
deleted file mode 100644 (file)
index f914764..0000000
+++ /dev/null
@@ -1,13 +0,0 @@
-#!/bin/sh
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-# cron.daily file to update the ufdb database
-
-# Avoid doing anything if no download user is set in the configuration
-# file
-( . /etc/conf.d/ufdb ; [ -z "${DOWNLOAD_USER}" ]; ) && exit
-
-/usr/sbin/ufdbUpdate
-
-/etc/init.d/squid rotate
diff --git a/net-proxy/ufdbguard/files/ufdbguard-1.24-gentoo.patch b/net-proxy/ufdbguard/files/ufdbguard-1.24-gentoo.patch
deleted file mode 100644 (file)
index 63da981..0000000
+++ /dev/null
@@ -1,13 +0,0 @@
-Index: ufdbGuard-1.24/src/ufdbUpdate.in
-===================================================================
---- ufdbGuard-1.24.orig/src/ufdbUpdate.in
-+++ ufdbGuard-1.24/src/ufdbUpdate.in
-@@ -39,6 +39,8 @@ WGET_COMMAND="@WGET@"
- NOTIFY_UFDBGUARDD="yes"                 # send HUP signal to ufdbguardd
- SYSLOG_FACILITY="local6"                # errors/warnings in system log have this facility name
-+source /etc/conf.d/ufdb
-+
- # end of user settings.
- # DO NOT EDIT ANYTHING BELOW THIS LINE.  ########################################
diff --git a/net-proxy/ufdbguard/metadata.xml b/net-proxy/ufdbguard/metadata.xml
deleted file mode 100644 (file)
index 3914a0f..0000000
+++ /dev/null
@@ -1,22 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
-  <longdescription>
-    The fastest URL filter with 25,000 URL verifications/sec to filter
-    unwanted web content. ufdbGuard is a redirector for the Squid
-    internet proxy.
-  </longdescription>
-  <use>
-    <flag name="httpd">
-      Build, install and start the provided mini-http daemon with the
-      redirect CGI integrated. Since there is no way to tell ufdbguard
-      to not start it, this is a build-time option.
-    </flag>
-    <flag name="doc">
-      Download and install the ufdbguard reference manual in PDF.
-    </flag>
-  </use>
-  <upstream>
-    <remote-id type="sourceforge">ufdbguard</remote-id>
-  </upstream>
-</pkgmetadata>
diff --git a/net-proxy/ufdbguard/ufdbguard-1.32.4.ebuild b/net-proxy/ufdbguard/ufdbguard-1.32.4.ebuild
deleted file mode 100644 (file)
index 49efe94..0000000
+++ /dev/null
@@ -1,126 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit eutils flag-o-matic user
-
-MY_P="ufdbGuard-${PV}"
-
-DESCRIPTION="ufdbGuard is a redirector for the Squid internet proxy"
-HOMEPAGE="http://www.urlfilterdb.com/en/products/ufdbguard.html"
-SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz
-       doc? ( mirror://sourceforge/${PN}/${PV/\.?/}/ReferenceManual.pdf -> ${P}-manual.pdf )"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="doc +httpd"
-
-COMMON_DEPEND="
-       app-arch/bzip2
-       dev-libs/openssl:0=
-       net-misc/wget
-"
-DEPEND="${COMMON_DEPEND}
-       sys-devel/bison
-       sys-devel/flex
-"
-RDEPEND="${COMMON_DEPEND}
-       sys-apps/openrc
-"
-
-DOCS=( CHANGELOG README src/sampleufdbGuard.conf )
-
-PATCHES=( "${FILESDIR}"/${PN}-1.24-gentoo.patch )
-
-S="${WORKDIR}/${MY_P}"
-
-pkg_setup() {
-       enewgroup squid
-       enewuser squid -1 -1 /var/cache/squid squid
-}
-
-src_configure() {
-       # better safe than sorry, the code has a number of possible
-       # breakage, and at least one certain breakage.
-       append-flags -fno-strict-aliasing
-
-       econf \
-               --with-ufdb-user=squid \
-               --with-ufdb-config="${EPREFIX}"/etc \
-               --with-ufdb-bindir="${EPREFIX}"/usr/libexec/ufdbguard \
-               --with-ufdb-logdir="${EPREFIX}"/var/log/ufdbguard \
-               --with-ufdb-dbhome="${EPREFIX}"/usr/share/ufdbguard/blacklists \
-               --with-ufdb-images_dir="${EPREFIX}"/usr/share/ufdbguard/images
-}
-
-src_install() {
-       einstalldocs
-       doman doc/*.1
-
-       dobin src/ufdbAnalyse src/ufdbGenTable src/ufdbGrab \
-               src/ufdbConvertDB
-       dosbin src/ufdbUpdate
-
-       exeinto /usr/libexec/ufdbguard
-       doexe src/mtserver/ufdbguardd src/mtserver/ufdbgclient
-
-       if use httpd; then
-               exeinto /usr/libexec/ufdbguard
-               doexe src/ufdbhttpd
-       fi
-
-       keepdir /usr/share/ufdbguard/blacklists
-
-       insinto /etc
-       doins src/ufdbGuard.conf
-
-       insinto /usr/share/ufdbguard/images
-       doins -r src/images/.
-
-       newconfd "${FILESDIR}"/ufdb.confd ufdb
-       newinitd "${FILESDIR}"/ufdb.initd.2 ufdb
-
-       exeinto /etc/cron.daily
-       newexe "${FILESDIR}"/ufdbUpdate.cron ufdbUpdate
-
-       use doc && newdoc "${DISTDIR}"/${P}-manual.pdf ReferenceManual.pdf
-}
-
-pkg_postinst() {
-       elog "The default location for the blacklist database has been"
-       elog "moved to ${EROOT%/}/usr/share/ufdbguard/blacklists."
-       elog ""
-       elog "The configuration file is no longer configurable in the"
-       elog "service file, and now resides at ${EROOT%/}/etc/ufdbGuard.conf ."
-       elog ""
-       elog "The service script has been renamed from ufdbguad to simply"
-       elog "${EROOT%/}/etc/init.d/ufdb, to follow the official documentation, and"
-       elog "it gained a reload option with a reconfig alias."
-       elog ""
-       elog "You can configure the username and password parameters for"
-       elog "ufdbUpdate, to fetch the blacklist database provided by"
-       elog "URLfilterDB, directly in ${EROOT%/}/etc/conf.d/ufdb without touching"
-       elog "the script itself."
-       elog ""
-       elog "To enable ufdbguard in squid, you should add this to your"
-       elog "squid.conf:"
-       elog ""
-       elog "    url_rewrite_program ${EROOT%/}/usr/libexec/ufdbguard/ufdbgclient -l ${EROOT%/}/var/log/ufdbguard"
-       elog "    url_rewrite_children 64"
-       elog ""
-       if ! use httpd; then
-               elog "You chose to not install the lightweight http daemon that"
-               elog "comes with ufdbguard."
-       else
-               elog "The ufdb service will start both the ufdbguardd daemon and"
-               elog "the ufdbhttpd http daemon to provide a local redirect CGI."
-               elog "If you don't want this to happen, disable the httpd USE flag."
-       fi
-       if use doc; then
-               elog ""
-               elog "The reference manual has been installed as"
-               elog "    ${EROOT%/}/usr/share/doc/${PF}/ReferenceManual.pdf"
-       fi
-}
index 4f2f5f3c2fb4eca3ed578e00fab4d0a686f587f2..244c74f9bc051f5efe42f4d69bf0a1af6a7db49d 100644 (file)
@@ -629,7 +629,6 @@ x11-libs/hippo-canvas
 # net-misc/sslwrap: #674524, last updated upstream in 2000
 # net-misc/stone: #675612, needs new snapshot, current ver is from 2008
 # net-misc/tn5250: #678684, last commits in 2012
-# net-proxy/ufdbguard: #677482, needs bump, current ver is from 2016
 #
 # Removal in 30 days.
 app-crypt/keynote
@@ -656,7 +655,6 @@ net-mail/uw-mailutils
 net-misc/sslwrap
 net-misc/stone
 net-misc/tn5250
-net-proxy/ufdbguard
 
 # Miroslav Šulc <fordfrog@gentoo.org> (19 Mar 2019)
 # Depends on >=virtual/{jdk,jre}-11 which is masked