Version bump. Removed older releases.
authorLukasz Strzygowski <lucass@gentoo.org>
Fri, 5 Jan 2007 18:57:01 +0000 (18:57 +0000)
committerLukasz Strzygowski <lucass@gentoo.org>
Fri, 5 Jan 2007 18:57:01 +0000 (18:57 +0000)
Package-Manager: portage-2.1.2_rc4

dev-python/urwid/ChangeLog
dev-python/urwid/files/digest-urwid-0.9.7.2 [new file with mode: 0644]
dev-python/urwid/urwid-0.9.7.2.ebuild [new file with mode: 0644]

index 8c75712165b591e6bfa22e9e6883ba05dfa83d8a..6179de89ece9933f23311ad01e59f7ddfc475b32 100644 (file)
@@ -1,6 +1,12 @@
 # ChangeLog for dev-python/urwid
-# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/urwid/ChangeLog,v 1.17 2006/10/04 19:43:51 lucass Exp $
+# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/urwid/ChangeLog,v 1.18 2007/01/05 18:57:01 lucass Exp $
+
+*urwid-0.9.7.2 (05 Jan 2007)
+
+  05 Jan 2007; Lukasz Strzygowski <lucass@gentoo.org> -urwid-0.9.4.ebuild,
+  -urwid-0.9.5.ebuild, -urwid-0.9.6.ebuild, +urwid-0.9.7.2.ebuild:
+  Version bump. Removed older releases.
 
 *urwid-0.9.7.1 (04 Oct 2006)
 
diff --git a/dev-python/urwid/files/digest-urwid-0.9.7.2 b/dev-python/urwid/files/digest-urwid-0.9.7.2
new file mode 100644 (file)
index 0000000..e2f6cea
--- /dev/null
@@ -0,0 +1,3 @@
+MD5 6e9a64c902389e3ddcfd28f876a383d3 urwid-0.9.7.2.tar.gz 154066
+RMD160 caffac1778b6b4ba6b69c9b83e66556fed91a007 urwid-0.9.7.2.tar.gz 154066
+SHA256 834cbcd01778789a74cbd7f5ac4b1e61dfd25bb760ea89c02448259e81f33b43 urwid-0.9.7.2.tar.gz 154066
diff --git a/dev-python/urwid/urwid-0.9.7.2.ebuild b/dev-python/urwid/urwid-0.9.7.2.ebuild
new file mode 100644 (file)
index 0000000..3ce50c9
--- /dev/null
@@ -0,0 +1,37 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/urwid/urwid-0.9.7.2.ebuild,v 1.1 2007/01/05 18:57:01 lucass Exp $
+
+inherit distutils eutils
+
+DESCRIPTION="Urwid is a curses-based user interface library for Python."
+HOMEPAGE="http://excess.org/urwid/"
+SRC_URI="http://excess.org/urwid/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~ppc ~sparc ~x86"
+
+IUSE="examples"
+DEPEND="virtual/python"
+
+src_unpack() {
+       unpack ${A}
+       cd "${S}"
+       epatch "${FILESDIR}/${PN}-0.9.6-nosetuptools.diff"
+}
+
+src_test() {
+       ${python} test_urwid.py || die "unit tests failed"
+}
+
+src_install() {
+       distutils_src_install
+
+       dohtml tutorial.html reference.html
+       if use examples; then
+               insinto /usr/share/doc/${PF}/examples
+               doins bigtext.py browse.py calc.py dialog.py edit.py
+               doins fib.py graph.py input_test.py tour.py
+       fi
+}