dev-libs/efl: -fno-common temporary fix
authorJoonas Niilola <juippis@gentoo.org>
Mon, 4 May 2020 16:14:22 +0000 (19:14 +0300)
committerJoonas Niilola <juippis@gentoo.org>
Mon, 4 May 2020 16:24:47 +0000 (19:24 +0300)
Closes: https://bugs.gentoo.org/707258
Signed-off-by: Joonas Niilola <juippis@gentoo.org>
dev-libs/efl/efl-1.23.3.ebuild

index 3a1dc1e3db54db14bcb773f821a500ca37b38982..65c7e876c0843152652792a7c9df63909ecfc089 100644 (file)
@@ -3,7 +3,7 @@
 
 EAPI=7
 
-inherit meson xdg-utils
+inherit flag-o-matic meson xdg-utils
 
 DESCRIPTION="Enlightenment Foundation Libraries all-in-one package"
 HOMEPAGE="https://www.enlightenment.org"
@@ -263,6 +263,8 @@ src_configure() {
        fi
        emesonargs+=( -D lua-interpreter="${luaChoice}" )
 
+       append-cflags -fcommon
+
        meson_src_configure
 }