app-backup/sarab: Port to EAPI 6
authorDavid Seifert <soap@gentoo.org>
Thu, 28 Dec 2017 13:58:41 +0000 (14:58 +0100)
committerDavid Seifert <soap@gentoo.org>
Thu, 28 Dec 2017 15:06:45 +0000 (16:06 +0100)
Package-Manager: Portage-2.3.19, Repoman-2.3.6

app-backup/sarab/files/README.gentoo [moved from app-backup/sarab/files/README.Gentoo with 100% similarity]
app-backup/sarab/sarab-1.0.0.ebuild

index 6c426c2c9cbdcb2eec2ff32485f01bf5b8f92a64..896edbcc95c876de5e4911eb84d999b377a3acd5 100644 (file)
@@ -1,38 +1,41 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 
-inherit eutils
+EAPI=6
+
+inherit readme.gentoo-r1
 
 DESCRIPTION="SaraB is a powerful and automated backup scheduling system based on DAR"
 HOMEPAGE="http://sarab.sourceforge.net/"
 SRC_URI="mirror://sourceforge/sarab/${P}.tar.gz"
+
 LICENSE="GPL-2"
 SLOT="0"
 KEYWORDS="amd64 x86"
 IUSE=""
 
 DEPEND=""
-RDEPEND="app-backup/dar
+RDEPEND="
+       app-backup/dar
        virtual/mailx"
 
-src_unpack() {
-       cd "${S}"
-       unpack ${A}
-
-       epatch "${FILESDIR}"/${PV}-better-defaults-gentoo.patch
-}
+PATCHES=( "${FILESDIR}"/${PV}-better-defaults-gentoo.patch )
 
 src_install() {
        dobin sarab.sh
+       einstalldocs
+
        insinto /etc/sarab
-       doins -r etc/*
+       doins -r etc/.
        # sarab.conf could contain passphrase information
        fperms 600 /etc/sarab/sarab.conf
-       dodoc CHANGELOG FAQ INSTALL README
-       dodoc "${FILESDIR}"/README.Gentoo
+
+       readme.gentoo_create_doc
 }
 
-pkg_postinstl() {
+pkg_postinst() {
+       readme.gentoo_print_elog
+
        ewarn "The configuration format for DAR encryption has changed in Sarab 0.2.4."
        ewarn "Replace DAR_ENCRYPTION_OPTIONS=\"--key blowfish:PASSPHRASE\""
        ewarn "by SARAB_KEY=\"blowfish:PASSPHRASE\" in /etc/sarab/sarab.conf"